From: Daniel Lezcano <daniel.lezcano@linaro.org>
To: Thomas Gleixner <tglx@linutronix.de>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Bai Ping <ping.bai@nxp.com>,
Bartosz Golaszewski <bgolaszewski@baylibre.com>,
Dmitry Osipenko <digetx@gmail.com>,
Linus Walleij <linus.walleij@linaro.org>,
Marek Szyprowski <m.szyprowski@samsung.com>,
Masahiro Yamada <yamada.masahiro@socionext.com>,
Neil Armstrong <narmstrong@baylibre.com>
Subject: [GIT PULL] timer drivers for v5.4
Date: Wed, 26 Jun 2019 16:43:32 +0200 [thread overview]
Message-ID: <adba7d03-e9bd-9542-60bc-0f2d4874a40e@linaro.org> (raw)
Hi Thomas,
The following changes since commit d48e0cd8fcaf314175a15d3076d7a1e71bd4e628:
timekeeping: Boot should be boottime for coarse ns accessor
(2019-06-25 08:54:51 +0200)
are available in the Git repository at:
https://git.linaro.org/people/daniel.lezcano/linux.git tags/timers-v5.4
for you to fetch changes up to a2e1bb44a35d84bc760a0553fb1e36fecc25a623:
Merge branch 'timers/drivers/davinci' into timers/drivers/next
(2019-06-26 16:24:33 +0200)
----------------------------------------------------------------
This version contains the following changes:
- Rewrite of the davinci timer resulting to an immutable branch to be
shared with davinci platform specific tree (Bartosz Golaszewski)
- Cleanup and improvements of the tegra timer (Dmitry Osipenko)
- Add new nxp system counter timer (Bai Ping)
- Increase priority for exynos_mct to take over the initialization
of the IP the arch ARM timer depends on (Marek Szyprowski)
- Change macro use _BITUL() by BIT() on arc timer (Masahiro Yamada)
- Implement the delay timer on ixp4xx (Linus Walleij)
- Add the SPDX license identifier on the meson timer (Neil Armstrong)
----------------------------------------------------------------
Andrew Murray (1):
clocksource/drivers/arm_arch_timer: Extract elf_hwcap use to
arch-helper
Bai Ping (1):
clocksource/drivers/sysctr: Add nxp system counter timer driver
support
Bartosz Golaszewski (2):
clocksource/drivers/davinci: Add support for clockevents
clocksource/drivers/davinci: Add support for clocksource
Daniel Lezcano (1):
Merge branch 'timers/drivers/davinci' into timers/drivers/next
Dmitry Osipenko (17):
clocksource/drivers/tegra: Support per-CPU timers on all Tegra's
clocksource/drivers/tegra: Unify timer code
clocksource/drivers/tegra: Reset hardware state on init
clocksource/drivers/tegra: Replace readl/writel with relaxed versions
clocksource/drivers/tegra: Release all IRQ's on request_irq() error
clocksource/drivers/tegra: Minor code clean up
clocksource/drivers/tegra: Support COMPILE_TEST universally
clocksource/drivers/tegra: Lower clocksource rating for some Tegra's
clocksource/drivers/tegra: Rename timer-tegra20.c to timer-tegra.c
clocksource/drivers/tegra: Restore timer rate on Tegra210
clocksource/drivers/tegra: Remove duplicated use of per_cpu_ptr
clocksource/drivers/tegra: Set and use timer's period
clocksource/drivers/tegra: Drop unneeded typecasting in one place
clocksource/drivers/tegra: Add verbose definition for 1MHz constant
clocksource/drivers/tegra: Restore base address before cleanup
clocksource/drivers/tegra: Cycles can't be 0
clocksource/drivers/tegra: Set up maximum-ticks limit properly
Linus Walleij (1):
clocksource/drivers/ixp4xx: Implement delay timer
Marek Szyprowski (1):
clocksource/drivers/exynos_mct: Increase priority over ARM arch timer
Masahiro Yamada (1):
clocksource/drivers/arc_timer: Use BIT() instead of _BITUL()
Neil Armstrong (1):
clocksource/drivers/timer-meson6: Update with SPDX Licence identifier
.../devicetree/bindings/timer/nxp,sysctr-timer.txt | 25 ++
arch/arm/include/asm/arch_timer.h | 10 +
arch/arm64/include/asm/arch_timer.h | 13 +
drivers/clocksource/Kconfig | 14 +-
drivers/clocksource/Makefile | 4 +-
drivers/clocksource/arc_timer.c | 3 +-
drivers/clocksource/arm_arch_timer.c | 15 +-
drivers/clocksource/exynos_mct.c | 4 +-
drivers/clocksource/timer-davinci.c | 369 ++++++++++++++++++
drivers/clocksource/timer-imx-sysctr.c | 145 +++++++
drivers/clocksource/timer-ixp4xx.c | 16 +-
drivers/clocksource/timer-meson6.c | 5 +-
drivers/clocksource/timer-tegra.c | 416
+++++++++++++++++++++
drivers/clocksource/timer-tegra20.c | 379
-------------------
include/clocksource/timer-davinci.h | 44 +++
include/linux/cpuhotplug.h | 2 +-
16 files changed, 1060 insertions(+), 404 deletions(-)
create mode 100644
Documentation/devicetree/bindings/timer/nxp,sysctr-timer.txt
create mode 100644 drivers/clocksource/timer-davinci.c
create mode 100644 drivers/clocksource/timer-imx-sysctr.c
create mode 100644 drivers/clocksource/timer-tegra.c
delete mode 100644 drivers/clocksource/timer-tegra20.c
create mode 100644 include/clocksource/timer-davinci.h
--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs
Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog
next reply other threads:[~2019-06-26 14:43 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-06-26 14:43 Daniel Lezcano [this message]
2019-06-26 14:46 ` [PATCH 01/25] clocksource/drivers/timer-meson6: Update with SPDX Licence identifier Daniel Lezcano
2019-06-26 14:46 ` [PATCH 02/25] clocksource/drivers/ixp4xx: Implement delay timer Daniel Lezcano
2019-06-26 14:46 ` [PATCH 03/25] clocksource/drivers/arc_timer: Use BIT() instead of _BITUL() Daniel Lezcano
2019-06-26 14:46 ` [PATCH 04/25] clocksource/drivers/exynos_mct: Increase priority over ARM arch timer Daniel Lezcano
2019-06-26 14:46 ` [PATCH 05/25] clocksource/drivers/tegra: Support per-CPU timers on all Tegra's Daniel Lezcano
2019-06-26 14:46 ` [PATCH 06/25] clocksource/drivers/tegra: Unify timer code Daniel Lezcano
2019-06-26 14:46 ` [PATCH 07/25] clocksource/drivers/tegra: Reset hardware state on init Daniel Lezcano
2019-06-26 14:46 ` [PATCH 08/25] clocksource/drivers/tegra: Replace readl/writel with relaxed versions Daniel Lezcano
2019-06-26 14:46 ` [PATCH 09/25] clocksource/drivers/tegra: Release all IRQ's on request_irq() error Daniel Lezcano
2019-06-26 14:46 ` [PATCH 10/25] clocksource/drivers/tegra: Minor code clean up Daniel Lezcano
2019-06-26 14:46 ` [PATCH 11/25] clocksource/drivers/tegra: Support COMPILE_TEST universally Daniel Lezcano
2019-06-26 14:46 ` [PATCH 12/25] clocksource/drivers/tegra: Lower clocksource rating for some Tegra's Daniel Lezcano
2019-06-26 14:46 ` [PATCH 13/25] clocksource/drivers/tegra: Rename timer-tegra20.c to timer-tegra.c Daniel Lezcano
2019-06-26 14:46 ` [PATCH 14/25] clocksource/drivers/sysctr: Add nxp system counter timer driver support Daniel Lezcano
2019-06-26 14:46 ` [PATCH 15/25] clocksource/drivers/arm_arch_timer: Extract elf_hwcap use to arch-helper Daniel Lezcano
2019-06-26 14:46 ` [PATCH 16/25] clocksource/drivers/tegra: Restore timer rate on Tegra210 Daniel Lezcano
2019-06-26 14:46 ` [PATCH 17/25] clocksource/drivers/tegra: Remove duplicated use of per_cpu_ptr Daniel Lezcano
2019-06-26 14:46 ` [PATCH 18/25] clocksource/drivers/tegra: Set and use timer's period Daniel Lezcano
2019-06-26 14:46 ` [PATCH 19/25] clocksource/drivers/tegra: Drop unneeded typecasting in one place Daniel Lezcano
2019-06-26 14:46 ` [PATCH 20/25] clocksource/drivers/tegra: Add verbose definition for 1MHz constant Daniel Lezcano
2019-06-26 14:46 ` [PATCH 21/25] clocksource/drivers/tegra: Restore base address before cleanup Daniel Lezcano
2019-06-26 14:46 ` [PATCH 22/25] clocksource/drivers/tegra: Cycles can't be 0 Daniel Lezcano
2019-06-26 14:46 ` [PATCH 23/25] clocksource/drivers/tegra: Set up maximum-ticks limit properly Daniel Lezcano
2019-06-26 14:46 ` [PATCH 24/25] clocksource/drivers/davinci: Add support for clockevents Daniel Lezcano
2019-06-26 14:46 ` [PATCH 25/25] clocksource/drivers/davinci: Add support for clocksource Daniel Lezcano
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=adba7d03-e9bd-9542-60bc-0f2d4874a40e@linaro.org \
--to=daniel.lezcano@linaro.org \
--cc=bgolaszewski@baylibre.com \
--cc=digetx@gmail.com \
--cc=linus.walleij@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=m.szyprowski@samsung.com \
--cc=narmstrong@baylibre.com \
--cc=ping.bai@nxp.com \
--cc=tglx@linutronix.de \
--cc=yamada.masahiro@socionext.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®