From: Thomas Gleixner <tglx@linutronix.de>
To: Baolin Wang <baolin.wang@linaro.org>
Cc: Alessandro Zummo <a.zummo@towertech.it>,
Alexandre Belloni <alexandre.belloni@free-electrons.com>,
Steven Rostedt <rostedt@goodmis.org>,
Ingo Molnar <mingo@redhat.com>,
John Stultz <john.stultz@linaro.org>,
Mark Brown <broonie@kernel.org>,
LKML <linux-kernel@vger.kernel.org>,
rtc-linux@googlegroups.com
Subject: Re: [PATCH 2/2] time: alarmtimer: Add the trcepoints for alarmtimer
Date: Wed, 21 Sep 2016 09:26:20 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.20.1609210919390.5573@nanos> (raw)
In-Reply-To: <CAMz4kuLYkyZzs33VKmo9B3JxTFFDYun7AHBYUUmHz=424yiq8g@mail.gmail.com>
On Wed, 21 Sep 2016, Baolin Wang wrote:
> On 21 September 2016 at 06:27, Thomas Gleixner <tglx@linutronix.de> wrote:
> >> + TP_fast_assign(
> >> + __entry->second = rtc_time->tm_sec;
> >> + __entry->minute = rtc_time->tm_min;
> >> + __entry->hour = rtc_time->tm_hour;
> >> + __entry->day = rtc_time->tm_mday;
> >> + __entry->mon = rtc_time->tm_mon;
> >> + __entry->year = rtc_time->tm_year;
> >> + __entry->alarm_type = flag;
> >
> > What's the value of storing the alarm time in RTC format?
>
> As suggested by Steven, change the type of RTC value to save trace buffer.
A single u64 does not take more storage space than this and it's a single
store.
> > 2) You store the expiry time again in RTC format. Store the information in
> > a plain u64 and be done with it.
>
> But I still think the RTC format is more readable for debugging alarm timer.
That's what post processing is for.
> > What's the point of this conditional? Avoiding rtc_ktime_to_tm() ? Oh well...
> >
> >> + tm_set = rtc_ktime_to_tm(now);
> >> + trace_alarmtimer_suspend(&tm_set, type);
> >
> > "now" is CLOCK_REALTIME based. You store the type of the alarm timer which
> > is the first to expire and therefor is the one setting the RTC value, but
> > we don't know which timer it is. Useful - NOT!
>
> We can know the timer by comparing the expire time.
Please make it similar to the timer/hrtimer tracing so people can reuse
their postprocessing scripts with minimial tweaks.
Thanks,
tglx
next prev parent reply other threads:[~2016-09-21 7:28 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-09-18 6:03 [PATCH 1/2] rtc: Add some dummy static inline functions Baolin Wang
2016-09-18 6:03 ` [PATCH 2/2] time: alarmtimer: Add the trcepoints for alarmtimer Baolin Wang
2016-09-20 22:27 ` Thomas Gleixner
2016-09-21 3:25 ` Baolin Wang
2016-09-21 7:26 ` Thomas Gleixner [this message]
2016-09-21 10:58 ` Baolin Wang
2016-09-21 12:33 ` Steven Rostedt
2016-09-21 12:36 ` Thomas Gleixner
2016-09-21 13:32 ` Steven Rostedt
2016-09-20 21:36 ` [PATCH 1/2] rtc: Add some dummy static inline functions Thomas Gleixner
2016-09-21 2:01 ` Baolin Wang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.20.1609210919390.5573@nanos \
--to=tglx@linutronix.de \
--cc=a.zummo@towertech.it \
--cc=alexandre.belloni@free-electrons.com \
--cc=baolin.wang@linaro.org \
--cc=broonie@kernel.org \
--cc=john.stultz@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rostedt@goodmis.org \
--cc=rtc-linux@googlegroups.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®