From: Linus Torvalds <torvalds@linux-foundation.org>
To: Ingo Molnar <mingo@elte.hu>
Cc: Jens Axboe <jens.axboe@oracle.com>,
linux-arch@vger.kernel.org,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
npiggin@suse.de, peterz@infradead.org, sam@ravnborg.org
Subject: Re: [PATCH 2/11] x86: convert to generic helpers for IPI function calls
Date: Tue, 22 Apr 2008 12:50:30 -0700 (PDT) [thread overview]
Message-ID: <alpine.LFD.1.10.0804221244350.2779@woody.linux-foundation.org> (raw)
In-Reply-To: <20080422192601.GB12588@elte.hu>
On Tue, 22 Apr 2008, Ingo Molnar wrote:
>
> ok. In which case the reschedule vector could be consolidated into that
> as well (it's just a special single-CPU call). Then there would be no
> new vector allocations needed at all, just the renaming of
> RESCHEDULE_VECTOR to something more generic.
Yes.
Btw, don't get me wrong - I'm not against multiple vectors per se. I just
wonder if there is any real reason for the code duplication.
And there certainly *can* be tons of valid reasons for it. For example,
some of the LAPIC can only have something like two pending interrupts per
vector, and after that IPI's would get lost.
However, since the queuing is actually done with the data structures, I
don't think it matters for the IPI's - they don't need any hardware
queuing at all, afaik, since even if two IPI's would be merged into one
(due to lack of hw queueing) the IPI handling code still has its list of
events, so it doesn't matter.
And performance can be a valid reason ("too expensive to check the shared
queue if we only have per-cpu events"), although I$ issues can cause that
argument to go both ways.
I was also wondering whether there are deadlock issues (ie one type of IPI
has to complete even if a lock is held for the other type).
So I don't dislike the patch per se, I just wanted to understand _why_ the
IPI's wanted separate vectors.
Linus
next prev parent reply other threads:[~2008-04-22 19:51 UTC|newest]
Thread overview: 62+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-04-22 18:50 [PATCH 0/11] Generic smp_call_function() #2 Jens Axboe
2008-04-22 18:50 ` [PATCH 1/11] Add generic helpers for arch IPI function calls Jens Axboe
2008-04-22 20:17 ` Peter Zijlstra
2008-04-23 6:07 ` Jens Axboe
2008-04-23 6:32 ` Peter Zijlstra
2008-04-23 7:49 ` Jens Axboe
2008-04-23 7:50 ` Peter Zijlstra
2008-04-24 22:01 ` Russell King
2008-04-25 7:18 ` Jens Axboe
2008-04-26 6:28 ` Jeremy Fitzhardinge
2008-04-28 7:38 ` Jes Sorensen
2008-04-26 6:11 ` Andrew Morton
2008-04-26 14:13 ` James Bottomley
2008-04-27 0:58 ` Paul E. McKenney
2008-04-27 10:36 ` Jens Axboe
2008-04-27 10:30 ` Jens Axboe
2008-04-28 14:25 ` David Howells
2008-04-28 14:43 ` James Bottomley
2008-04-22 18:50 ` [PATCH 2/11] x86: convert to generic helpers for " Jens Axboe
2008-04-22 19:03 ` Linus Torvalds
2008-04-22 19:12 ` Ingo Molnar
2008-04-22 19:22 ` Linus Torvalds
2008-04-22 19:26 ` Ingo Molnar
2008-04-22 19:50 ` Linus Torvalds [this message]
2008-04-23 1:11 ` Nick Piggin
2008-04-23 1:22 ` Linus Torvalds
2008-04-23 1:36 ` Nick Piggin
2008-04-23 7:08 ` Jens Axboe
2008-04-23 12:54 ` Jens Axboe
2008-04-26 6:44 ` Jeremy Fitzhardinge
2008-04-27 10:23 ` Jens Axboe
2008-04-27 15:18 ` Jeremy Fitzhardinge
2008-04-22 18:50 ` [PATCH 3/11] powerpc: " Jens Axboe
2008-04-22 18:50 ` [PATCH 4/11] ia64: " Jens Axboe
2008-04-22 18:50 ` [PATCH 5/11] alpha: " Jens Axboe
2008-04-22 18:50 ` [PATCH 6/11] arm: " Jens Axboe
2008-04-22 18:50 ` [PATCH 7/11] m32r: " Jens Axboe
2008-04-22 18:50 ` [PATCH 8/11] mips: " Jens Axboe
2008-04-22 23:18 ` Ralf Baechle
2008-04-23 7:18 ` Jens Axboe
2008-04-22 18:50 ` [PATCH 9/11] parisc: " Jens Axboe
2008-04-22 18:50 ` [PATCH 10/11] sh: " Jens Axboe
2008-04-25 8:56 ` Paul Mundt
2008-04-25 9:16 ` Jens Axboe
2008-04-22 18:50 ` [PATCH 11/11] s390: " Jens Axboe
2008-04-23 7:58 ` Heiko Carstens
2008-04-23 8:11 ` Jens Axboe
2008-04-23 11:21 ` Jens Axboe
2008-04-23 11:47 ` Heiko Carstens
2008-04-23 11:54 ` Jens Axboe
2008-04-23 12:42 ` Martin Schwidefsky
2008-04-23 15:56 ` Rusty Russell
-- strict thread matches above, loose matches on Subject: below --
2008-04-22 7:57 [PATCH 0/11] Generic smp_call_function() and friends Jens Axboe
2008-04-22 7:57 ` [PATCH 2/11] x86: convert to generic helpers for IPI function calls Jens Axboe
2008-04-22 8:38 ` Sam Ravnborg
2008-04-22 8:43 ` Jens Axboe
2008-04-22 11:15 ` Jens Axboe
2008-04-22 8:47 ` Ingo Molnar
2008-04-22 8:48 ` Jacek Luczak
2008-04-22 8:56 ` Jens Axboe
2008-04-22 9:04 ` Jacek Luczak
2008-04-22 8:52 ` Jens Axboe
2008-04-26 8:59 ` Jeremy Fitzhardinge
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LFD.1.10.0804221244350.2779@woody.linux-foundation.org \
--to=torvalds@linux-foundation.org \
--cc=jens.axboe@oracle.com \
--cc=linux-arch@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=npiggin@suse.de \
--cc=peterz@infradead.org \
--cc=sam@ravnborg.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®