From: Andy Shevchenko <andriy.shevchenko@intel.com>
To: Archit Anant <architanant5@gmail.com>
Cc: jic23@kernel.org, dlechner@baylibre.com, andy@kernel.org,
nuno.sa@analog.com, u.kleine-koenig@baylibre.com,
linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5 09/10] iio: adc: ti-ads1015: inline ads1015_set_conv_mode()
Date: Thu, 1 Oct 2026 20:54:20 +0300 [thread overview]
Message-ID: <ar6eTN422AoPkeV6@ashevche-desk.local> (raw)
In-Reply-To: <20260930171204.12863-10-architanant5@gmail.com>
On Wed, Sep 30, 2026 at 10:42:03PM +0530, Archit Anant wrote:
> The ads1015_set_conv_mode() helper function is a single-line wrapper
> around regmap_update_bits().
>
> Since the function is simple and only called during initialization and
> power management state transitions, the wrapper is unnecessary. Remove
> it and inline the regmap_update_bits() logic directly at the call sites
> to improve code readability and traceabilty.
>
> Where applicable, introduce a local 'map' pointer to keep the
> inlined function calls concise.
...
> - ret = regmap_update_bits(data->regmap, ADS1015_CFG_REG,
> + ret = regmap_update_bits(map, ADS1015_CFG_REG,
> ADS1015_CFG_COMP_QUE_MASK,
> ADS1015_CFG_COMP_DISABLE <<
> ADS1015_CFG_COMP_QUE_SHIFT);
The indentation is broken even in the original code.
> static void ads1015_power_down(void *p)
> {
> struct ads1015_data *data = p;
> + struct regmap *map = data->regmap;
> int ret;
>
> - ret = ads1015_set_conv_mode(data, ADS1015_SINGLESHOT);
> + ret = regmap_update_bits(map, ADS1015_CFG_REG,
> + ADS1015_CFG_MOD_MASK,
> + ADS1015_SINGLESHOT << ADS1015_CFG_MOD_SHIFT);
> if (ret)
> dev_warn(regmap_get_device(data->regmap),
At some point (may be even in this patch) it makes sense to switch to use 'map'
in all applicable cases.
> "Failed to power down (%pe)\n", ERR_PTR(ret));
...
> static int ads1015_probe(struct i2c_client *client)
>
> - ret = ads1015_set_conv_mode(data, ADS1015_CONTINUOUS);
> + ret = regmap_update_bits(data->regmap, ADS1015_CFG_REG,
Can you also use 'map' here?
> + ADS1015_CFG_MOD_MASK,
> + ADS1015_CONTINUOUS << ADS1015_CFG_MOD_SHIFT);
> if (ret)
> return ret;
...
> + ret = regmap_update_bits(map, ADS1015_CFG_REG,
> + ADS1015_CFG_MOD_MASK,
This is now perfectly a single line, same for the cases above.
> + ADS1015_CONTINUOUS << ADS1015_CFG_MOD_SHIFT);
> if (!ret)
> data->conv_invalid = true;
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2026-10-01 17:54 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-30 17:11 [PATCH v5 00/10] iio: adc: ti-ads1015: modernize resource management and bitfield logic Archit Anant
2026-09-30 17:11 ` [PATCH v5 01/10] iio: adc: ti-ads1015: use DEFINE_RUNTIME_DEV_PM_OPS() Archit Anant
2026-09-30 17:11 ` [PATCH v5 02/10] iio: adc: ti-ads1015: sort headers alphabetically Archit Anant
2026-10-01 7:08 ` Joshua Crofts
2026-09-30 17:11 ` [PATCH v5 03/10] iio: adc: ti-ads1015: return -ENODATA when match data is missing Archit Anant
2026-10-01 17:47 ` Andy Shevchenko
2026-09-30 17:11 ` [PATCH v5 04/10] iio: adc: ti-ads1015: use local device pointer in probe Archit Anant
2026-09-30 17:11 ` [PATCH v5 05/10] iio: adc: ti-ads1015: use dev_err_probe() for error handling Archit Anant
2026-10-01 7:10 ` Joshua Crofts
2026-09-30 17:12 ` [PATCH v5 06/10] iio: adc: ti-ads1015: drop unneeded < 0 error checks Archit Anant
2026-09-30 17:12 ` [PATCH v5 07/10] iio: adc: ti-ads1015: use devm_mutex_init() Archit Anant
2026-09-30 17:12 ` [PATCH v5 08/10] iio: adc: ti-ads1015: use managed runtime PM setup Archit Anant
2026-09-30 17:12 ` [PATCH v5 09/10] iio: adc: ti-ads1015: inline ads1015_set_conv_mode() Archit Anant
2026-10-01 17:54 ` Andy Shevchenko [this message]
2026-09-30 17:12 ` [PATCH v5 10/10] iio: adc: ti-ads1015: replace custom shift macros with FIELD_PREP/GET Archit Anant
2026-10-01 18:01 ` Andy Shevchenko
2026-10-01 7:12 ` [PATCH v5 00/10] iio: adc: ti-ads1015: modernize resource management and bitfield logic Joshua Crofts
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ar6eTN422AoPkeV6@ashevche-desk.local \
--to=andriy.shevchenko@intel.com \
--cc=andy@kernel.org \
--cc=architanant5@gmail.com \
--cc=dlechner@baylibre.com \
--cc=jic23@kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=nuno.sa@analog.com \
--cc=u.kleine-koenig@baylibre.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®