From: Philipp Hortmann <philipp.g.hortmann@gmail.com>
To: Xingquan Liu <b1n@b1n.io>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/7] staging: vt6655: Rename variable iTDUsed
Date: Tue, 24 Sep 2024 09:29:27 +0200 [thread overview]
Message-ID: <c20e4935-faca-41ef-ab66-09199b38a6d2@gmail.com> (raw)
In-Reply-To: <D4DNIARBI7Q0.13E9XY3QTDIW3@b1n.io>
On 9/23/24 2:09 PM, Xingquan Liu wrote:
> Hi,
>
> I'm a bit confused. Should I rename struct vnt_tx_desc
> *apCurrTD[TYPE_MAXTD];
> to curr_td?
> It looks like 'ap' means array pointer.
Hi Xingquan,
yes I think so as well.
This line shows this:
priv->apCurrTD[0] = &priv->ap_td0_rings[0];
>
> For struct vnt_rx_desc *aRD0Ring;, where 'a' doesn't means array, should
> I rename it to rd0_ring?
>
When the "a" does not belong to hungarian notation it can remain.
The following is just my personal opinion:
You can keep working on this driver and your patches will remain in the
git. But I think I will propose to delete this driver. Reason is that it
supports maximum 54MBit/s and the connection is always weak. Its form
factor is mini PCI that is really old. I use an adapter from mini PCI to
PCI to get it into my Desktop PC. It furthermore is not buyable anymore.
I like to focus on the hardware that is really well useable and on the
market available:
For example:
rtl8712 (r8712u)
Backard Bell: AW-NU120
Thanks for your support.
Bye Philipp
next prev parent reply other threads:[~2024-09-24 7:29 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-09-20 16:20 [PATCH 1/7] staging: vt6655: Rename variable apCurrTD Xingquan Liu
2024-09-20 16:20 ` [PATCH 2/7] staging: vt6655: Rename variable iTDUsed Xingquan Liu
2024-09-21 14:10 ` Philipp Hortmann
2024-09-22 4:46 ` Xingquan Liu
2024-09-23 12:09 ` Xingquan Liu
2024-09-24 7:29 ` Philipp Hortmann [this message]
2024-09-24 13:09 ` Xingquan Liu
2024-09-20 16:20 ` [PATCH 3/7] staging: vt6655: Rename function CARDvSafeResetRx Xingquan Liu
2024-09-20 16:20 ` [PATCH 4/7] staging: vt6655: Rename variable pDesc Xingquan Liu
2024-09-20 16:20 ` [PATCH 5/7] staging: vt6655: Rename variable pCurrRD Xingquan Liu
2024-09-20 16:20 ` [PATCH 6/7] staging: vt6655: Rename variable aRD0Ring Xingquan Liu
2024-09-20 16:20 ` [PATCH 7/7] staging: vt6655: Rename variable aRD1Ring Xingquan Liu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c20e4935-faca-41ef-ab66-09199b38a6d2@gmail.com \
--to=philipp.g.hortmann@gmail.com \
--cc=b1n@b1n.io \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®