From: "Uwe Kleine-König (The Capable Hub)" <u.kleine-koenig@baylibre.com>
To: Arnd Bergmann <arnd@arndb.de>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-kernel@vger.kernel.org
Subject: [PATCH v1 0/2] misc: pch_phub: Two cleanups
Date: Thu, 21 May 2026 12:46:34 +0200 [thread overview]
Message-ID: <cover.1779360001.git.u.kleine-koenig@baylibre.com> (raw)
Hello,
my objective is to convert all pci_device_id assignments to use named
initializer for a further cleanup. See
https://lore.kernel.org/all/20260507074102.2654314-2-u.kleine-koenig@baylibre.com/
for details about that.
While working on the pch_phub driver, I found a few more opportunities
for improvement and the conversion to named initializers is just a side
effect of the 2nd patch.
If a "= 1" was added to the definition of PCH_EG20T in patch #2, there would be
no differences in the generated code. Without that there is a shift in the
magic constants that doesn't change the semantics however.
Best regards
Uwe
Uwe Kleine-König (The Capable Hub) (2):
misc: pch_phub: Drop two unused functions
misc: pch_phub: Introduce an enum for device indentification
drivers/misc/pch_phub.c | 151 +++++-----------------------------------
1 file changed, 18 insertions(+), 133 deletions(-)
base-commit: 254f49634ee16a731174d2ae34bc50bd5f45e731
--
2.47.3
next reply other threads:[~2026-05-21 10:46 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-21 10:46 Uwe Kleine-König (The Capable Hub) [this message]
2026-05-21 10:46 ` [PATCH v1 1/2] misc: pch_phub: Drop two unused functions Uwe Kleine-König (The Capable Hub)
2026-05-21 10:46 ` [PATCH v1 2/2] misc: pch_phub: Introduce an enum for device indentification Uwe Kleine-König (The Capable Hub)
2026-05-24 10:12 ` [PATCH v1 0/2] misc: pch_phub: Two cleanups Uwe Kleine-König (The Capable Hub)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1779360001.git.u.kleine-koenig@baylibre.com \
--to=u.kleine-koenig@baylibre.com \
--cc=arnd@arndb.de \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®