mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v1 0/2] misc: pch_phub: Two cleanups
@ 2026-05-21 10:46 Uwe Kleine-König (The Capable Hub)
  2026-05-21 10:46 ` [PATCH v1 1/2] misc: pch_phub: Drop two unused functions Uwe Kleine-König (The Capable Hub)
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-05-21 10:46 UTC (permalink / raw)
  To: Arnd Bergmann, Greg Kroah-Hartman; +Cc: linux-kernel

Hello,

my objective is to convert all pci_device_id assignments to use named
initializer for a further cleanup. See
https://lore.kernel.org/all/20260507074102.2654314-2-u.kleine-koenig@baylibre.com/
for details about that.

While working on the pch_phub driver, I found a few more opportunities
for improvement and the conversion to named initializers is just a side
effect of the 2nd patch.

If a "= 1" was added to the definition of PCH_EG20T in patch #2, there would be
no differences in the generated code. Without that there is a shift in the
magic constants that doesn't change the semantics however.

Best regards
Uwe

Uwe Kleine-König (The Capable Hub) (2):
  misc: pch_phub: Drop two unused functions
  misc: pch_phub: Introduce an enum for device indentification

 drivers/misc/pch_phub.c | 151 +++++-----------------------------------
 1 file changed, 18 insertions(+), 133 deletions(-)


base-commit: 254f49634ee16a731174d2ae34bc50bd5f45e731
-- 
2.47.3


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2026-05-24 10:12 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-05-21 10:46 [PATCH v1 0/2] misc: pch_phub: Two cleanups Uwe Kleine-König (The Capable Hub)
2026-05-21 10:46 ` [PATCH v1 1/2] misc: pch_phub: Drop two unused functions Uwe Kleine-König (The Capable Hub)
2026-05-21 10:46 ` [PATCH v1 2/2] misc: pch_phub: Introduce an enum for device indentification Uwe Kleine-König (The Capable Hub)
2026-05-24 10:12 ` [PATCH v1 0/2] misc: pch_phub: Two cleanups Uwe Kleine-König (The Capable Hub)

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®