mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v2 0/3] drm/panic: Add kunit tests for drm_panic
@ 2025-09-08  9:00 Jocelyn Falempe
  2025-09-08  9:00 ` [PATCH v2 1/3] drm/panic: Rename draw_panic_static_* to draw_panic_screen_* Jocelyn Falempe
                   ` (2 more replies)
  0 siblings, 3 replies; 11+ messages in thread
From: Jocelyn Falempe @ 2025-09-08  9:00 UTC (permalink / raw)
  To: Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
	David Airlie, Simona Vetter, Jocelyn Falempe,
	Javier Martinez Canillas, linux-kernel, dri-devel

This series adds some kunit tests to drm_panic, and a debugfs interface to easily test the panic screen rendering at different resolutions/pixel format.

The kunit tests draws the panic screens to different framebuffer size and format, and ensure it doesn't crash or draw outside of the buffer.
However it doesn't check the resulting image, because it depends on other Kconfig options, like logo, fonts, or panic colors.

v2:
 * Use debugfs instead of sending the framebuffer through the kunit logs. (Thomas Zimmermann).
 * Add a few checks, and more comments in the kunit tests. (Maxime Ripard).

Jocelyn Falempe (3):
  drm/panic: Rename draw_panic_static_* to draw_panic_screen_*
  drm/panic: Add kunit tests for drm_panic
  drm/panic: Add a drm_panic/draw_test in debugfs

 MAINTAINERS                            |   1 +
 drivers/gpu/drm/Kconfig                |   2 +
 drivers/gpu/drm/drm_panic.c            | 150 +++++++++++++++++--
 drivers/gpu/drm/tests/drm_panic_test.c | 198 +++++++++++++++++++++++++
 4 files changed, 336 insertions(+), 15 deletions(-)
 create mode 100644 drivers/gpu/drm/tests/drm_panic_test.c


base-commit: 685e8dae19df73d5400734ee5ad9e96470f9c0b4
-- 
2.51.0


^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2025-09-25 15:50 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-09-08  9:00 [PATCH v2 0/3] drm/panic: Add kunit tests for drm_panic Jocelyn Falempe
2025-09-08  9:00 ` [PATCH v2 1/3] drm/panic: Rename draw_panic_static_* to draw_panic_screen_* Jocelyn Falempe
2025-09-08  9:00 ` [PATCH v2 2/3] drm/panic: Add kunit tests for drm_panic Jocelyn Falempe
2025-09-10  8:33   ` Maxime Ripard
2025-09-10 15:16     ` Jocelyn Falempe
2025-09-23  9:57       ` Maxime Ripard
2025-09-25 15:50         ` Jocelyn Falempe
2025-09-08  9:00 ` [PATCH v2 3/3] drm/panic: Add a drm_panic/draw_test in debugfs Jocelyn Falempe
2025-09-10 10:49   ` Maxime Ripard
2025-09-11 12:00     ` Jocelyn Falempe
2025-09-23 10:15       ` Maxime Ripard

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®