From: Reinette Chatre <reinette.chatre@intel.com>
To: James Morse <james.morse@arm.com>, <x86@kernel.org>,
<linux-kernel@vger.kernel.org>
Cc: Fenghua Yu <fenghua.yu@intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
<shameerali.kolothum.thodi@huawei.com>,
D Scott Phillips OS <scott@os.amperecomputing.com>,
<carl@os.amperecomputing.com>, <lcherian@marvell.com>,
<bobo.shaobowang@huawei.com>, <tan.shaopeng@fujitsu.com>,
<xingxin.hx@openanolis.org>, <baolin.wang@linux.alibaba.com>,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>, <peternewman@google.com>,
<dfustini@baylibre.com>
Subject: Re: [PATCH v4 21/24] x86/resctrl: Allow overflow/limbo handlers to be scheduled on any-but cpu
Date: Thu, 15 Jun 2023 15:25:49 -0700 [thread overview]
Message-ID: <d4296dd5-a3ca-3319-8cf5-489d73195a2a@intel.com> (raw)
In-Reply-To: <20230525180209.19497-22-james.morse@arm.com>
Hi James,
On 5/25/2023 11:02 AM, James Morse wrote:
...
> diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
> index 021a8956518c..9cba8fc405b9 100644
> --- a/arch/x86/kernel/cpu/resctrl/internal.h
> +++ b/arch/x86/kernel/cpu/resctrl/internal.h
> @@ -79,6 +79,37 @@ static inline unsigned int cpumask_any_housekeeping(const struct cpumask *mask)
> return cpu;
> }
>
> +/**
> + * cpumask_any_housekeeping_but() - Chose any cpu in @mask, preferring those
> + * that aren't marked nohz_full, excluding
> + * the provided CPU
> + * @mask: The mask to pick a CPU from.
> + * @exclude_cpu:The CPU to avoid picking.
> + *
> + * Returns a CPU from @mask, but not @but. If there are housekeeping CPUs that
"but not @exclude_cpu"
> + * don't use nohz_full, these are preferred.
> + * Returns >= nr_cpu_ids if no CPUs are available.
> + */
> +static inline unsigned int
> +cpumask_any_housekeeping_but(const struct cpumask *mask, int exclude_cpu)
> +{
> + int cpu, hk_cpu;
Should these be unsigned int?
> +
> + cpu = cpumask_any_but(mask, exclude_cpu);
> + if (tick_nohz_full_cpu(cpu)) {
> + hk_cpu = cpumask_nth_andnot(0, mask, tick_nohz_full_mask);
> + if (hk_cpu == exclude_cpu) {
> + hk_cpu = cpumask_nth_andnot(1, mask,
> + tick_nohz_full_mask);
> + }
> +
These braces are not necessary. If they are added to help readability then
perhaps the indentation can be reduced by using an earlier:
if (!tick_nohz_full_cpu(cpu))
return cpu;
> + if (hk_cpu < nr_cpu_ids)
> + cpu = hk_cpu;
> + }
> +
> + return cpu;
> +}
> +
> struct rdt_fs_context {
> struct kernfs_fs_context kfc;
> bool enable_cdpl2;
> @@ -564,11 +595,13 @@ void mon_event_read(struct rmid_read *rr, struct rdt_resource *r,
> struct rdt_domain *d, struct rdtgroup *rdtgrp,
> int evtid, int first);
> void mbm_setup_overflow_handler(struct rdt_domain *dom,
> - unsigned long delay_ms);
> + unsigned long delay_ms,
> + int exclude_cpu);
> void mbm_handle_overflow(struct work_struct *work);
> void __init intel_rdt_mbm_apply_quirk(void);
> bool is_mba_sc(struct rdt_resource *r);
> -void cqm_setup_limbo_handler(struct rdt_domain *dom, unsigned long delay_ms);
> +void cqm_setup_limbo_handler(struct rdt_domain *dom, unsigned long delay_ms,
> + int exclude_cpu);
> void cqm_handle_limbo(struct work_struct *work);
> bool has_busy_rmid(struct rdt_resource *r, struct rdt_domain *d);
> void __check_limbo(struct rdt_domain *d, bool force_free);
> diff --git a/arch/x86/kernel/cpu/resctrl/monitor.c b/arch/x86/kernel/cpu/resctrl/monitor.c
> index ced933694f60..ae02185f3354 100644
> --- a/arch/x86/kernel/cpu/resctrl/monitor.c
> +++ b/arch/x86/kernel/cpu/resctrl/monitor.c
> @@ -485,7 +485,7 @@ static void add_rmid_to_limbo(struct rmid_entry *entry)
> * setup up the limbo worker.
> */
> if (!has_busy_rmid(r, d))
> - cqm_setup_limbo_handler(d, CQM_LIMBOCHECK_INTERVAL);
> + cqm_setup_limbo_handler(d, CQM_LIMBOCHECK_INTERVAL, -1);
Should this -1 be RESCTRL_PICK_ANY_CPU?
> set_bit(idx, d->rmid_busy_llc);
> entry->busy++;
> }
> @@ -810,15 +810,28 @@ void cqm_handle_limbo(struct work_struct *work)
> mutex_unlock(&rdtgroup_mutex);
> }
>
> -void cqm_setup_limbo_handler(struct rdt_domain *dom, unsigned long delay_ms)
> +/**
> + * cqm_setup_limbo_handler() - Schedule the limbo handler to run for this
> + * domain.
> + * @delay_ms: How far in the future the handler should run.
> + * @exclude_cpu: Which CPU the handler should not run on, -1 to pick any CPU.
Should -1 be RESCTRL_PICK_ANY_CPU?
> + */
> +void cqm_setup_limbo_handler(struct rdt_domain *dom, unsigned long delay_ms,
> + int exclude_cpu)
> {
> unsigned long delay = msecs_to_jiffies(delay_ms);
> int cpu;
>
> - cpu = cpumask_any_housekeeping(&dom->cpu_mask);
> - dom->cqm_work_cpu = cpu;
> + if (exclude_cpu == RESCTRL_PICK_ANY_CPU)
> + cpu = cpumask_any_housekeeping(&dom->cpu_mask);
> + else
> + cpu = cpumask_any_housekeeping_but(&dom->cpu_mask,
> + exclude_cpu);
>
> - schedule_delayed_work_on(cpu, &dom->cqm_limbo, delay);
> + if (cpu < nr_cpu_ids) {
> + dom->cqm_work_cpu = cpu;
Should cqm_work_cpu not perhaps be set to nr_cpu_ids on failure? If it keeps
pointing to CPU that ran worker previously there may be unexpected behavior.
Note the different behavior between cqm_setup_limbo_handler() and
mbm_setup_overflow_handler() in this regard.
> + schedule_delayed_work_on(cpu, &dom->cqm_limbo, delay);
> + }
> }
>
> void mbm_handle_overflow(struct work_struct *work)
> @@ -864,7 +877,14 @@ void mbm_handle_overflow(struct work_struct *work)
> mutex_unlock(&rdtgroup_mutex);
> }
>
> -void mbm_setup_overflow_handler(struct rdt_domain *dom, unsigned long delay_ms)
> +/**
> + * mbm_setup_overflow_handler() - Schedule the overflow handler to run for this
> + * domain.
> + * @delay_ms: How far in the future the handler should run.
> + * @exclude_cpu: Which CPU the handler should not run on, -1 to pick any CPU.
RESCTRL_PICK_ANY_CPU?
> + */
> +void mbm_setup_overflow_handler(struct rdt_domain *dom, unsigned long delay_ms,
> + int exclude_cpu)
> {
> unsigned long delay = msecs_to_jiffies(delay_ms);
> int cpu;
> @@ -875,9 +895,15 @@ void mbm_setup_overflow_handler(struct rdt_domain *dom, unsigned long delay_ms)
> */
> if (!resctrl_mounted || !resctrl_arch_mon_capable())
> return;
> - cpu = cpumask_any_housekeeping(&dom->cpu_mask);
> + if (exclude_cpu == -1)
same
> + cpu = cpumask_any_housekeeping(&dom->cpu_mask);
> + else
> + cpu = cpumask_any_housekeeping_but(&dom->cpu_mask,
> + exclude_cpu);
> dom->mbm_work_cpu = cpu;
> - schedule_delayed_work_on(cpu, &dom->mbm_over, delay);
> +
> + if (cpu < nr_cpu_ids)
> + schedule_delayed_work_on(cpu, &dom->mbm_over, delay);
> }
>
...
> diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h
> index ecd41762d61a..089b91133e5e 100644
> --- a/include/linux/resctrl.h
> +++ b/include/linux/resctrl.h
> @@ -9,6 +9,9 @@
> /* CLOSID value used by the default control group */
> #define RESCTRL_RESERVED_CLOSID 0
>
> +/* Indicates no CPU needs to be excluded */
This comment seems to just be a rewrite of the macro name.
> +#define RESCTRL_PICK_ANY_CPU -1
> +
> #ifdef CONFIG_PROC_CPU_RESCTRL
>
> int proc_resctrl_show(struct seq_file *m,
Reinette
next prev parent reply other threads:[~2023-06-15 22:26 UTC|newest]
Thread overview: 62+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-25 18:01 [PATCH v4 00/24] x86/resctrl: monitored closid+rmid together, separate arch/fs locking James Morse
2023-05-25 18:01 ` [PATCH v4 01/24] x86/resctrl: Track the closid with the rmid James Morse
2023-06-15 22:01 ` Reinette Chatre
2023-05-25 18:01 ` [PATCH v4 02/24] x86/resctrl: Access per-rmid structures by index James Morse
2023-06-08 7:52 ` Shaopeng Tan (Fujitsu)
2023-06-15 22:03 ` Reinette Chatre
2023-07-28 16:34 ` James Morse
2023-05-25 18:01 ` [PATCH v4 03/24] x86/resctrl: Create helper for RMID allocation and mondata dir creation James Morse
2023-06-15 22:04 ` Reinette Chatre
2023-05-25 18:01 ` [PATCH v4 04/24] x86/resctrl: Move rmid allocation out of mkdir_rdt_prepare() James Morse
2023-06-15 22:05 ` Reinette Chatre
2023-05-25 18:01 ` [PATCH v4 05/24] x86/resctrl: Allow RMID allocation to be scoped by CLOSID James Morse
2023-06-15 22:05 ` Reinette Chatre
2023-05-25 18:01 ` [PATCH v4 06/24] x86/resctrl: Track the number of dirty RMID a CLOSID has James Morse
2023-06-15 22:08 ` Reinette Chatre
2023-07-28 16:35 ` James Morse
2023-05-25 18:01 ` [PATCH v4 07/24] x86/resctrl: Use set_bit()/clear_bit() instead of open coding James Morse
2023-05-25 18:01 ` [PATCH v4 08/24] x86/resctrl: Allocate the cleanest CLOSID by searching closid_num_dirty_rmid James Morse
2023-06-15 22:09 ` Reinette Chatre
2023-07-28 16:35 ` James Morse
2023-05-25 18:01 ` [PATCH v4 09/24] x86/resctrl: Move CLOSID/RMID matching and setting to use helpers James Morse
2023-05-25 18:01 ` [PATCH v4 10/24] tick/nohz: Move tick_nohz_full_mask declaration outside the #ifdef James Morse
2023-05-25 18:01 ` [PATCH v4 11/24] x86/resctrl: Add cpumask_any_housekeeping() for limbo/overflow James Morse
2023-06-15 22:10 ` Reinette Chatre
2023-05-25 18:01 ` [PATCH v4 12/24] x86/resctrl: Make resctrl_arch_rmid_read() retry when it is interrupted James Morse
2023-06-06 8:49 ` Peter Newman
2023-06-06 17:03 ` James Morse
2023-06-07 12:51 ` Peter Newman
2023-07-17 17:07 ` James Morse
2023-06-08 8:53 ` Peter Newman
2023-07-17 17:06 ` James Morse
2023-05-25 18:01 ` [PATCH v4 13/24] x86/resctrl: Queue mon_event_read() instead of sending an IPI James Morse
2023-06-15 22:10 ` Reinette Chatre
2023-05-25 18:01 ` [PATCH v4 14/24] x86/resctrl: Allow resctrl_arch_rmid_read() to sleep James Morse
2023-06-15 22:13 ` Reinette Chatre
2023-07-28 16:32 ` James Morse
2023-05-25 18:02 ` [PATCH v4 15/24] x86/resctrl: Allow arch to allocate memory needed in resctrl_arch_rmid_read() James Morse
2023-06-12 5:39 ` Shaopeng Tan (Fujitsu)
2023-07-28 16:34 ` James Morse
2023-06-15 22:13 ` Reinette Chatre
2023-05-25 18:02 ` [PATCH v4 16/24] x86/resctrl: Make resctrl_mounted checks explicit James Morse
2023-06-15 22:23 ` Reinette Chatre
2023-05-25 18:02 ` [PATCH v4 17/24] x86/resctrl: Move alloc/mon static keys into helpers James Morse
2023-05-25 18:02 ` [PATCH v4 18/24] x86/resctrl: Make rdt_enable_key the arch's decision to switch James Morse
2023-05-25 18:02 ` [PATCH v4 19/24] x86/resctrl: Add helpers for system wide mon/alloc capable James Morse
2023-05-25 18:02 ` [PATCH v4 20/24] x86/resctrl: Add cpu online callback for resctrl work James Morse
2023-06-15 22:23 ` Reinette Chatre
2023-05-25 18:02 ` [PATCH v4 21/24] x86/resctrl: Allow overflow/limbo handlers to be scheduled on any-but cpu James Morse
2023-06-09 11:10 ` Shaopeng Tan (Fujitsu)
2023-07-28 16:29 ` James Morse
2023-06-15 22:25 ` Reinette Chatre [this message]
2023-07-28 16:29 ` James Morse
2023-05-25 18:02 ` [PATCH v4 22/24] x86/resctrl: Add cpu offline callback for resctrl work James Morse
2023-05-25 18:02 ` [PATCH v4 23/24] x86/resctrl: Move domain helper migration into resctrl_offline_cpu() James Morse
2023-05-25 18:02 ` [PATCH v4 24/24] x86/resctrl: Separate arch and fs resctrl locks James Morse
2023-06-13 9:15 ` Peter Newman
2023-07-28 16:32 ` James Morse
2023-06-15 22:26 ` Reinette Chatre
2023-07-28 16:34 ` James Morse
2023-06-13 6:18 ` [PATCH v4 00/24] x86/resctrl: monitored closid+rmid together, separate arch/fs locking Shaopeng Tan (Fujitsu)
2023-07-28 16:34 ` James Morse
2023-06-15 23:28 ` Reinette Chatre
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d4296dd5-a3ca-3319-8cf5-489d73195a2a@intel.com \
--to=reinette.chatre@intel.com \
--cc=Babu.Moger@amd.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dfustini@baylibre.com \
--cc=fenghua.yu@intel.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=scott@os.amperecomputing.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
--cc=xingxin.hx@openanolis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®