mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dave Hansen <dave.hansen@intel.com>
To: Borislav Petkov <bp@alien8.de>
Cc: Dave Hansen <dave.hansen@linux.intel.com>,
	linux-kernel@vger.kernel.org, x86@kernel.org, tglx@linutronix.de,
	rafael@kernel.org, lenb@kernel.org
Subject: Re: [PATCH 11/11] x86/cpu: Make all all CPUID leaf names consistent
Date: Fri, 6 Dec 2024 15:01:30 -0800	[thread overview]
Message-ID: <d6680add-f4d2-4d65-a711-3f80bfd43f6d@intel.com> (raw)
In-Reply-To: <20241129182747.GEZ0oHo1eR0l7sREJY@fat_crate.local>

[-- Attachment #1: Type: text/plain, Size: 867 bytes --]

On 11/29/24 10:27, Borislav Petkov wrote:
> Well, enum cpuid_leafs as it is now is the *indices* into the cap flags array:
> 
> struct cpuinfo_x86 {
> 
> 	...
> 
> 	__u32           x86_capability[NCAPINTS + NBUGINTS];
> 
> And having a "CPUID_" prefixed thing and a "CPUID_LEAF_" prefixed other thing
> is going to cause confusion.
> 
> And renaming enum cpuid_leafs is going to cause a massive churn...

Wait a sec though:

$ git grep 'enum cpuid_leafs' arch/x86/
arch/x86/include/asm/cpufeature.h:enum cpuid_leafs
arch/x86/kvm/cpuid.c:static __always_inline void kvm_cpu_cap_mask(enum
cpuid_leafs leaf, u32 mask)

So there is only one direct reference to the type.

I think all it will take to rename the _type_ is something like the
attached. Also, I think the new name 'x86_capability_words' and variable
'cap_nr' make the KVM site a lot more readable.

Thoughts?

[-- Attachment #2: rename-cpuid_leafs.patch --]
[-- Type: text/x-patch, Size: 1369 bytes --]



---

 b/arch/x86/include/asm/cpufeature.h |    2 +-
 b/arch/x86/kvm/cpuid.c              |    8 ++++----
 2 files changed, 5 insertions(+), 5 deletions(-)

diff -puN arch/x86/include/asm/cpufeature.h~rename-cpuid_leafs arch/x86/include/asm/cpufeature.h
--- a/arch/x86/include/asm/cpufeature.h~rename-cpuid_leafs	2024-12-06 14:57:52.350793675 -0800
+++ b/arch/x86/include/asm/cpufeature.h	2024-12-06 14:58:43.464719842 -0800
@@ -10,7 +10,7 @@
 #include <linux/bitops.h>
 #include <asm/alternative.h>
 
-enum cpuid_leafs
+enum x86_capability_words
 {
 	CPUID_1_EDX		= 0,
 	CPUID_8000_0001_EDX,
diff -puN arch/x86/kvm/cpuid.c~rename-cpuid_leafs arch/x86/kvm/cpuid.c
--- a/arch/x86/kvm/cpuid.c~rename-cpuid_leafs	2024-12-06 14:58:45.084780924 -0800
+++ b/arch/x86/kvm/cpuid.c	2024-12-06 14:59:24.818279432 -0800
@@ -594,14 +594,14 @@ void kvm_cpu_cap_init_kvm_defined(enum k
 	__kvm_cpu_cap_mask(leaf);
 }
 
-static __always_inline void kvm_cpu_cap_mask(enum cpuid_leafs leaf, u32 mask)
+static __always_inline void kvm_cpu_cap_mask(enum x86_capability_words cap_nr, u32 mask)
 {
 	/* Use kvm_cpu_cap_init_kvm_defined for KVM-only leafs. */
-	BUILD_BUG_ON(leaf >= NCAPINTS);
+	BUILD_BUG_ON(cap_nr >= NCAPINTS);
 
-	kvm_cpu_caps[leaf] &= mask;
+	kvm_cpu_caps[cap_nr] &= mask;
 
-	__kvm_cpu_cap_mask(leaf);
+	__kvm_cpu_cap_mask(cap_nr);
 }
 
 void kvm_set_cpu_caps(void)
_

  reply	other threads:[~2024-12-06 23:01 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-30 21:33 [PATCH 00/11] x86/cpu: Centralize and standardize CPUID leaf naming Dave Hansen
2024-10-30 21:33 ` [PATCH 01/11] x86/cpu: Move MWAIT leaf definition to common header Dave Hansen
2024-10-30 21:33 ` [PATCH 02/11] x86/cpu: Use MWAIT leaf definition Dave Hansen
2024-10-30 21:33 ` [PATCH 03/11] x86/cpu: Remove unnecessary MwAIT leaf checks Dave Hansen
2024-10-30 21:33 ` [PATCH 04/11] x86/acpi: Check MWAIT feature instead of CPUID level Dave Hansen
2024-10-30 21:33 ` [PATCH 05/11] x86/cpu: Move DCA leaf definition Dave Hansen
2024-10-30 21:33 ` [PATCH 06/11] x86/cpu: Move TSC CPUID " Dave Hansen
2024-10-30 21:33 ` [PATCH 07/11] x86/tsc: Move away from TSC leaf magic numbers Dave Hansen
2024-10-30 21:33 ` [PATCH 08/11] x86/tsc: Remove CPUID "frequency" " Dave Hansen
2024-10-30 21:33 ` [PATCH 09/11] x86/fpu: Move CPUID leaf definitions to common code Dave Hansen
2024-10-30 21:33 ` [PATCH 10/11] x86/fpu: Remove unnecessary CPUID level check Dave Hansen
2024-10-30 21:33 ` [PATCH 11/11] x86/cpu: Make all all CPUID leaf names consistent Dave Hansen
2024-10-31 10:18   ` Borislav Petkov
2024-10-31 17:19     ` Dave Hansen
2024-11-29 18:27       ` Borislav Petkov
2024-12-06 23:01         ` Dave Hansen [this message]
2024-12-09 16:27           ` Sean Christopherson
2024-12-09 17:25             ` Dave Hansen
2024-12-09 20:23               ` Sean Christopherson
2024-12-10 11:28             ` Borislav Petkov
2024-12-10 11:19       ` Borislav Petkov
2024-11-20 19:53 [PATCH 00/11] x86/cpu: Centralize and standardize CPUID leaf naming Dave Hansen
2024-11-20 19:53 ` [PATCH 11/11] x86/cpu: Make all all CPUID leaf names consistent Dave Hansen
2024-11-20 20:23   ` Dave Jiang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d6680add-f4d2-4d65-a711-3f80bfd43f6d@intel.com \
    --to=dave.hansen@intel.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=lenb@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®