* [PATCH] HID: appletb-kbd: Replace msecs_to_jiffies with secs_to_jiffies for timer settings
@ 2025-03-19 2:12 xie.ludan
2025-03-19 7:26 ` Krzysztof Kozlowski
0 siblings, 1 reply; 3+ messages in thread
From: xie.ludan @ 2025-03-19 2:12 UTC (permalink / raw)
To: bentiss
Cc: jikos, linux-input, linux-kernel, xu.xin16, yang.yang29, jiang.peng9
From: Peng Jiang <jiang.peng9@zte.com.cn>
The variables `appletb_tb_idle_timeout` and `appletb_tb_dim_timeout`
are already defined in seconds, so using `secs_to_jiffies` directly
makes the code more readable and consistent with the units used.
This is converted using scripts/coccinelle/misc/secs_to_jiffies.cocci with
the following Coccinelle rules:
@depends on patch@
expression E;
@@
-msecs_to_jiffies
+secs_to_jiffies
(E
- * \( 1000 \| MSEC_PER_SEC \)
)
Signed-off-by: Peng Jiang <jiang.peng9@zte.com.cn>
Signed-off-by: XieLudan <xie.ludan@zte.com.cn>
---
drivers/hid/hid-appletb-kbd.c | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/hid/hid-appletb-kbd.c b/drivers/hid/hid-appletb-kbd.c
index d4b95aa3eecb..2f78db891cb9 100644
--- a/drivers/hid/hid-appletb-kbd.c
+++ b/drivers/hid/hid-appletb-kbd.c
@@ -172,7 +172,8 @@ static void appletb_inactivity_timer(struct timer_list *t)
if (!kbd->has_dimmed) {
backlight_device_set_brightness(kbd->backlight_dev, 1);
kbd->has_dimmed = true;
- mod_timer(&kbd->inactivity_timer, jiffies + msecs_to_jiffies(appletb_tb_idle_timeout * 1000));
+ mod_timer(&kbd->inactivity_timer,
+ jiffies + secs_to_jiffies(appletb_tb_idle_timeout));
} else if (!kbd->has_turned_off) {
backlight_device_set_brightness(kbd->backlight_dev, 0);
kbd->has_turned_off = true;
@@ -188,7 +189,8 @@ static void reset_inactivity_timer(struct appletb_kbd *kbd)
kbd->has_dimmed = false;
kbd->has_turned_off = false;
}
- mod_timer(&kbd->inactivity_timer, jiffies + msecs_to_jiffies(appletb_tb_dim_timeout * 1000));
+ mod_timer(&kbd->inactivity_timer,
+ jiffies + secs_to_jiffies(appletb_tb_dim_timeout));
}
}
@@ -407,7 +409,8 @@ static int appletb_kbd_probe(struct hid_device *hdev, const struct hid_device_id
} else {
backlight_device_set_brightness(kbd->backlight_dev, 2);
timer_setup(&kbd->inactivity_timer, appletb_inactivity_timer, 0);
- mod_timer(&kbd->inactivity_timer, jiffies + msecs_to_jiffies(appletb_tb_dim_timeout * 1000));
+ mod_timer(&kbd->inactivity_timer,
+ jiffies + secs_to_jiffies(appletb_tb_dim_timeout));
}
kbd->inp_handler.event = appletb_kbd_inp_event;
--
2.25.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] HID: appletb-kbd: Replace msecs_to_jiffies with secs_to_jiffies for timer settings
2025-03-19 2:12 [PATCH] HID: appletb-kbd: Replace msecs_to_jiffies with secs_to_jiffies for timer settings xie.ludan
@ 2025-03-19 7:26 ` Krzysztof Kozlowski
2025-03-19 8:01 ` jiang.peng9
0 siblings, 1 reply; 3+ messages in thread
From: Krzysztof Kozlowski @ 2025-03-19 7:26 UTC (permalink / raw)
To: xie.ludan, bentiss
Cc: jikos, linux-input, linux-kernel, xu.xin16, yang.yang29, jiang.peng9
On 19/03/2025 03:12, xie.ludan@zte.com.cn wrote:
> From: Peng Jiang <jiang.peng9@zte.com.cn>
>
> The variables `appletb_tb_idle_timeout` and `appletb_tb_dim_timeout`
> are already defined in seconds, so using `secs_to_jiffies` directly
> makes the code more readable and consistent with the units used.
>
> This is converted using scripts/coccinelle/misc/secs_to_jiffies.cocci with
> the following Coccinelle rules:
Why do you need to paste here contentx of existing cocci script? It's
already mainlined, no?
>
> @depends on patch@
> expression E;
> @@
>
> -msecs_to_jiffies
> +secs_to_jiffies
> (E
> - * \( 1000 \| MSEC_PER_SEC \)
> )
>
> Signed-off-by: Peng Jiang <jiang.peng9@zte.com.cn>
> Signed-off-by: XieLudan <xie.ludan@zte.com.cn>
Same comment as before. Did you respond to previous feedbacks? No.
Best regards,
Krzysztof
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] HID: appletb-kbd: Replace msecs_to_jiffies with secs_to_jiffies for timer settings
2025-03-19 7:26 ` Krzysztof Kozlowski
@ 2025-03-19 8:01 ` jiang.peng9
0 siblings, 0 replies; 3+ messages in thread
From: jiang.peng9 @ 2025-03-19 8:01 UTC (permalink / raw)
To: krzk
Cc: xie.ludan, bentiss, jikos, linux-input, linux-kernel, xu.xin16,
yang.yang29
> > From: Peng Jiang <jiang.peng9@zte.com.cn>
> >
> > The variables `appletb_tb_idle_timeout` and `appletb_tb_dim_timeout`
> > are already defined in seconds, so using `secs_to_jiffies` directly
> > makes the code more readable and consistent with the units used.
> >
> > This is converted using scripts/coccinelle/misc/secs_to_jiffies.cocci with
> > the following Coccinelle rules:
>
> Why do you need to paste here contentx of existing cocci script? It's
> already mainlined, no?
>
> >
> > @depends on patch@
> > expression E;
> > @@
> >
> > -msecs_to_jiffies
> > +secs_to_jiffies
> > (E
> > - * \( 1000 \| MSEC_PER_SEC \)
> > )
> >
I intended to refer to the source of the modifications. Therefore, removing the Coccinelle script is appropriate.
Thank you for your feedback!
Best regards,
Peng Jiang
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2025-03-19 8:02 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-03-19 2:12 [PATCH] HID: appletb-kbd: Replace msecs_to_jiffies with secs_to_jiffies for timer settings xie.ludan
2025-03-19 7:26 ` Krzysztof Kozlowski
2025-03-19 8:01 ` jiang.peng9
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®