mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v3 0/6] drm/mediatek: Small mtk-dpi cleanups
@ 2023-07-26  8:22 AngeloGioacchino Del Regno
  2023-07-26  8:22 ` [PATCH v3 1/6] drm/mediatek: mtk_dpi: Simplify with devm_drm_bridge_add() AngeloGioacchino Del Regno
                   ` (5 more replies)
  0 siblings, 6 replies; 9+ messages in thread
From: AngeloGioacchino Del Regno @ 2023-07-26  8:22 UTC (permalink / raw)
  To: chunkuang.hu
  Cc: p.zabel, airlied, daniel, matthias.bgg,
	angelogioacchino.delregno, dri-devel, linux-mediatek,
	linux-kernel, linux-arm-kernel, kernel, fshao

Changes in v3:
 - Fixed removal of mtk_dpi pointer in mtk_dpi_remove on patch [1/6]
   instead of patch [3/6]; thanks CK Hu!

Changes in v2:
 - Removed drm_bridge_remove() call in patch 1
 - Added dev_err_probe print to devm_drm_of_get_bridge()
   call error handling
 - Switched to devm_platform_ioremap_resource() to remove
   the useless pointer to struct resource in probe function
 - Added a commit to compress struct of_device_id entries
 - Added a commit to switch to .remove_new() callback

This is a small cleanup of the mtk-dpi driver, switching it to devm
variants where possible and where it made sense, and reducing lines
while retaining and improving human readability.

AngeloGioacchino Del Regno (6):
  drm/mediatek: mtk_dpi: Simplify with devm_drm_bridge_add()
  drm/mediatek: mtk_dpi: Simplify with dev_err_probe()
  drm/mediatek: mtk_dpi: Switch to devm_drm_of_get_bridge()
  drm/mediatek: mtk_dpi: Switch to .remove_new() void callback
  drm/mediatek: mtk_dpi: Use devm_platform_ioremap_resource()
  drm/mediatek: mtk_dpi: Compress struct of_device_id entries

 drivers/gpu/drm/mediatek/mtk_dpi.c | 100 +++++++++--------------------
 1 file changed, 32 insertions(+), 68 deletions(-)

-- 
2.41.0


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2023-07-27  3:25 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-07-26  8:22 [PATCH v3 0/6] drm/mediatek: Small mtk-dpi cleanups AngeloGioacchino Del Regno
2023-07-26  8:22 ` [PATCH v3 1/6] drm/mediatek: mtk_dpi: Simplify with devm_drm_bridge_add() AngeloGioacchino Del Regno
2023-07-27  3:11   ` CK Hu (胡俊光)
2023-07-26  8:22 ` [PATCH v3 2/6] drm/mediatek: mtk_dpi: Simplify with dev_err_probe() AngeloGioacchino Del Regno
2023-07-26  8:22 ` [PATCH v3 3/6] drm/mediatek: mtk_dpi: Switch to devm_drm_of_get_bridge() AngeloGioacchino Del Regno
2023-07-27  3:24   ` CK Hu (胡俊光)
2023-07-26  8:22 ` [PATCH v3 4/6] drm/mediatek: mtk_dpi: Switch to .remove_new() void callback AngeloGioacchino Del Regno
2023-07-26  8:22 ` [PATCH v3 5/6] drm/mediatek: mtk_dpi: Use devm_platform_ioremap_resource() AngeloGioacchino Del Regno
2023-07-26  8:22 ` [PATCH v3 6/6] drm/mediatek: mtk_dpi: Compress struct of_device_id entries AngeloGioacchino Del Regno

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®