* [PATCH] drm/amdgpu: Fix typos in amdgpu_vm_bo_update comments
@ 2025-12-23 4:41 Ding Yihan
2026-01-07 12:47 ` Christian König
0 siblings, 1 reply; 2+ messages in thread
From: Ding Yihan @ 2025-12-23 4:41 UTC (permalink / raw)
To: alexander.deucher, christian.koenig
Cc: airlied, simona, amd-gfx, dri-devel, linux-kernel, Ding Yihan
Fix spelling mistakes in the comment block within amdgpu_vm_bo_update().
Specifically, correct "contians" to "contains" and "WIRTEABLE" to
"WRITEABLE".
Additionally, improve the grammar, capitalization, and punctuation of
the comment for better readability.
Signed-off-by: Ding Yihan <dingyihan@uniontech.com>
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
index c362d4dfb5bb..502d32728008 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
@@ -1352,8 +1352,8 @@ int amdgpu_vm_bo_update(struct amdgpu_device *adev, struct amdgpu_bo_va *bo_va,
list_for_each_entry(mapping, &bo_va->invalids, list) {
uint64_t update_flags = flags;
- /* normally,bo_va->flags only contians READABLE and WIRTEABLE bit go here
- * but in case of something, we filter the flags in first place
+ /* Normally,bo_va->flags only contains READABLE and WRITEABLE bits here.
+ * But in case of something, we filter the flags in first place.
*/
if (!(mapping->flags & AMDGPU_VM_PAGE_READABLE))
update_flags &= ~AMDGPU_PTE_READABLE;
--
2.20.1
^ permalink raw reply [flat|nested] 2+ messages in thread* Re: [PATCH] drm/amdgpu: Fix typos in amdgpu_vm_bo_update comments
2025-12-23 4:41 [PATCH] drm/amdgpu: Fix typos in amdgpu_vm_bo_update comments Ding Yihan
@ 2026-01-07 12:47 ` Christian König
0 siblings, 0 replies; 2+ messages in thread
From: Christian König @ 2026-01-07 12:47 UTC (permalink / raw)
To: Ding Yihan, alexander.deucher
Cc: airlied, simona, amd-gfx, dri-devel, linux-kernel
On 12/23/25 05:41, Ding Yihan wrote:
> Fix spelling mistakes in the comment block within amdgpu_vm_bo_update().
> Specifically, correct "contians" to "contains" and "WIRTEABLE" to
> "WRITEABLE".
>
> Additionally, improve the grammar, capitalization, and punctuation of
> the comment for better readability.
>
> Signed-off-by: Ding Yihan <dingyihan@uniontech.com>
Reviewed-by: Christian König <christian.koenig@amd.com>
> ---
> drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
> index c362d4dfb5bb..502d32728008 100644
> --- a/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
> +++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
> @@ -1352,8 +1352,8 @@ int amdgpu_vm_bo_update(struct amdgpu_device *adev, struct amdgpu_bo_va *bo_va,
> list_for_each_entry(mapping, &bo_va->invalids, list) {
> uint64_t update_flags = flags;
>
> - /* normally,bo_va->flags only contians READABLE and WIRTEABLE bit go here
> - * but in case of something, we filter the flags in first place
> + /* Normally,bo_va->flags only contains READABLE and WRITEABLE bits here.
> + * But in case of something, we filter the flags in first place.
> */
> if (!(mapping->flags & AMDGPU_VM_PAGE_READABLE))
> update_flags &= ~AMDGPU_PTE_READABLE;
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-01-07 12:47 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-12-23 4:41 [PATCH] drm/amdgpu: Fix typos in amdgpu_vm_bo_update comments Ding Yihan
2026-01-07 12:47 ` Christian König
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®