From: "KANDA Mitsuru / 神田 充" <kanda@nn.iij4u.or.jp>
To: linux-kernel@vger.kernel.org
Cc: usagi-core@linux-ipv6.org
Subject: USAGI stable release
Date: Tue, 01 Jan 2002 22:32:04 +0900 [thread overview]
Message-ID: <m3lmfiurhn.wl@dom.osaru.yi.org> (raw)
A Happy New Year!
We are glad that we can announce the 3rd STABLE RELEASE of USAGI
(UniverSAl playGround for Ipv6)[1] product on January 1st, 2002.
On this release, we provide ipv6 enhanced kernel (based on
linux-2.2.20 and/or linux-2.4.13) and basic IPv6 libraries and
applications.
The improved features are listed below.
- ICMPv6 Node Information Queries
- Privacy Extensions (RFC 3041)(kernel-2.4 only)
- IPv6 khttpd
- Better source address selection
- Per-device statistics for SNMP
- IPv4/IPv6 socket binding on the same port
- Dropping IPv6 packets with malicious address(es)
- Enabling default route when IPv6 forwarding is enabled
- Improving SO_REUSEADDR behavior
- Fixing bugs in NDP(Neighbor Discovery Protocol)
- Fixing bugs in Stateless Address Auto-configuration
- Catching up and implementing RFC2553 / RFC2553bis APIs
including IPV6_V6ONLY socket option
- Catching up and implementing RFC2292 / RFC2292bis APIs
- Making many basic applications IPv6 ready.
You can get our source codes from the following URL.
<ftp://ftp.linux-ipv6.org/pub/usagi/stable/kit/>
We also provide our code in the form divided into the patch
against the main-line kernel and the tool.
<ftp://ftp.linux-ipv6.org/pub/usagi/stable/splitted/>
We plan to provide the binary packages for some distributions.
They will appear under
<ftp://ftp.linux-ipv6.org/pub/usagi/stable/packages/>
within several weeks.
We announce latest information via web. Please check
our web site <http://www.linux-ipv6.org>.
We also manage the mailing list for USAGI users.
If you have questions, please join the mailing list.
Comments and advises are also welcome on that mailing list.
Please visit <http://www.linux-ipv6.org/ml/> for further
information.
Thanks.
About USAGI Project:
The USAGI Project is managed by volunteers and aims to provide better
IPv6 environment on Linux freely. We are tightly collaborating with
WIDE Project[2], KAME Project[3] and TAHI Project[4], and trying
improving Linux kernel, IPv6 related libraries and IPv6 applications.
Our products are released every two weeks and stable release several
times a year. Please check our web site <http://www.linux-ipv6.org>
for the latest detailed information.
In-Reply-To:
[1] USAGI Project <http://www.linux-ipv6.org>
[2] WIDE Project <http://www.wide.ad.jp>
[3] KAME Project <http://www.kame.net>
[4] TAHI Project <http://www.tahi.org>
--
USAGI Project <http://www.linux-ipv6.org>
next reply other threads:[~2002-01-01 13:32 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2002-01-01 13:32 KANDA Mitsuru / 神田 充 [this message]
2002-04-08 16:06 Kazunori Miyazawa
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=m3lmfiurhn.wl@dom.osaru.yi.org \
--to=kanda@nn.iij4u.or.jp \
--cc=linux-kernel@vger.kernel.org \
--cc=usagi-core@linux-ipv6.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®