mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* USAGI stable release
@ 2002-01-01 13:32 KANDA Mitsuru / 神田 充
  0 siblings, 0 replies; 2+ messages in thread
From: KANDA Mitsuru / 神田 充 @ 2002-01-01 13:32 UTC (permalink / raw)
  To: linux-kernel; +Cc: usagi-core


A Happy New Year!

We are glad that we can announce the 3rd STABLE RELEASE of USAGI
(UniverSAl playGround for Ipv6)[1] product on January 1st, 2002. 
On this release, we provide ipv6 enhanced kernel (based on 
linux-2.2.20 and/or linux-2.4.13) and basic IPv6 libraries and
applications.

The improved features are listed below.

	- ICMPv6 Node Information Queries
        - Privacy Extensions (RFC 3041)(kernel-2.4 only)
        - IPv6 khttpd
        - Better source address selection
        - Per-device statistics for SNMP
        - IPv4/IPv6 socket binding on the same port
        - Dropping IPv6 packets with malicious address(es)
        - Enabling default route when IPv6 forwarding is enabled
        - Improving SO_REUSEADDR behavior
        - Fixing bugs in NDP(Neighbor Discovery Protocol)
        - Fixing bugs in Stateless Address Auto-configuration
        - Catching up and implementing RFC2553 / RFC2553bis APIs
	  including IPV6_V6ONLY socket option
        - Catching up and implementing RFC2292 / RFC2292bis APIs
        - Making many basic applications IPv6 ready.

You can get our source codes from the following URL.
	<ftp://ftp.linux-ipv6.org/pub/usagi/stable/kit/>

We also provide our code in the form divided into the patch
against the main-line kernel and the tool.
	<ftp://ftp.linux-ipv6.org/pub/usagi/stable/splitted/>

We plan to provide the binary packages for some distributions.
They will appear under
	<ftp://ftp.linux-ipv6.org/pub/usagi/stable/packages/>
within several weeks.


We announce latest information via web.  Please check
our web site <http://www.linux-ipv6.org>.

We also manage the mailing list for USAGI users. 
If you have questions, please join the mailing list.
Comments and advises are also welcome on that mailing list.  
Please visit <http://www.linux-ipv6.org/ml/> for further
information.


Thanks.


About USAGI Project:

The USAGI Project is managed by volunteers and aims to provide better
IPv6 environment on Linux freely.  We are tightly collaborating with 
WIDE Project[2], KAME Project[3] and TAHI Project[4], and trying 
improving Linux kernel, IPv6 related libraries and IPv6 applications.  
Our products are released every two weeks and stable release several 
times a year.  Please check our web site <http://www.linux-ipv6.org>
for the latest detailed information.


In-Reply-To:

	[1] USAGI Project	<http://www.linux-ipv6.org>
	[2] WIDE Project	<http://www.wide.ad.jp>
	[3] KAME Project	<http://www.kame.net>
	[4] TAHI Project	<http://www.tahi.org>

-- 
USAGI Project <http://www.linux-ipv6.org>

^ permalink raw reply	[flat|nested] 2+ messages in thread
* USAGI stable release
@ 2002-04-08 16:06 Kazunori Miyazawa
  0 siblings, 0 replies; 2+ messages in thread
From: Kazunori Miyazawa @ 2002-04-08 16:06 UTC (permalink / raw)
  To: linux-kernel; +Cc: USAGI Core

Hello,

We are glad to announce the USAGI[1] STABLE RELEASE 3.1, dated on April 8th,
2002.  Although this is a maintenance release of the STABLE RELEASE 3 dated 
on January 1st, 2002, it comes with a latest kernel and couple of new 
features.  

The new / updated features are:
	- based on latest kernel linux-2.4.18 
	  (linux-2.2.20 for linux-2.2 systems)
	- based on radvd-0.7.1, a router advertisement daemon
	- ISATAP (Intra-Site Automatic Tunnel Addressing Protocol) support
	- IPv4 and/or IPv6 over IPv4 Tunnel on a single driver support
	- Privacy Extensions for linux-2.2 systems

We also fixed the following bugs of the previous release:
	- Fixed a bug, which devices, such as PCMCIA devices, could not
	  finish correctly when using Privacy Extensions.
	- Fixed a bug, which getifaddrs(3) did not report local/remote 
	  addresses of point-to-point devices.
	- Fixed a bug, which tcp_wrapper was not compiled correctly,
	  so that ipv6 support was not enabled.
	and so on.

You can get our complete kit which includes kernel tree, library and 
applications from the following URL.
	<ftp://ftp.linux-ipv6.org/pub/usagi/stable/kit/>

We also provide separate patches against the main-line kernel and the tools.
	<ftp://ftp.linux-ipv6.org/pub/usagi/stable/split/>

We have a plan to provide the binary packages for some distributions.
They will appear under
	<ftp://ftp.linux-ipv6.org/pub/usagi/stable/packages/>
within several weeks.


We announce the latest information on our web pages.  
Please check our web site <http://www.linux-ipv6.org>.

We also manage the mailing list for USAGI users. 
If you have questions, please join the mailing list.
Comments and advises are also welcome on that mailing list.  
Please visit <http://www.linux-ipv6.org/ml/> for further
information.


Thanks.


About USAGI Project:

The USAGI Project is managed by volunteers and aims to provide better
IPv6 environment on Linux freely.  We are tightly collaborating with
WIDE Project[2], KAME Project[3] and TAHI Project[4], and trying to
improve Linux kernel, IPv6 related libraries and IPv6 applications.
Our snapshots are released every two weeks and stable release is
released several times a year.  Please check our web site
<http://www.linux-ipv6.org> for the latest information.


In-Reply-To:

	[1] USAGI Project       <http://www.linux-ipv6.org>
	[2] WIDE Project        <http://www.wide.ad.jp>
	[3] KAME Project        <http://www.kame.net>
	[4] TAHI Project        <http://www.tahi.org>

-- 
USAGI Project <http://www.linux-ipv6.org>



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2002-04-08 16:06 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2002-01-01 13:32 USAGI stable release KANDA Mitsuru / 神田 充
2002-04-08 16:06 Kazunori Miyazawa

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®