mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Pavel Machek <pavel@suse.cz>
Cc: Andrew Morton <akpm@osdl.org>,
	kernel list <linux-kernel@vger.kernel.org>,
	perex@suse.cz, alsa-devel@alsa-project.org, pshou@realtek.com.tw
Subject: Re: sound/pci/hda/intel_hda: small cleanups
Date: Thu, 31 Aug 2006 16:53:49 +0200	[thread overview]
Message-ID: <s5hveo90xdu.wl%tiwai@suse.de> (raw)
In-Reply-To: <20060831133929.GH3923@elf.ucw.cz>

At Thu, 31 Aug 2006 15:39:29 +0200,
Pavel Machek wrote:
> 
> Hi!
> 
> > > @@ -271,8 +272,8 @@ struct azx_dev {
> > >  	/* for sanity check of position buffer */
> > >  	unsigned int period_intr;
> > >  
> > > -	unsigned int opened: 1;
> > > -	unsigned int running: 1;
> > > +	unsigned int opened :1;
> > > +	unsigned int running :1;
> > >  };
> > >  
> > >  /* CORB/RIRB */
> > > @@ -330,8 +331,8 @@ struct azx {
> > >  
> > >  	/* flags */
> > >  	int position_fix;
> > > -	unsigned int initialized: 1;
> > > -	unsigned int single_cmd: 1;
> > > +	unsigned int initialized :1;
> > > +	unsigned int single_cmd :1;
> > >  };
> > 
> > Any official standard reference for bit-field expressions?
> 
> Well, logically : belongs to the 1, and include/linux understands it
> like that...

OK, "xxx :1;" looks major, too :)

> > >  /* driver types */
> > > @@ -642,14 +643,14 @@ static int azx_reset(struct azx *chip)
> > >  	azx_writeb(chip, GCTL, azx_readb(chip, GCTL) | ICH6_GCTL_RESET);
> > >  
> > >  	count = 50;
> > > -	while (! azx_readb(chip, GCTL) && --count)
> > > +	while (!azx_readb(chip, GCTL) && --count)
> > >  		msleep(1);
> > 
> > Hm, it looks rather like a personal preference.
> > IMHO, it's harder to read without space...
> 
> Well, core parts (sched.c?) use it without the space, and I'd say (!
> expression) is unusual in kernel, but no, could not find it codified.

I don't mind much to change it now, but hopefully people won't be too
strict about this rule...

> > I'll fix the volatile things separately.

The access is really over RAM, not MMIO.  So it should be OK to access
in that way.  But volatile seems superfluous.  I'll get rid of it.

Also, msleep() in the removal should be synchronize_irq().

I'll fix these changes and commit with your space fixes to ALSA tree.


Thanks,


Takashi

  reply	other threads:[~2006-08-31 14:53 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-08-31 12:37 Pavel Machek
2006-08-31 13:01 ` Takashi Iwai
2006-08-31 13:39   ` Pavel Machek
2006-08-31 14:53     ` Takashi Iwai [this message]
2006-08-31 22:29       ` Pavel Machek
2006-08-31 18:04   ` CodingStyle (was: Re: sound/pci/hda/intel_hda: small cleanups) Randy.Dunlap
2006-09-02 23:15     ` Pavel Machek
2006-09-03  4:30       ` Randy.Dunlap
2006-09-05  8:08         ` Pavel Machek
2006-09-05 15:26           ` Takashi Iwai
2006-09-05 15:43           ` Randy.Dunlap
2006-09-06  7:23             ` Ingo Oeser
2006-09-06 13:51             ` Pavel Machek
2006-09-06 22:22               ` Chase Venters
2006-09-05 16:40           ` CodingStyle Stefan Richter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5hveo90xdu.wl%tiwai@suse.de \
    --to=tiwai@suse.de \
    --cc=akpm@osdl.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pavel@suse.cz \
    --cc=perex@suse.cz \
    --cc=pshou@realtek.com.tw \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®