mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Catalin Marinas <catalin.marinas@arm.com>
To: Sachin Pandhare <sachinpandhare@gmail.com>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: kmemleak_scan_area
Date: Wed, 31 Mar 2010 13:06:49 +0100	[thread overview]
Message-ID: <tnx7hosy9t2.fsf@e102109-lin.cambridge.arm.com> (raw)
In-Reply-To: <n2m72cf309c1003310300k26b9aacbob7b49ff2f43f949d@mail.gmail.com> (Sachin Pandhare's message of "Wed, 31 Mar 2010 15:30:11 +0530")

Sachin Pandhare <sachinpandhare@gmail.com> wrote:
> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
> well as a function.
> e.g.:
> - struct kmemleak_scan_area {
> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
>
> Do you think it is a good to have it like that?

Does it cause any problems? I think C has different namespaces for types
and functions, so they should not collide. I agree that from a
readability perspective, it would be better if they are named
differently (like kmemleak_scan_area_node :)).

-- 
Catalin

  parent reply	other threads:[~2010-03-31 12:07 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-03-31 10:00 kmemleak_scan_area Sachin Pandhare
2010-03-31 10:10 ` kmemleak_scan_area Sachin Pandhare
2010-03-31 12:06 ` Catalin Marinas [this message]
2010-03-31 12:10   ` kmemleak_scan_area Sachin Pandhare

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=tnx7hosy9t2.fsf@e102109-lin.cambridge.arm.com \
    --to=catalin.marinas@arm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sachinpandhare@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®