mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sachin Pandhare <sachinpandhare@gmail.com>
To: Catalin Marinas <catalin.marinas@arm.com>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: kmemleak_scan_area
Date: Wed, 31 Mar 2010 17:40:25 +0530	[thread overview]
Message-ID: <y2t72cf309c1003310510o87c33ebew5278758fe76556a9@mail.gmail.com> (raw)
In-Reply-To: <tnx7hosy9t2.fsf@e102109-lin.cambridge.arm.com>

On Wed, Mar 31, 2010 at 5:36 PM, Catalin Marinas
<catalin.marinas@arm.com> wrote:
> Sachin Pandhare <sachinpandhare@gmail.com> wrote:
>> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
>> well as a function.
>> e.g.:
>> - struct kmemleak_scan_area {
>> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
>>
>> Do you think it is a good to have it like that?
>
> Does it cause any problems? I think C has different namespaces for types
> and functions, so they should not collide. I agree that from a
> readability perspective, it would be better if they are named
> differently (like kmemleak_scan_area_node :)).

It has not caused any problem.
Thanks,

>
> --
> Catalin

      reply	other threads:[~2010-03-31 12:10 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-03-31 10:00 kmemleak_scan_area Sachin Pandhare
2010-03-31 10:10 ` kmemleak_scan_area Sachin Pandhare
2010-03-31 12:06 ` kmemleak_scan_area Catalin Marinas
2010-03-31 12:10   ` Sachin Pandhare [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=y2t72cf309c1003310510o87c33ebew5278758fe76556a9@mail.gmail.com \
    --to=sachinpandhare@gmail.com \
    --cc=catalin.marinas@arm.com \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®