mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Laight <David.Laight@ACULAB.COM>
To: "'Borislav Petkov'" <bp@alien8.de>, Josh Poimboeuf <jpoimboe@redhat.com>
Cc: X86 ML <x86@kernel.org>, Andy Lutomirski <luto@amacapital.net>,
	"Linus Torvalds" <torvalds@linux-foundation.org>,
	Peter Zijlstra <peterz@infradead.org>,
	LKML <linux-kernel@vger.kernel.org>
Subject: RE: [PATCH 4/9] x86/dumpstack: Improve opcodes dumping in the Code: section
Date: Fri, 16 Mar 2018 11:57:15 +0000	[thread overview]
Message-ID: <107ab804c8f44a9fba4cb52a60ee1f0d@AcuMS.aculab.com> (raw)
In-Reply-To: <20180315181612.GH27816@pd.tnic>

From: Borislav Petkov
> Sent: 15 March 2018 18:16
> On Thu, Mar 15, 2018 at 01:10:54PM -0500, Josh Poimboeuf wrote:
> > I liked OPCODE_BUFSIZE where it was before :-)  Here it disrupts the
> > readability of the function a bit IMO.
> 
> My thinking is have it close by so that you don't have to go search for
> its definition.
> 
> But I don't have a strong opinion on where it should be so...

Is OPCODE_BUFSIZE even needed?
Maybe replace with 64 and use sizeof() and/or ARRAY_SIZE() elsewhere.
Then no one has to check that the bound is appropriate for the array.

	David

  parent reply	other threads:[~2018-03-16 11:56 UTC|newest]

Thread overview: 37+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-03-15 15:44 [PATCH 0/9] x86/dumpstack: Cleanups and user opcode bytes Code: section, v2 Borislav Petkov
2018-03-15 15:44 ` [PATCH 1/9] x86/dumstack: Remove code_bytes Borislav Petkov
2018-03-15 18:12   ` Josh Poimboeuf
2018-03-15 15:44 ` [PATCH 2/9] x86/dumpstack: Unexport oops_begin() Borislav Petkov
2018-03-15 15:44 ` [PATCH 3/9] x86/dumpstack: Carve out Code: dumping into a function Borislav Petkov
2018-03-15 15:44 ` [PATCH 4/9] x86/dumpstack: Improve opcodes dumping in the Code: section Borislav Petkov
2018-03-15 18:10   ` Josh Poimboeuf
2018-03-15 18:16     ` Borislav Petkov
2018-03-15 19:06       ` Josh Poimboeuf
2018-03-16 11:57       ` David Laight [this message]
2018-03-15 18:19   ` Josh Poimboeuf
2018-03-15 18:23   ` Josh Poimboeuf
2018-03-15 15:44 ` [PATCH 5/9] x86/dumpstack: Add loglevel argument to show_opcodes() Borislav Petkov
2018-03-15 15:44 ` [PATCH 6/9] x86/fault: Dump user opcode bytes on fatal faults Borislav Petkov
2018-03-15 15:44 ` [PATCH 7/9] x86/dumpstack: Add a show_ip() function Borislav Petkov
2018-03-15 18:34   ` Josh Poimboeuf
2018-03-15 18:55     ` Borislav Petkov
2018-03-15 15:44 ` [PATCH 8/9] x86/dumpstack: Save first regs set for the executive summary Borislav Petkov
2018-03-15 19:01   ` Josh Poimboeuf
2018-03-16 11:48     ` Borislav Petkov
2018-03-16 12:01       ` Josh Poimboeuf
2018-03-16 12:11         ` Borislav Petkov
2018-03-16 13:16           ` Josh Poimboeuf
2018-03-16 13:44             ` Borislav Petkov
2018-03-16 17:22       ` Linus Torvalds
2018-03-16 17:40         ` Josh Poimboeuf
2018-03-16 17:45         ` Borislav Petkov
2018-03-16 18:38           ` Josh Poimboeuf
2018-03-15 15:44 ` [PATCH 9/9] x86/dumpstack: Explain the reasoning for the prologue and buffer size Borislav Petkov
2018-03-15 18:07   ` Josh Poimboeuf
2018-03-15 18:17     ` Borislav Petkov
2018-03-15 17:51 ` [PATCH 0/9] x86/dumpstack: Cleanups and user opcode bytes Code: section, v2 Linus Torvalds
2018-04-17 14:40   ` Borislav Petkov
2018-04-17 20:16     ` Josh Poimboeuf
2018-04-17 21:06       ` Borislav Petkov
2018-04-18 13:26         ` Josh Poimboeuf
2018-04-17 16:11 [PATCH 0/9] x86/dumpstack: Cleanups and user opcode bytes Code: section, v3 Borislav Petkov
2018-04-17 16:11 ` [PATCH 4/9] x86/dumpstack: Improve opcodes dumping in the Code: section Borislav Petkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=107ab804c8f44a9fba4cb52a60ee1f0d@AcuMS.aculab.com \
    --to=david.laight@aculab.com \
    --cc=bp@alien8.de \
    --cc=jpoimboe@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@amacapital.net \
    --cc=peterz@infradead.org \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome