From: Josh Poimboeuf <jpoimboe@redhat.com>
To: Borislav Petkov <bp@alien8.de>
Cc: X86 ML <x86@kernel.org>, Andy Lutomirski <luto@amacapital.net>,
Linus Torvalds <torvalds@linux-foundation.org>,
Peter Zijlstra <peterz@infradead.org>,
LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 4/9] x86/dumpstack: Improve opcodes dumping in the Code: section
Date: Thu, 15 Mar 2018 13:10:54 -0500 [thread overview]
Message-ID: <20180315181054.3fuuetu6fxpzlpcn@treble> (raw)
In-Reply-To: <20180315154448.16222-5-bp@alien8.de>
On Thu, Mar 15, 2018 at 04:44:43PM +0100, Borislav Petkov wrote:
> From: Borislav Petkov <bp@suse.de>
>
> The code used to iterate byte-by-byte over the bytes around RIP and that
> is expensive: disabling pagefaults around it, copy_from_user, etc...
>
> Make it read the whole buffer of OPCODE_BUFSIZE size in one go. Use a
> statically allocated 64 bytes buffer so that concurrent show_opcodes()
> do not interleave in the output even though in the majority of the cases
> we sync on die_lock. Except the #PF path which doesn't...
>
> Also, do the PAGE_OFFSET check outside of the function because latter
> will be reused in other context.
>
> Signed-off-by: Borislav Petkov <bp@suse.de>
> ---
> arch/x86/kernel/dumpstack.c | 34 ++++++++++++++++------------------
> 1 file changed, 16 insertions(+), 18 deletions(-)
>
> diff --git a/arch/x86/kernel/dumpstack.c b/arch/x86/kernel/dumpstack.c
> index eb9d6c00a52f..3f781a8dddb8 100644
> --- a/arch/x86/kernel/dumpstack.c
> +++ b/arch/x86/kernel/dumpstack.c
> @@ -22,8 +22,6 @@
> #include <asm/stacktrace.h>
> #include <asm/unwind.h>
>
> -#define OPCODE_BUFSIZE 64
> -
> int panic_on_unrecovered_nmi;
> int panic_on_io_nmi;
> static int die_counter;
> @@ -72,29 +70,25 @@ static void printk_stack_address(unsigned long address, int reliable,
>
> static void show_opcodes(u8 *rip)
> {
> - unsigned int code_prologue = OPCODE_BUFSIZE * 43 / 64;
> - unsigned int code_len = OPCODE_BUFSIZE;
> - unsigned char c;
> +#define OPCODE_BUFSIZE 64
> + unsigned int code_prologue = OPCODE_BUFSIZE * 2 / 3;
> + u8 opcodes[OPCODE_BUFSIZE];
I liked OPCODE_BUFSIZE where it was before :-) Here it disrupts the
readability of the function a bit IMO.
--
Josh
next prev parent reply other threads:[~2018-03-15 18:10 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-03-15 15:44 [PATCH 0/9] x86/dumpstack: Cleanups and user opcode bytes Code: section, v2 Borislav Petkov
2018-03-15 15:44 ` [PATCH 1/9] x86/dumstack: Remove code_bytes Borislav Petkov
2018-03-15 18:12 ` Josh Poimboeuf
2018-03-15 15:44 ` [PATCH 2/9] x86/dumpstack: Unexport oops_begin() Borislav Petkov
2018-03-15 15:44 ` [PATCH 3/9] x86/dumpstack: Carve out Code: dumping into a function Borislav Petkov
2018-03-15 15:44 ` [PATCH 4/9] x86/dumpstack: Improve opcodes dumping in the Code: section Borislav Petkov
2018-03-15 18:10 ` Josh Poimboeuf [this message]
2018-03-15 18:16 ` Borislav Petkov
2018-03-15 19:06 ` Josh Poimboeuf
2018-03-16 11:57 ` David Laight
2018-03-15 18:19 ` Josh Poimboeuf
2018-03-15 18:23 ` Josh Poimboeuf
2018-03-15 15:44 ` [PATCH 5/9] x86/dumpstack: Add loglevel argument to show_opcodes() Borislav Petkov
2018-03-15 15:44 ` [PATCH 6/9] x86/fault: Dump user opcode bytes on fatal faults Borislav Petkov
2018-03-15 15:44 ` [PATCH 7/9] x86/dumpstack: Add a show_ip() function Borislav Petkov
2018-03-15 18:34 ` Josh Poimboeuf
2018-03-15 18:55 ` Borislav Petkov
2018-03-15 15:44 ` [PATCH 8/9] x86/dumpstack: Save first regs set for the executive summary Borislav Petkov
2018-03-15 19:01 ` Josh Poimboeuf
2018-03-16 11:48 ` Borislav Petkov
2018-03-16 12:01 ` Josh Poimboeuf
2018-03-16 12:11 ` Borislav Petkov
2018-03-16 13:16 ` Josh Poimboeuf
2018-03-16 13:44 ` Borislav Petkov
2018-03-16 17:22 ` Linus Torvalds
2018-03-16 17:40 ` Josh Poimboeuf
2018-03-16 17:45 ` Borislav Petkov
2018-03-16 18:38 ` Josh Poimboeuf
2018-03-15 15:44 ` [PATCH 9/9] x86/dumpstack: Explain the reasoning for the prologue and buffer size Borislav Petkov
2018-03-15 18:07 ` Josh Poimboeuf
2018-03-15 18:17 ` Borislav Petkov
2018-03-15 17:51 ` [PATCH 0/9] x86/dumpstack: Cleanups and user opcode bytes Code: section, v2 Linus Torvalds
2018-04-17 14:40 ` Borislav Petkov
2018-04-17 20:16 ` Josh Poimboeuf
2018-04-17 21:06 ` Borislav Petkov
2018-04-18 13:26 ` Josh Poimboeuf
2018-04-17 16:11 [PATCH 0/9] x86/dumpstack: Cleanups and user opcode bytes Code: section, v3 Borislav Petkov
2018-04-17 16:11 ` [PATCH 4/9] x86/dumpstack: Improve opcodes dumping in the Code: section Borislav Petkov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180315181054.3fuuetu6fxpzlpcn@treble \
--to=jpoimboe@redhat.com \
--cc=bp@alien8.de \
--cc=linux-kernel@vger.kernel.org \
--cc=luto@amacapital.net \
--cc=peterz@infradead.org \
--cc=torvalds@linux-foundation.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®