mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/5] tracing/workqueue updates
@ 2009-06-01 17:17 Frederic Weisbecker
  2009-06-01 17:17 ` [PATCH 1/5] tracing/workqueue: get rid of searching last executed worklet in probe_worklet_complete() Frederic Weisbecker
                   ` (5 more replies)
  0 siblings, 6 replies; 7+ messages in thread
From: Frederic Weisbecker @ 2009-06-01 17:17 UTC (permalink / raw)
  To: Ingo Molnar
  Cc: LKML, Frederic Weisbecker, Oleg Nesterov, Zhao Lei,
	Anton Blanchard, Steven Rostedt, Andrew Morton

Hi Ingo,

The following patches are fixes and cleanup for the workqueue tracer.

One of them makes the worklet search patch faster.
Some of them fix and sanitize the histogram output and the others clean and
standardize the code.

Thanks.

The following changes since commit c5f0530c4bb2ec77a805cfcf23db09b3e5ab09d4:
  Ingo Molnar (1):
        Merge branch 'tracing/core' into tracing/workqueues

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/frederic/random-tracing.git tracing/workqueue

Anton Blanchard (2):
      tracing/events: use %pf in workqueue trace events
      tracing/events: rename worklet_execute to worklet_entry and worklet_complete to worklet_exit

Zhaolei (3):
      tracing/workqueue: get rid of searching last executed worklet in probe_worklet_complete()
      tracing/workqueue: fix list header and function name format
      tracing/workqueue: cleanup for trace_workqueue.c

 Documentation/trace/workqueue.txt |   12 ++--
 include/trace/events/workqueue.h  |    8 +-
 kernel/trace/trace_workqueue.c    |  124 +++++++++++++++++-------------------
 3 files changed, 69 insertions(+), 75 deletions(-)

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2009-06-01 21:43 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-06-01 17:17 [PATCH 0/5] tracing/workqueue updates Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 1/5] tracing/workqueue: get rid of searching last executed worklet in probe_worklet_complete() Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 2/5] tracing/events: use %pf in workqueue trace events Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 3/5] tracing/events: rename worklet_execute to worklet_entry and worklet_complete to worklet_exit Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 4/5] tracing/workqueue: fix list header and function name format Frederic Weisbecker
2009-06-01 17:17 ` [PATCH 5/5] tracing/workqueue: cleanup for trace_workqueue.c Frederic Weisbecker
2009-06-01 21:42 ` [PATCH 0/5] tracing/workqueue updates Ingo Molnar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®