From: Jason Wessel <jason.wessel@windriver.com>
To: torvalds@linux-foundation.org
Cc: linux-kernel@vger.kernel.org, kgdb-bugreport@lists.sourceforge.net
Subject: [GIT PULL] kgdb,kdb for 2.6.36 (1 of 2)
Date: Thu, 5 Aug 2010 09:37:41 -0500 [thread overview]
Message-ID: <1281019078-6636-1-git-send-email-jason.wessel@windriver.com> (raw)
Linus, please pull the for_linus branch which contains all the core
kgdb and kdb changes intended for the 2.6.36 kernel.
git://git.kernel.org/pub/scm/linux/kernel/git/jwessel/linux-2.6-kgdb.git for_lin
us
The key new features here are:
* ftdump command for kdb
- dumps the ftrace buffer for all cpus or an individual cpu
* Individual register read / write in kdb (x86, mips, arm)
* Generic plumbing for gdb serial register packets 'p' and 'P'
- implementations for x86, mips and arm
* ARM kgdb makes use of die notifiers
* Optimize gdbserial response packets containing "thread:"
The remainder of the patches contain miscellaneous cleanups.
Jason.
---
Andi Kleen (1):
KGDB: Remove set but unused newPC
Andy Shevchenko (1):
kgdb: remove custom hex_to_bin()implementation
Dongdong Deng (1):
kgdb,x86: use macro HBP_NUM to replace magic number 4
Jason Wessel (13):
gdbstub: Optimize kgdb's "thread:" response for the gdb serial protocol
kgdb,kdb: individual register set and and get API
kgdb,x86: Individual register get/set for x86
kgdb,mips: Individual register get/set for mips
kgdb,arm: Individual register get/set for arm
gdbstub: Implement gdbserial 'p' and 'P' packets
gdbstub: do not directly use dbg_reg_def[] in gdb_cmd_reg_set()
arm,kgdb: Add ability to trap into debugger on notify_die
ftrace,kdb: Extend kdb to be able to dump the ftrace buffer
ftrace,kdb: Allow dumping a specific cpu's buffer with ftdump
mm,kdb,kgdb: Add a debug reference for the kdb kmap usage
kgdb,mips: remove unused kgdb_cpu_doing_single_step operations
debug_core,kdb: fix crash when arch does not have single step
Michal Simek (1):
kgdb,powerpc: Replace hardcoded offset by BREAK_INSTR_SIZE
arch/arm/include/asm/kgdb.h | 6 +-
arch/arm/kernel/kgdb.c | 124 ++++++++++++++++---------
arch/mips/include/asm/kgdb.h | 19 ++--
arch/mips/kernel/kgdb.c | 211 +++++++++++++++++++++++++++++-------------
arch/powerpc/kernel/kgdb.c | 2 +-
arch/x86/include/asm/kgdb.h | 20 ++--
arch/x86/kernel/kgdb.c | 189 ++++++++++++++++++-------------------
include/linux/kgdb.h | 15 +++-
kernel/debug/debug_core.c | 2 +
kernel/debug/gdbstub.c | 189 +++++++++++++++++++++++++++-----------
kernel/debug/kdb/kdb_main.c | 132 ++++++++++++++++++++++++---
kernel/trace/Makefile | 3 +
kernel/trace/trace.c | 43 +++++----
kernel/trace/trace.h | 19 ++++
kernel/trace/trace_kdb.c | 136 +++++++++++++++++++++++++++
mm/highmem.c | 7 ++
16 files changed, 801 insertions(+), 316 deletions(-)
create mode 100644 kernel/trace/trace_kdb.c
next reply other threads:[~2010-08-05 14:38 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-08-05 14:37 Jason Wessel [this message]
2010-08-05 14:37 ` [PATCH 01/17] kgdb: remove custom hex_to_bin()implementation Jason Wessel
2010-08-05 14:37 ` [PATCH 02/17] gdbstub: Optimize kgdb's "thread:" response for the gdb serial protocol Jason Wessel
2010-08-05 14:37 ` [PATCH 03/17] kgdb,kdb: individual register set and and get API Jason Wessel
2010-08-05 14:37 ` [PATCH 04/17] kgdb,x86: Individual register get/set for x86 Jason Wessel
2010-08-05 14:37 ` [PATCH 05/17] kgdb,mips: Individual register get/set for mips Jason Wessel
2010-08-05 14:37 ` [PATCH 06/17] kgdb,arm: Individual register get/set for arm Jason Wessel
2010-08-05 14:37 ` [PATCH 07/17] gdbstub: Implement gdbserial 'p' and 'P' packets Jason Wessel
2010-08-05 14:37 ` [PATCH 08/17] gdbstub: do not directly use dbg_reg_def[] in gdb_cmd_reg_set() Jason Wessel
2010-08-05 14:37 ` [PATCH 09/17] arm,kgdb: Add ability to trap into debugger on notify_die Jason Wessel
2010-08-05 14:37 ` [PATCH 10/17] kgdb,powerpc: Replace hardcoded offset by BREAK_INSTR_SIZE Jason Wessel
2010-08-05 14:37 ` [PATCH 11/17] ftrace,kdb: Extend kdb to be able to dump the ftrace buffer Jason Wessel
2010-08-05 14:37 ` [PATCH 12/17] ftrace,kdb: Allow dumping a specific cpu's buffer with ftdump Jason Wessel
2010-08-05 14:37 ` [PATCH 13/17] KGDB: Remove set but unused newPC Jason Wessel
2010-08-05 14:37 ` [PATCH 14/17] mm,kdb,kgdb: Add a debug reference for the kdb kmap usage Jason Wessel
2010-08-05 14:37 ` [PATCH 15/17] kgdb,mips: remove unused kgdb_cpu_doing_single_step operations Jason Wessel
2010-08-05 14:37 ` [PATCH 16/17] kgdb,x86: use macro HBP_NUM to replace magic number 4 Jason Wessel
2010-08-05 14:37 ` [PATCH 17/17] debug_core,kdb: fix crash when arch does not have single step Jason Wessel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1281019078-6636-1-git-send-email-jason.wessel@windriver.com \
--to=jason.wessel@windriver.com \
--cc=kgdb-bugreport@lists.sourceforge.net \
--cc=linux-kernel@vger.kernel.org \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®