From: Jason Wessel <jason.wessel@windriver.com>
To: torvalds@linux-foundation.org
Cc: linux-kernel@vger.kernel.org,
kgdb-bugreport@lists.sourceforge.net,
Jason Wessel <jason.wessel@windriver.com>,
Dongdong Deng <dongdong.deng@windriver.com>,
linux-mips@linux-mips.org
Subject: [PATCH 15/17] kgdb,mips: remove unused kgdb_cpu_doing_single_step operations
Date: Thu, 5 Aug 2010 09:37:56 -0500 [thread overview]
Message-ID: <1281019078-6636-16-git-send-email-jason.wessel@windriver.com> (raw)
In-Reply-To: <1281019078-6636-15-git-send-email-jason.wessel@windriver.com>
The mips kgdb specific code does not support software or HW single
stepping so it should not implement
Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Signed-off-by: Dongdong Deng <dongdong.deng@windriver.com>
Acked-by: Ralf Baechle <ralf@linux-mips.org>
CC: linux-mips@linux-mips.org
---
arch/mips/kernel/kgdb.c | 8 +-------
1 files changed, 1 insertions(+), 7 deletions(-)
diff --git a/arch/mips/kernel/kgdb.c b/arch/mips/kernel/kgdb.c
index 5e76c2d..1f4e2fa 100644
--- a/arch/mips/kernel/kgdb.c
+++ b/arch/mips/kernel/kgdb.c
@@ -329,7 +329,7 @@ static struct notifier_block kgdb_notifier = {
};
/*
- * Handle the 's' and 'c' commands
+ * Handle the 'c' command
*/
int kgdb_arch_handle_exception(int vector, int signo, int err_code,
char *remcom_in_buffer, char *remcom_out_buffer,
@@ -337,20 +337,14 @@ int kgdb_arch_handle_exception(int vector, int signo, int err_code,
{
char *ptr;
unsigned long address;
- int cpu = smp_processor_id();
switch (remcom_in_buffer[0]) {
- case 's':
case 'c':
/* handle the optional parameter */
ptr = &remcom_in_buffer[1];
if (kgdb_hex2long(&ptr, &address))
regs->cp0_epc = address;
- atomic_set(&kgdb_cpu_doing_single_step, -1);
- if (remcom_in_buffer[0] == 's')
- atomic_set(&kgdb_cpu_doing_single_step, cpu);
-
return 0;
}
--
1.6.3.3
next prev parent reply other threads:[~2010-08-05 14:40 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-08-05 14:37 [GIT PULL] kgdb,kdb for 2.6.36 (1 of 2) Jason Wessel
2010-08-05 14:37 ` [PATCH 01/17] kgdb: remove custom hex_to_bin()implementation Jason Wessel
2010-08-05 14:37 ` [PATCH 02/17] gdbstub: Optimize kgdb's "thread:" response for the gdb serial protocol Jason Wessel
2010-08-05 14:37 ` [PATCH 03/17] kgdb,kdb: individual register set and and get API Jason Wessel
2010-08-05 14:37 ` [PATCH 04/17] kgdb,x86: Individual register get/set for x86 Jason Wessel
2010-08-05 14:37 ` [PATCH 05/17] kgdb,mips: Individual register get/set for mips Jason Wessel
2010-08-05 14:37 ` [PATCH 06/17] kgdb,arm: Individual register get/set for arm Jason Wessel
2010-08-05 14:37 ` [PATCH 07/17] gdbstub: Implement gdbserial 'p' and 'P' packets Jason Wessel
2010-08-05 14:37 ` [PATCH 08/17] gdbstub: do not directly use dbg_reg_def[] in gdb_cmd_reg_set() Jason Wessel
2010-08-05 14:37 ` [PATCH 09/17] arm,kgdb: Add ability to trap into debugger on notify_die Jason Wessel
2010-08-05 14:37 ` [PATCH 10/17] kgdb,powerpc: Replace hardcoded offset by BREAK_INSTR_SIZE Jason Wessel
2010-08-05 14:37 ` [PATCH 11/17] ftrace,kdb: Extend kdb to be able to dump the ftrace buffer Jason Wessel
2010-08-05 14:37 ` [PATCH 12/17] ftrace,kdb: Allow dumping a specific cpu's buffer with ftdump Jason Wessel
2010-08-05 14:37 ` [PATCH 13/17] KGDB: Remove set but unused newPC Jason Wessel
2010-08-05 14:37 ` [PATCH 14/17] mm,kdb,kgdb: Add a debug reference for the kdb kmap usage Jason Wessel
2010-08-05 14:37 ` Jason Wessel [this message]
2010-08-05 14:37 ` [PATCH 16/17] kgdb,x86: use macro HBP_NUM to replace magic number 4 Jason Wessel
2010-08-05 14:37 ` [PATCH 17/17] debug_core,kdb: fix crash when arch does not have single step Jason Wessel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1281019078-6636-16-git-send-email-jason.wessel@windriver.com \
--to=jason.wessel@windriver.com \
--cc=dongdong.deng@windriver.com \
--cc=kgdb-bugreport@lists.sourceforge.net \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mips@linux-mips.org \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®