From: Tejun Heo <tj@kernel.org>
To: linux-kernel@vger.kernel.org, x86@kernel.org, yinghai@kernel.org,
brgerst@gmail.com, gorcunov@gmail.com, shaohui.zheng@intel.com,
rientjes@google.com, mingo@elte.hu, hpa@linux.intel.com
Cc: Tejun Heo <tj@kernel.org>
Subject: [PATCH 20/26] x86-64, NUMA: make numa_cleanup_meminfo() prettier
Date: Sat, 12 Feb 2011 18:10:57 +0100 [thread overview]
Message-ID: <1297530663-26234-21-git-send-email-tj@kernel.org> (raw)
In-Reply-To: <1297530663-26234-1-git-send-email-tj@kernel.org>
* Factor out numa_remove_memblk_from().
* Hole detection doesn't need separate start/end. Calculate start/end
once.
* Relocate comment.
* Define iterators at the top and remove unnecessary prefix
increments.
This prepares for further improvements to the function.
Signed-off-by: Tejun Heo <tj@kernel.org>
Cc: Yinghai Lu <yinghai@kernel.org>
Cc: Brian Gerst <brgerst@gmail.com>
Cc: Cyrill Gorcunov <gorcunov@gmail.com>
Cc: Shaohui Zheng <shaohui.zheng@intel.com>
Cc: David Rientjes <rientjes@google.com>
Cc: Ingo Molnar <mingo@elte.hu>
Cc: H. Peter Anvin <hpa@linux.intel.com>
---
arch/x86/mm/numa_64.c | 36 +++++++++++++++++++-----------------
1 files changed, 19 insertions(+), 17 deletions(-)
diff --git a/arch/x86/mm/numa_64.c b/arch/x86/mm/numa_64.c
index 4f173a5..62ba1fd 100644
--- a/arch/x86/mm/numa_64.c
+++ b/arch/x86/mm/numa_64.c
@@ -230,6 +230,13 @@ int __init numa_add_memblk(int nid, u64 start, u64 end)
return 0;
}
+static void __init numa_remove_memblk_from(int idx, struct numa_meminfo *mi)
+{
+ mi->nr_blks--;
+ memmove(&mi->blk[idx], &mi->blk[idx + 1],
+ (mi->nr_blks - idx) * sizeof(mi->blk[0]));
+}
+
static __init void cutoff_node(int i, unsigned long start, unsigned long end)
{
struct bootnode *nd = &numa_nodes[i];
@@ -294,25 +301,25 @@ setup_node_bootmem(int nodeid, unsigned long start, unsigned long end)
static int __init numa_cleanup_meminfo(struct numa_meminfo *mi)
{
- int i;
+ int i, j, k;
- /*
- * Join together blocks on the same node, holes between
- * which don't overlap with memory on other nodes.
- */
- for (i = 0; i < mi->nr_blks; ++i) {
+ for (i = 0; i < mi->nr_blks; i++) {
struct numa_memblk *bi = &mi->blk[i];
- int j, k;
- for (j = i + 1; j < mi->nr_blks; ++j) {
+ for (j = i + 1; j < mi->nr_blks; j++) {
struct numa_memblk *bj = &mi->blk[j];
unsigned long start, end;
+ /*
+ * Join together blocks on the same node, holes
+ * between which don't overlap with memory on other
+ * nodes.
+ */
if (bi->nid != bj->nid)
continue;
- start = min(bi->end, bj->end);
- end = max(bi->start, bj->start);
- for (k = 0; k < mi->nr_blks; ++k) {
+ start = min(bi->start, bj->start);
+ end = max(bi->end, bj->end);
+ for (k = 0; k < mi->nr_blks; k++) {
struct numa_memblk *bk = &mi->blk[k];
if (bi->nid == bk->nid)
@@ -322,17 +329,12 @@ static int __init numa_cleanup_meminfo(struct numa_meminfo *mi)
}
if (k < mi->nr_blks)
continue;
- start = min(bi->start, bj->start);
- end = max(bi->end, bj->end);
printk(KERN_INFO "NUMA: Node %d [%Lx,%Lx) + [%Lx,%Lx) -> [%lx,%lx)\n",
bi->nid, bi->start, bi->end, bj->start, bj->end,
start, end);
bi->start = start;
bi->end = end;
- k = --mi->nr_blks - j;
- memmove(mi->blk + j, mi->blk + j + 1,
- k * sizeof(mi->blk[0]));
- --j;
+ numa_remove_memblk_from(j--, mi);
}
}
--
1.7.1
next prev parent reply other threads:[~2011-02-12 17:13 UTC|newest]
Thread overview: 77+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-02-12 17:10 [PATCHSET x86/numa] x86-64, NUMA: bring sanity to NUMA configuration Tejun Heo
2011-02-12 17:10 ` [PATCH 01/26] x86-64, NUMA: Make dummy node initialization path similar to non-dummy ones Tejun Heo
2011-02-12 17:52 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 02/26] x86-64, NUMA: Simplify hotplug node handling in acpi_numa_memory_affinity_init() Tejun Heo
2011-02-12 17:47 ` Yinghai Lu
2011-02-12 17:56 ` Tejun Heo
2011-02-12 18:04 ` Yinghai Lu
2011-02-12 18:06 ` Tejun Heo
2011-02-12 18:13 ` Yinghai Lu
2011-02-14 11:25 ` Tejun Heo
2011-02-14 16:12 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 03/26] x86-64, NUMA: Drop @start/last_pfn from initmem_init() Tejun Heo
2011-02-12 17:58 ` Yinghai Lu
2011-02-12 18:03 ` Tejun Heo
2011-02-14 13:50 ` [PATCH UPDATED 03/26] x86, NUMA: Drop @start/last_pfn from initmem_init() initmem_init() Tejun Heo
2011-02-14 14:20 ` Ingo Molnar
2011-02-14 14:58 ` Tejun Heo
2011-02-14 19:03 ` Yinghai Lu
2011-02-14 19:31 ` Tejun Heo
2011-02-15 2:29 ` Ingo Molnar
2011-02-12 17:10 ` [PATCH 04/26] x86-64, NUMA: Unify {acpi|amd}_{numa_init|scan_nodes}() arguments and return values Tejun Heo
2011-02-12 18:39 ` Yinghai Lu
2011-02-14 11:29 ` Tejun Heo
2011-02-14 16:14 ` Yinghai Lu
2011-02-14 16:18 ` Tejun Heo
2011-02-14 18:00 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 05/26] x86-64, NUMA: Wrap acpi_numa_init() so that failure can be indicated by return value Tejun Heo
2011-02-12 17:10 ` [PATCH 06/26] x86-64, NUMA: Move *_numa_init() invocations into initmem_init() Tejun Heo
2011-02-14 6:10 ` Ankita Garg
2011-02-14 11:09 ` Tejun Heo
2011-02-14 13:51 ` [PATCH UPDATED 06/26] x86, " Tejun Heo
2011-02-14 14:21 ` Ingo Molnar
2011-02-12 17:10 ` [PATCH 07/26] x86-64, NUMA: Restructure initmem_init() Tejun Heo
2011-02-12 17:10 ` [PATCH 08/26] x86-64, NUMA: Use common {cpu|mem}_nodes_parsed Tejun Heo
2011-02-12 17:10 ` [PATCH 09/26] x86-64, NUMA: Remove local variable found from amd_numa_init() Tejun Heo
2011-02-12 17:10 ` [PATCH 10/26] x86-64, NUMA: Move apicid to numa mapping initialization from amd_scan_nodes() to amd_numa_init() Tejun Heo
2011-02-14 22:59 ` Cyrill Gorcunov
2011-02-15 9:36 ` Tejun Heo
2011-02-15 17:31 ` Cyrill Gorcunov
2011-02-15 17:54 ` Yinghai Lu
2011-02-15 18:01 ` Cyrill Gorcunov
2011-02-15 18:27 ` Cyrill Gorcunov
2011-02-15 19:41 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 11/26] x86-64, NUMA: Use common numa_nodes[] Tejun Heo
2011-02-12 17:10 ` [PATCH 12/26] x86-64, NUMA: Kill {acpi|amd}_get_nodes() Tejun Heo
2011-02-12 17:10 ` [PATCH 13/26] x86-64, NUMA: Factor out memblk handling into numa_{add|register}_memblk() Tejun Heo
2011-02-12 17:10 ` [PATCH 14/26] x86-64, NUMA: Unify use of memblk in all init methods Tejun Heo
2011-02-12 17:10 ` [PATCH 15/26] x86-64, NUMA: Unify the rest of memblk registration Tejun Heo
2011-02-13 0:45 ` Yinghai Lu
2011-02-14 11:32 ` Tejun Heo
2011-02-14 16:08 ` Yinghai Lu
2011-02-14 16:12 ` Tejun Heo
2011-02-14 16:17 ` Yinghai Lu
2011-02-14 16:22 ` Tejun Heo
2011-02-14 18:14 ` Yinghai Lu
2011-02-14 18:27 ` Tejun Heo
2011-02-14 19:07 ` Yinghai Lu
2011-02-14 19:30 ` Tejun Heo
2011-02-14 19:35 ` Yinghai Lu
2011-02-15 9:11 ` Tejun Heo
2011-02-15 9:43 ` Ingo Molnar
2011-02-15 16:49 ` Tejun Heo
2011-02-16 8:41 ` Ingo Molnar
2011-02-16 8:48 ` Ingo Molnar
2011-02-16 9:01 ` Tejun Heo
2011-02-16 9:31 ` Ingo Molnar
2011-02-12 17:10 ` [PATCH 16/26] x86-64, NUMA: Kill {acpi|amd|dummy}_scan_nodes() Tejun Heo
2011-02-12 17:10 ` [PATCH 17/26] x86-64, NUMA: Remove %NULL @nodeids handling from compute_hash_shift() Tejun Heo
2011-02-12 17:10 ` [PATCH 18/26] x86-64, NUMA: Introduce struct numa_meminfo Tejun Heo
2011-02-12 17:10 ` [PATCH 19/26] x86-64, NUMA: Separate out numa_cleanup_meminfo() Tejun Heo
2011-02-12 17:10 ` Tejun Heo [this message]
2011-02-12 17:10 ` [PATCH 21/26] x86-64, NUMA: consolidate and improve memblk sanity checks Tejun Heo
2011-02-12 17:10 ` [PATCH 22/26] x86-64, NUMA: Add common find_node_by_addr() Tejun Heo
2011-02-12 17:11 ` [PATCH 23/26] x86-64, NUMA: kill numa_nodes[] Tejun Heo
2011-02-12 17:11 ` [PATCH 24/26] x86-64, NUMA: Rename cpu_nodes_parsed to numa_nodes_parsed Tejun Heo
2011-02-12 17:11 ` [PATCH 25/26] x86-64, NUMA: Kill mem_nodes_parsed Tejun Heo
2011-02-12 17:11 ` [PATCH 26/26] x86-64, NUMA: Implement generic node distance handling Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1297530663-26234-21-git-send-email-tj@kernel.org \
--to=tj@kernel.org \
--cc=brgerst@gmail.com \
--cc=gorcunov@gmail.com \
--cc=hpa@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=rientjes@google.com \
--cc=shaohui.zheng@intel.com \
--cc=x86@kernel.org \
--cc=yinghai@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome