From: Yinghai Lu <yinghai@kernel.org>
To: Tejun Heo <tj@kernel.org>
Cc: linux-kernel@vger.kernel.org, x86@kernel.org, brgerst@gmail.com,
gorcunov@gmail.com, shaohui.zheng@intel.com, rientjes@google.com,
mingo@elte.hu, hpa@linux.intel.com
Subject: Re: [PATCH 15/26] x86-64, NUMA: Unify the rest of memblk registration
Date: Mon, 14 Feb 2011 11:07:02 -0800 [thread overview]
Message-ID: <4D597D56.5060408@kernel.org> (raw)
In-Reply-To: <20110214182718.GB18742@htj.dyndns.org>
On 02/14/2011 10:27 AM, Tejun Heo wrote:
> Hello,
>
> On Mon, Feb 14, 2011 at 10:14:15AM -0800, Yinghai Lu wrote:
>> I just want seperate setup_bootmem ( and maybe init_memory_mapping_high...)
>> out that __register__ function.
>>
>> that __register__ function do some sth like memblock_register to
>> early_node_map[] looks reasonable.
>
> Can you please provide some rationales _why_ you think setup_bootmem()
> should be moved elsewhere? Because it is not apparent to me and I
> cannot read your mind. I'm not against it given good enough reasons.
> After all, _technically_ it doesn't make one iota of difference, but I
> don't want to change it just because you don't like it and I don't
> think you want that either, so _please_ give me some explanations
> about what you want and _why_. It's not like we're involved in a
> romantic relationship and even when I'm in one I suck at that implied
> communication thing.
Never mind. will send out patch after your patches get merged into tip.
BTW, you may need to rebase your on top of tip/master.
Thanks
Yinghai
next prev parent reply other threads:[~2011-02-14 19:08 UTC|newest]
Thread overview: 77+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-02-12 17:10 [PATCHSET x86/numa] x86-64, NUMA: bring sanity to NUMA configuration Tejun Heo
2011-02-12 17:10 ` [PATCH 01/26] x86-64, NUMA: Make dummy node initialization path similar to non-dummy ones Tejun Heo
2011-02-12 17:52 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 02/26] x86-64, NUMA: Simplify hotplug node handling in acpi_numa_memory_affinity_init() Tejun Heo
2011-02-12 17:47 ` Yinghai Lu
2011-02-12 17:56 ` Tejun Heo
2011-02-12 18:04 ` Yinghai Lu
2011-02-12 18:06 ` Tejun Heo
2011-02-12 18:13 ` Yinghai Lu
2011-02-14 11:25 ` Tejun Heo
2011-02-14 16:12 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 03/26] x86-64, NUMA: Drop @start/last_pfn from initmem_init() Tejun Heo
2011-02-12 17:58 ` Yinghai Lu
2011-02-12 18:03 ` Tejun Heo
2011-02-14 13:50 ` [PATCH UPDATED 03/26] x86, NUMA: Drop @start/last_pfn from initmem_init() initmem_init() Tejun Heo
2011-02-14 14:20 ` Ingo Molnar
2011-02-14 14:58 ` Tejun Heo
2011-02-14 19:03 ` Yinghai Lu
2011-02-14 19:31 ` Tejun Heo
2011-02-15 2:29 ` Ingo Molnar
2011-02-12 17:10 ` [PATCH 04/26] x86-64, NUMA: Unify {acpi|amd}_{numa_init|scan_nodes}() arguments and return values Tejun Heo
2011-02-12 18:39 ` Yinghai Lu
2011-02-14 11:29 ` Tejun Heo
2011-02-14 16:14 ` Yinghai Lu
2011-02-14 16:18 ` Tejun Heo
2011-02-14 18:00 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 05/26] x86-64, NUMA: Wrap acpi_numa_init() so that failure can be indicated by return value Tejun Heo
2011-02-12 17:10 ` [PATCH 06/26] x86-64, NUMA: Move *_numa_init() invocations into initmem_init() Tejun Heo
2011-02-14 6:10 ` Ankita Garg
2011-02-14 11:09 ` Tejun Heo
2011-02-14 13:51 ` [PATCH UPDATED 06/26] x86, " Tejun Heo
2011-02-14 14:21 ` Ingo Molnar
2011-02-12 17:10 ` [PATCH 07/26] x86-64, NUMA: Restructure initmem_init() Tejun Heo
2011-02-12 17:10 ` [PATCH 08/26] x86-64, NUMA: Use common {cpu|mem}_nodes_parsed Tejun Heo
2011-02-12 17:10 ` [PATCH 09/26] x86-64, NUMA: Remove local variable found from amd_numa_init() Tejun Heo
2011-02-12 17:10 ` [PATCH 10/26] x86-64, NUMA: Move apicid to numa mapping initialization from amd_scan_nodes() to amd_numa_init() Tejun Heo
2011-02-14 22:59 ` Cyrill Gorcunov
2011-02-15 9:36 ` Tejun Heo
2011-02-15 17:31 ` Cyrill Gorcunov
2011-02-15 17:54 ` Yinghai Lu
2011-02-15 18:01 ` Cyrill Gorcunov
2011-02-15 18:27 ` Cyrill Gorcunov
2011-02-15 19:41 ` Yinghai Lu
2011-02-12 17:10 ` [PATCH 11/26] x86-64, NUMA: Use common numa_nodes[] Tejun Heo
2011-02-12 17:10 ` [PATCH 12/26] x86-64, NUMA: Kill {acpi|amd}_get_nodes() Tejun Heo
2011-02-12 17:10 ` [PATCH 13/26] x86-64, NUMA: Factor out memblk handling into numa_{add|register}_memblk() Tejun Heo
2011-02-12 17:10 ` [PATCH 14/26] x86-64, NUMA: Unify use of memblk in all init methods Tejun Heo
2011-02-12 17:10 ` [PATCH 15/26] x86-64, NUMA: Unify the rest of memblk registration Tejun Heo
2011-02-13 0:45 ` Yinghai Lu
2011-02-14 11:32 ` Tejun Heo
2011-02-14 16:08 ` Yinghai Lu
2011-02-14 16:12 ` Tejun Heo
2011-02-14 16:17 ` Yinghai Lu
2011-02-14 16:22 ` Tejun Heo
2011-02-14 18:14 ` Yinghai Lu
2011-02-14 18:27 ` Tejun Heo
2011-02-14 19:07 ` Yinghai Lu [this message]
2011-02-14 19:30 ` Tejun Heo
2011-02-14 19:35 ` Yinghai Lu
2011-02-15 9:11 ` Tejun Heo
2011-02-15 9:43 ` Ingo Molnar
2011-02-15 16:49 ` Tejun Heo
2011-02-16 8:41 ` Ingo Molnar
2011-02-16 8:48 ` Ingo Molnar
2011-02-16 9:01 ` Tejun Heo
2011-02-16 9:31 ` Ingo Molnar
2011-02-12 17:10 ` [PATCH 16/26] x86-64, NUMA: Kill {acpi|amd|dummy}_scan_nodes() Tejun Heo
2011-02-12 17:10 ` [PATCH 17/26] x86-64, NUMA: Remove %NULL @nodeids handling from compute_hash_shift() Tejun Heo
2011-02-12 17:10 ` [PATCH 18/26] x86-64, NUMA: Introduce struct numa_meminfo Tejun Heo
2011-02-12 17:10 ` [PATCH 19/26] x86-64, NUMA: Separate out numa_cleanup_meminfo() Tejun Heo
2011-02-12 17:10 ` [PATCH 20/26] x86-64, NUMA: make numa_cleanup_meminfo() prettier Tejun Heo
2011-02-12 17:10 ` [PATCH 21/26] x86-64, NUMA: consolidate and improve memblk sanity checks Tejun Heo
2011-02-12 17:10 ` [PATCH 22/26] x86-64, NUMA: Add common find_node_by_addr() Tejun Heo
2011-02-12 17:11 ` [PATCH 23/26] x86-64, NUMA: kill numa_nodes[] Tejun Heo
2011-02-12 17:11 ` [PATCH 24/26] x86-64, NUMA: Rename cpu_nodes_parsed to numa_nodes_parsed Tejun Heo
2011-02-12 17:11 ` [PATCH 25/26] x86-64, NUMA: Kill mem_nodes_parsed Tejun Heo
2011-02-12 17:11 ` [PATCH 26/26] x86-64, NUMA: Implement generic node distance handling Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4D597D56.5060408@kernel.org \
--to=yinghai@kernel.org \
--cc=brgerst@gmail.com \
--cc=gorcunov@gmail.com \
--cc=hpa@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=rientjes@google.com \
--cc=shaohui.zheng@intel.com \
--cc=tj@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome