From: Florian Fainelli <florian@openwrt.org>
To: stern@rowland.harvard.edu
Cc: linux-usb@vger.kernel.org, Florian Fainelli <florian@openwrt.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-kernel@vger.kernel.org
Subject: [PATCH 13/32 v3] USB: ohci: move ohci_pci_{suspend,resume} to ohci-hcd.c
Date: Mon, 8 Oct 2012 15:11:27 +0200 [thread overview]
Message-ID: <1349701906-16481-14-git-send-email-florian@openwrt.org> (raw)
In-Reply-To: <1349701906-16481-1-git-send-email-florian@openwrt.org>
As suggested by Alan Stern, move the ohci-pci.c ohci_pci_{suspend,resume}
routines to ohci-hcd.c. Due to their move, also rename them to
ohci_{suspend,resume} to make it clear they operate on ohci_hcd. Since they
are not necessarily called, annotate them with __maybe_unused, and make them
enclosed within an #ifdef CONFIG_PM / #endif section.
Signed-off-by: Florian Fainelli <florian@openwrt.org>
---
Changes in v3:
- moved ohci_{suspend,resume} within a #ifdef CONFIG_PM block as needed
- rebased against greg's latest usb-next
Changes in v2:
- moved ohci_{suspend,resume} out of the #ifdef CONFIG_PM block
- removed the empty CONFIG_PM #ifdef/endif block in ohci-pci.c
drivers/usb/host/ohci-hcd.c | 43 +++++++++++++++++++++++++++++++++++++++
drivers/usb/host/ohci-pci.c | 47 ++-----------------------------------------
2 files changed, 45 insertions(+), 45 deletions(-)
diff --git a/drivers/usb/host/ohci-hcd.c b/drivers/usb/host/ohci-hcd.c
index fd97801..9171599 100644
--- a/drivers/usb/host/ohci-hcd.c
+++ b/drivers/usb/host/ohci-hcd.c
@@ -983,6 +983,49 @@ static int ohci_restart (struct ohci_hcd *ohci)
#endif
+#ifdef CONFIG_PM
+
+static int __maybe_unused ohci_suspend(struct usb_hcd *hcd, bool do_wakeup)
+{
+ struct ohci_hcd *ohci = hcd_to_ohci (hcd);
+ unsigned long flags;
+ int rc = 0;
+
+ /* Root hub was already suspended. Disable irq emission and
+ * mark HW unaccessible, bail out if RH has been resumed. Use
+ * the spinlock to properly synchronize with possible pending
+ * RH suspend or resume activity.
+ */
+ spin_lock_irqsave (&ohci->lock, flags);
+ if (ohci->rh_state != OHCI_RH_SUSPENDED) {
+ rc = -EINVAL;
+ goto bail;
+ }
+ ohci_writel(ohci, OHCI_INTR_MIE, &ohci->regs->intrdisable);
+ (void)ohci_readl(ohci, &ohci->regs->intrdisable);
+
+ clear_bit(HCD_FLAG_HW_ACCESSIBLE, &hcd->flags);
+ bail:
+ spin_unlock_irqrestore (&ohci->lock, flags);
+
+ return rc;
+}
+
+
+static int __maybe_unused ohci_resume(struct usb_hcd *hcd, bool hibernated)
+{
+ set_bit(HCD_FLAG_HW_ACCESSIBLE, &hcd->flags);
+
+ /* Make sure resume from hibernation re-enumerates everything */
+ if (hibernated)
+ ohci_usb_reset(hcd_to_ohci(hcd));
+
+ ohci_finish_controller_resume(hcd);
+ return 0;
+}
+
+#endif
+
/*-------------------------------------------------------------------------*/
MODULE_AUTHOR (DRIVER_AUTHOR);
diff --git a/drivers/usb/host/ohci-pci.c b/drivers/usb/host/ohci-pci.c
index 1843bb6..6afa7dc 100644
--- a/drivers/usb/host/ohci-pci.c
+++ b/drivers/usb/host/ohci-pci.c
@@ -296,49 +296,6 @@ static int __devinit ohci_pci_start (struct usb_hcd *hcd)
return ret;
}
-#ifdef CONFIG_PM
-
-static int ohci_pci_suspend(struct usb_hcd *hcd, bool do_wakeup)
-{
- struct ohci_hcd *ohci = hcd_to_ohci (hcd);
- unsigned long flags;
- int rc = 0;
-
- /* Root hub was already suspended. Disable irq emission and
- * mark HW unaccessible, bail out if RH has been resumed. Use
- * the spinlock to properly synchronize with possible pending
- * RH suspend or resume activity.
- */
- spin_lock_irqsave (&ohci->lock, flags);
- if (ohci->rh_state != OHCI_RH_SUSPENDED) {
- rc = -EINVAL;
- goto bail;
- }
- ohci_writel(ohci, OHCI_INTR_MIE, &ohci->regs->intrdisable);
- (void)ohci_readl(ohci, &ohci->regs->intrdisable);
-
- clear_bit(HCD_FLAG_HW_ACCESSIBLE, &hcd->flags);
- bail:
- spin_unlock_irqrestore (&ohci->lock, flags);
-
- return rc;
-}
-
-
-static int ohci_pci_resume(struct usb_hcd *hcd, bool hibernated)
-{
- set_bit(HCD_FLAG_HW_ACCESSIBLE, &hcd->flags);
-
- /* Make sure resume from hibernation re-enumerates everything */
- if (hibernated)
- ohci_usb_reset(hcd_to_ohci(hcd));
-
- ohci_finish_controller_resume(hcd);
- return 0;
-}
-
-#endif /* CONFIG_PM */
-
/*-------------------------------------------------------------------------*/
@@ -362,8 +319,8 @@ static const struct hc_driver ohci_pci_hc_driver = {
.shutdown = ohci_shutdown,
#ifdef CONFIG_PM
- .pci_suspend = ohci_pci_suspend,
- .pci_resume = ohci_pci_resume,
+ .pci_suspend = ohci_suspend,
+ .pci_resume = ohci_resume,
#endif
/*
--
1.7.9.5
next prev parent reply other threads:[~2012-10-08 13:14 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1349701906-16481-1-git-send-email-florian@openwrt.org>
2012-10-08 13:11 ` [PATCH 01/32 v4] USB: EHCI: remove IXP4xx EHCI driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 02/32 v2] USB: OHCI: remove ohci-pcc-soc driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 03/32 v4] MIPS: Loongson 1B: use ehci-platform instead of ehci-ls1x Florian Fainelli
[not found] ` <CAJhJPsV5mFmOgU38ZpnYqUTNuOPmvRXjsf31XdFUqNOzsd_Edg@mail.gmail.com>
2012-10-23 8:46 ` Florian Fainelli
2012-10-23 8:53 ` Florian Fainelli
2012-10-08 13:11 ` [PATCH 04/32 v4] USB: EHCI: remove Loongson 1B EHCI driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 05/32 v4] MIPS: Netlogic: use ehci-platform driver Florian Fainelli
2012-10-08 14:06 ` Jayachandran C.
2012-10-08 13:11 ` [PATCH 06/32 v4] USB: EHCI: remove Netlogic XLS EHCI driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 07/32 v4] USB: EHCI: add no_io_watchdog platform_data parameter to ehci-platform Florian Fainelli
2012-10-08 13:11 ` [PATCH 08/32 v4] MIPS: Alchemy: use the ehci platform driver Florian Fainelli
2012-10-22 18:19 ` Greg KH
2012-10-08 13:11 ` [PATCH 09/32 v4] USB: EHCI: remove Alchemy EHCI driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 10/32 v4] ARM: cns3xxx: use ehci platform driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 11/32 v4] USB: EHCI: remove CNS3xxx EHCI " Florian Fainelli
2012-10-08 13:11 ` [PATCH 12/32 v4] USB: ohci: allow platform driver to specify the number of ports Florian Fainelli
2012-10-08 13:11 ` Florian Fainelli [this message]
2012-10-08 13:11 ` [PATCH 14/32 v3] USB: ohci: remove check for RH already suspended in ohci_suspend Florian Fainelli
2012-10-08 13:11 ` [PATCH 15/32 v3] USB: ohci: merge ohci_finish_controller_resume with ohci_resume Florian Fainelli
2012-10-08 13:11 ` [PATCH 16/32 v4] MIPS: PNX8550: use OHCI platform driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 17/32 v4] USB: OHCI: remove PNX8550 OHCI driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 18/32 v4] ARM: cns3xxx: use OHCI platform driver Florian Fainelli
2012-10-08 13:11 ` [PATCH 19/32 v4] USB: OHCI: remove CNS3xxx " Florian Fainelli
2012-10-08 13:11 ` [PATCH 20/32 v4] MIPS: Netlogic: convert to use " Florian Fainelli
2012-10-08 13:11 ` [PATCH 21/32 v4] USB: OHCI: remove Netlogic XLS " Florian Fainelli
2012-10-08 13:11 ` [PATCH 22/32 v4] sh: convert boards to use the " Florian Fainelli
2012-10-08 13:11 ` [PATCH 23/32 v4] USB: OHCI: remove OHCI SH " Florian Fainelli
2012-10-08 13:11 ` [PATCH 24/32 v4] MIPS: Alchemy: use the OHCI " Florian Fainelli
2012-10-22 18:27 ` Greg KH
2012-10-08 13:11 ` [PATCH 25/32 v4] USB: OHCI: remove Alchemy " Florian Fainelli
2012-10-08 13:11 ` [PATCH 26/32 v2] USB: move common alchemy USB routines to arch/mips/alchemy/common.c Florian Fainelli
2012-10-08 13:11 ` [PATCH 27/32 v2] USB: EHCI: make ehci-platform use dev_err() instead of pr_err() Florian Fainelli
2012-10-08 13:11 ` [PATCH 28/32 v2] USB: OHCI: make ohci-platform " Florian Fainelli
2012-10-08 13:11 ` [PATCH 29/32 v2] USB: EHCI: fix typo in ehci-platform driver on the word "resource" Florian Fainelli
2012-10-08 13:11 ` [PATCH 30/32 v2] USB: OHCI: fix typo in ohci-platform " Florian Fainelli
2012-10-08 13:11 ` [PATCH 31/32 v3] USB: EHCI: make ehci-platform use devm_request_and_ioremap helper Florian Fainelli
2012-10-08 13:11 ` [PATCH 32/32 v3] USB: OHCI: make ohci-platform " Florian Fainelli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1349701906-16481-14-git-send-email-florian@openwrt.org \
--to=florian@openwrt.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome