* [PATCH 1/6] staging: line6: rename MidiBuffer to avoid CamelCase
2013-01-11 22:08 [PATCH 0/6] staging: line6: more checkpatch.pl warnings fixes Stefan Hajnoczi
@ 2013-01-11 22:08 ` Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 2/6] staging: line6: wrap comment to 80 chars in driver.c Stefan Hajnoczi
` (4 subsequent siblings)
5 siblings, 0 replies; 7+ messages in thread
From: Stefan Hajnoczi @ 2013-01-11 22:08 UTC (permalink / raw)
To: devel
Cc: Markus Grabner, Greg Kroah-Hartman, line6linux-devel,
linux-kernel, Laurent Navet, Stefan Hajnoczi
Fix checkpatch.pl warnings related to MidiBuffer:
WARNING: Avoid CamelCase: <MidiBuffer>
#947: FILE: staging/line6/driver.c:363:
+ struct MidiBuffer *mb = &line6->line6midi->midibuf_in;
Rename MidiBuffer to midi_buffer.
Note that "midibuf" would be another good name but sound/oss/midibuf.c
already uses it for a different concept. Avoid possible confusion by
using "midi_buffer" instead.
Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
---
drivers/staging/line6/driver.c | 2 +-
drivers/staging/line6/midi.c | 2 +-
drivers/staging/line6/midi.h | 4 ++--
drivers/staging/line6/midibuf.c | 25 +++++++++++++------------
drivers/staging/line6/midibuf.h | 22 +++++++++++-----------
5 files changed, 28 insertions(+), 27 deletions(-)
diff --git a/drivers/staging/line6/driver.c b/drivers/staging/line6/driver.c
index ecb461e..96cfbc9 100644
--- a/drivers/staging/line6/driver.c
+++ b/drivers/staging/line6/driver.c
@@ -360,7 +360,7 @@ char *line6_alloc_sysex_buffer(struct usb_line6 *line6, int code1, int code2,
static void line6_data_received(struct urb *urb)
{
struct usb_line6 *line6 = (struct usb_line6 *)urb->context;
- struct MidiBuffer *mb = &line6->line6midi->midibuf_in;
+ struct midi_buffer *mb = &line6->line6midi->midibuf_in;
int done;
if (urb->status == -ESHUTDOWN)
diff --git a/drivers/staging/line6/midi.c b/drivers/staging/line6/midi.c
index 6982eca..e3f9a53 100644
--- a/drivers/staging/line6/midi.c
+++ b/drivers/staging/line6/midi.c
@@ -45,7 +45,7 @@ static void line6_midi_transmit(struct snd_rawmidi_substream *substream)
struct usb_line6 *line6 =
line6_rawmidi_substream_midi(substream)->line6;
struct snd_line6_midi *line6midi = line6->line6midi;
- struct MidiBuffer *mb = &line6midi->midibuf_out;
+ struct midi_buffer *mb = &line6midi->midibuf_out;
unsigned long flags;
unsigned char chunk[line6->max_packet_size];
int req, done;
diff --git a/drivers/staging/line6/midi.h b/drivers/staging/line6/midi.h
index 19dabd5..78f903f 100644
--- a/drivers/staging/line6/midi.h
+++ b/drivers/staging/line6/midi.h
@@ -57,12 +57,12 @@ struct snd_line6_midi {
/**
Buffer for incoming MIDI stream.
*/
- struct MidiBuffer midibuf_in;
+ struct midi_buffer midibuf_in;
/**
Buffer for outgoing MIDI stream.
*/
- struct MidiBuffer midibuf_out;
+ struct midi_buffer midibuf_out;
};
extern int line6_init_midi(struct usb_line6 *line6);
diff --git a/drivers/staging/line6/midibuf.c b/drivers/staging/line6/midibuf.c
index 968e0de..f0adb7b 100644
--- a/drivers/staging/line6/midibuf.c
+++ b/drivers/staging/line6/midibuf.c
@@ -33,23 +33,23 @@ static int midibuf_message_length(unsigned char code)
}
}
-static int midibuf_is_empty(struct MidiBuffer *this)
+static int midibuf_is_empty(struct midi_buffer *this)
{
return (this->pos_read == this->pos_write) && !this->full;
}
-static int midibuf_is_full(struct MidiBuffer *this)
+static int midibuf_is_full(struct midi_buffer *this)
{
return this->full;
}
-void line6_midibuf_reset(struct MidiBuffer *this)
+void line6_midibuf_reset(struct midi_buffer *this)
{
this->pos_read = this->pos_write = this->full = 0;
this->command_prev = -1;
}
-int line6_midibuf_init(struct MidiBuffer *this, int size, int split)
+int line6_midibuf_init(struct midi_buffer *this, int size, int split)
{
this->buf = kmalloc(size, GFP_KERNEL);
@@ -62,14 +62,14 @@ int line6_midibuf_init(struct MidiBuffer *this, int size, int split)
return 0;
}
-void line6_midibuf_status(struct MidiBuffer *this)
+void line6_midibuf_status(struct midi_buffer *this)
{
pr_debug("midibuf size=%d split=%d pos_read=%d pos_write=%d full=%d command_prev=%02x\n",
this->size, this->split, this->pos_read, this->pos_write,
this->full, this->command_prev);
}
-int line6_midibuf_bytes_free(struct MidiBuffer *this)
+int line6_midibuf_bytes_free(struct midi_buffer *this)
{
return
midibuf_is_full(this) ?
@@ -78,7 +78,7 @@ int line6_midibuf_bytes_free(struct MidiBuffer *this)
1;
}
-int line6_midibuf_bytes_used(struct MidiBuffer *this)
+int line6_midibuf_bytes_used(struct midi_buffer *this)
{
return
midibuf_is_empty(this) ?
@@ -87,7 +87,7 @@ int line6_midibuf_bytes_used(struct MidiBuffer *this)
1;
}
-int line6_midibuf_write(struct MidiBuffer *this, unsigned char *data,
+int line6_midibuf_write(struct midi_buffer *this, unsigned char *data,
int length)
{
int bytes_free;
@@ -130,7 +130,8 @@ int line6_midibuf_write(struct MidiBuffer *this, unsigned char *data,
return length + skip_active_sense;
}
-int line6_midibuf_read(struct MidiBuffer *this, unsigned char *data, int length)
+int line6_midibuf_read(struct midi_buffer *this, unsigned char *data,
+ int length)
{
int bytes_used;
int length1, length2;
@@ -234,7 +235,7 @@ int line6_midibuf_read(struct MidiBuffer *this, unsigned char *data, int length)
return length + repeat;
}
-int line6_midibuf_ignore(struct MidiBuffer *this, int length)
+int line6_midibuf_ignore(struct midi_buffer *this, int length)
{
int bytes_used = line6_midibuf_bytes_used(this);
@@ -246,7 +247,7 @@ int line6_midibuf_ignore(struct MidiBuffer *this, int length)
return length;
}
-int line6_midibuf_skip_message(struct MidiBuffer *this, unsigned short mask)
+int line6_midibuf_skip_message(struct midi_buffer *this, unsigned short mask)
{
int cmd = this->command_prev;
@@ -257,7 +258,7 @@ int line6_midibuf_skip_message(struct MidiBuffer *this, unsigned short mask)
return 0;
}
-void line6_midibuf_destroy(struct MidiBuffer *this)
+void line6_midibuf_destroy(struct midi_buffer *this)
{
kfree(this->buf);
this->buf = NULL;
diff --git a/drivers/staging/line6/midibuf.h b/drivers/staging/line6/midibuf.h
index 444cb3a..707482b 100644
--- a/drivers/staging/line6/midibuf.h
+++ b/drivers/staging/line6/midibuf.h
@@ -12,7 +12,7 @@
#ifndef MIDIBUF_H
#define MIDIBUF_H
-struct MidiBuffer {
+struct midi_buffer {
unsigned char *buf;
int size;
int split;
@@ -21,18 +21,18 @@ struct MidiBuffer {
int command_prev;
};
-extern int line6_midibuf_bytes_used(struct MidiBuffer *mb);
-extern int line6_midibuf_bytes_free(struct MidiBuffer *mb);
-extern void line6_midibuf_destroy(struct MidiBuffer *mb);
-extern int line6_midibuf_ignore(struct MidiBuffer *mb, int length);
-extern int line6_midibuf_init(struct MidiBuffer *mb, int size, int split);
-extern int line6_midibuf_read(struct MidiBuffer *mb, unsigned char *data,
+extern int line6_midibuf_bytes_used(struct midi_buffer *mb);
+extern int line6_midibuf_bytes_free(struct midi_buffer *mb);
+extern void line6_midibuf_destroy(struct midi_buffer *mb);
+extern int line6_midibuf_ignore(struct midi_buffer *mb, int length);
+extern int line6_midibuf_init(struct midi_buffer *mb, int size, int split);
+extern int line6_midibuf_read(struct midi_buffer *mb, unsigned char *data,
int length);
-extern void line6_midibuf_reset(struct MidiBuffer *mb);
-extern int line6_midibuf_skip_message(struct MidiBuffer *mb,
+extern void line6_midibuf_reset(struct midi_buffer *mb);
+extern int line6_midibuf_skip_message(struct midi_buffer *mb,
unsigned short mask);
-extern void line6_midibuf_status(struct MidiBuffer *mb);
-extern int line6_midibuf_write(struct MidiBuffer *mb, unsigned char *data,
+extern void line6_midibuf_status(struct midi_buffer *mb);
+extern int line6_midibuf_write(struct midi_buffer *mb, unsigned char *data,
int length);
#endif
--
1.8.0.2
^ permalink raw reply [flat|nested] 7+ messages in thread* [PATCH 2/6] staging: line6: wrap comment to 80 chars in driver.c
2013-01-11 22:08 [PATCH 0/6] staging: line6: more checkpatch.pl warnings fixes Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 1/6] staging: line6: rename MidiBuffer to avoid CamelCase Stefan Hajnoczi
@ 2013-01-11 22:08 ` Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 3/6] staging: line6: use pr_err() instead of printk(KERN_ERR, ...) Stefan Hajnoczi
` (3 subsequent siblings)
5 siblings, 0 replies; 7+ messages in thread
From: Stefan Hajnoczi @ 2013-01-11 22:08 UTC (permalink / raw)
To: devel
Cc: Markus Grabner, Greg Kroah-Hartman, line6linux-devel,
linux-kernel, Laurent Navet, Stefan Hajnoczi
Fix the following checkpatch.pl warning:
WARNING: line over 80 characters
#1107: FILE: staging/line6/driver.c:523:
+ /* Wait for data length. We'll get a couple of 0xff until length arrives. */
Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
---
drivers/staging/line6/driver.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/line6/driver.c b/drivers/staging/line6/driver.c
index 96cfbc9..1b05633 100644
--- a/drivers/staging/line6/driver.c
+++ b/drivers/staging/line6/driver.c
@@ -520,7 +520,7 @@ int line6_read_data(struct usb_line6 *line6, int address, void *data,
return ret;
}
- /* Wait for data length. We'll get a couple of 0xff until length arrives. */
+ /* Wait for data length. We'll get 0xff until length arrives. */
do {
ret = usb_control_msg(usbdev, usb_rcvctrlpipe(usbdev, 0), 0x67,
USB_TYPE_VENDOR | USB_RECIP_DEVICE |
--
1.8.0.2
^ permalink raw reply [flat|nested] 7+ messages in thread* [PATCH 3/6] staging: line6: use pr_err() instead of printk(KERN_ERR, ...)
2013-01-11 22:08 [PATCH 0/6] staging: line6: more checkpatch.pl warnings fixes Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 1/6] staging: line6: rename MidiBuffer to avoid CamelCase Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 2/6] staging: line6: wrap comment to 80 chars in driver.c Stefan Hajnoczi
@ 2013-01-11 22:08 ` Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 4/6] staging: line6: wrap lines to 80 chars in pod.c Stefan Hajnoczi
` (2 subsequent siblings)
5 siblings, 0 replies; 7+ messages in thread
From: Stefan Hajnoczi @ 2013-01-11 22:08 UTC (permalink / raw)
To: devel
Cc: Markus Grabner, Greg Kroah-Hartman, line6linux-devel,
linux-kernel, Laurent Navet, Stefan Hajnoczi
Fix the following checkpatch.pl warning:
WARNING: Prefer netdev_err(netdev, ... then dev_err(dev, ... then pr_err(... to printk(KERN_ERR ...
#1861: FILE: staging/line6/driver.h:56:
+ printk(KERN_ERR "line6usb driver bug: missing case in %s:%d\n", \
Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
---
drivers/staging/line6/driver.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/line6/driver.h b/drivers/staging/line6/driver.h
index 1dd768c2..2e0f134 100644
--- a/drivers/staging/line6/driver.h
+++ b/drivers/staging/line6/driver.h
@@ -53,7 +53,7 @@
#define LINE6_CHANNEL_MASK 0x0f
#define MISSING_CASE \
- printk(KERN_ERR "line6usb driver bug: missing case in %s:%d\n", \
+ pr_err("line6usb driver bug: missing case in %s:%d\n", \
__FILE__, __LINE__)
#define CHECK_RETURN(x) \
--
1.8.0.2
^ permalink raw reply [flat|nested] 7+ messages in thread* [PATCH 4/6] staging: line6: wrap lines to 80 chars in pod.c
2013-01-11 22:08 [PATCH 0/6] staging: line6: more checkpatch.pl warnings fixes Stefan Hajnoczi
` (2 preceding siblings ...)
2013-01-11 22:08 ` [PATCH 3/6] staging: line6: use pr_err() instead of printk(KERN_ERR, ...) Stefan Hajnoczi
@ 2013-01-11 22:08 ` Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 5/6] staging: line6: drop ToneportSourceInfo CamelCase name Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 6/6] staging: line6: avoid CamelCase POD_* enums in pod.c Stefan Hajnoczi
5 siblings, 0 replies; 7+ messages in thread
From: Stefan Hajnoczi @ 2013-01-11 22:08 UTC (permalink / raw)
To: devel
Cc: Markus Grabner, Greg Kroah-Hartman, line6linux-devel,
linux-kernel, Laurent Navet, Stefan Hajnoczi
Fix the following checkpatch.pl warnings:
WARNING: line over 80 characters
#4508: FILE: staging/line6/pod.c:37:
+ /* POD_SYSEX_DUMPMEM2 = 0x76 */ /* dumps entire internal memory of PODxt Pro */
WARNING: line over 80 characters
#4630: FILE: staging/line6/pod.c:159:
+ if (memcmp(buf + 1, line6_midi_id, sizeof(line6_midi_id)) == 0) {
Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
---
drivers/staging/line6/pod.c | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/line6/pod.c b/drivers/staging/line6/pod.c
index e542540..1a11906 100644
--- a/drivers/staging/line6/pod.c
+++ b/drivers/staging/line6/pod.c
@@ -34,7 +34,9 @@ enum {
POD_SYSEX_DUMPMEM = 0x73,
POD_SYSEX_DUMP = 0x74,
POD_SYSEX_DUMPREQ = 0x75
- /* POD_SYSEX_DUMPMEM2 = 0x76 */ /* dumps entire internal memory of PODxt Pro */
+
+ /* dumps entire internal memory of PODxt Pro */
+ /* POD_SYSEX_DUMPMEM2 = 0x76 */
};
enum {
@@ -156,7 +158,8 @@ void line6_pod_process_message(struct usb_line6_pod *pod)
case LINE6_SYSEX_BEGIN | LINE6_CHANNEL_DEVICE:
case LINE6_SYSEX_BEGIN | LINE6_CHANNEL_UNKNOWN:
- if (memcmp(buf + 1, line6_midi_id, sizeof(line6_midi_id)) == 0) {
+ if (memcmp(buf + 1, line6_midi_id,
+ sizeof(line6_midi_id)) == 0) {
switch (buf[5]) {
case POD_SYSEX_DUMP:
break;
--
1.8.0.2
^ permalink raw reply [flat|nested] 7+ messages in thread* [PATCH 5/6] staging: line6: drop ToneportSourceInfo CamelCase name
2013-01-11 22:08 [PATCH 0/6] staging: line6: more checkpatch.pl warnings fixes Stefan Hajnoczi
` (3 preceding siblings ...)
2013-01-11 22:08 ` [PATCH 4/6] staging: line6: wrap lines to 80 chars in pod.c Stefan Hajnoczi
@ 2013-01-11 22:08 ` Stefan Hajnoczi
2013-01-11 22:08 ` [PATCH 6/6] staging: line6: avoid CamelCase POD_* enums in pod.c Stefan Hajnoczi
5 siblings, 0 replies; 7+ messages in thread
From: Stefan Hajnoczi @ 2013-01-11 22:08 UTC (permalink / raw)
To: devel
Cc: Markus Grabner, Greg Kroah-Hartman, line6linux-devel,
linux-kernel, Laurent Navet, Stefan Hajnoczi
Fix the following checkpatch.pl warning:
WARNING: Avoid CamelCase: <ToneportSourceInfo>
#5383: FILE: staging/line6/toneport.c:90:
+struct ToneportSourceInfo {
Since the struct is only used to define the global
toneport_source_info[] table, I have chosen to make the struct
anonymous and part of the table definition.
Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
---
drivers/staging/line6/toneport.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/line6/toneport.c b/drivers/staging/line6/toneport.c
index a529dd3..2f44d56 100644
--- a/drivers/staging/line6/toneport.c
+++ b/drivers/staging/line6/toneport.c
@@ -87,12 +87,10 @@ static struct line6_pcm_properties toneport_pcm_properties = {
static int led_red = 0x00;
static int led_green = 0x26;
-struct ToneportSourceInfo {
+static const struct {
const char *name;
int code;
-};
-
-static const struct ToneportSourceInfo toneport_source_info[] = {
+} toneport_source_info[] = {
{"Microphone", 0x0a01},
{"Line", 0x0801},
{"Instrument", 0x0b01},
--
1.8.0.2
^ permalink raw reply [flat|nested] 7+ messages in thread* [PATCH 6/6] staging: line6: avoid CamelCase POD_* enums in pod.c
2013-01-11 22:08 [PATCH 0/6] staging: line6: more checkpatch.pl warnings fixes Stefan Hajnoczi
` (4 preceding siblings ...)
2013-01-11 22:08 ` [PATCH 5/6] staging: line6: drop ToneportSourceInfo CamelCase name Stefan Hajnoczi
@ 2013-01-11 22:08 ` Stefan Hajnoczi
5 siblings, 0 replies; 7+ messages in thread
From: Stefan Hajnoczi @ 2013-01-11 22:08 UTC (permalink / raw)
To: devel
Cc: Markus Grabner, Greg Kroah-Hartman, line6linux-devel,
linux-kernel, Laurent Navet, Stefan Hajnoczi
Fix the following checkpatch.pl warnings:
WARNING: Avoid CamelCase: <POD_monitor_level>
#4512: FILE: staging/line6/pod.c:41:
+ POD_monitor_level = 0x04,
WARNING: Avoid CamelCase: <POD_system_invalid>
#4513: FILE: staging/line6/pod.c:42:
+ POD_system_invalid = 0x10000
Signed-off-by: Stefan Hajnoczi <stefanha@gmail.com>
---
drivers/staging/line6/pod.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/line6/pod.c b/drivers/staging/line6/pod.c
index 1a11906..ba6fed4 100644
--- a/drivers/staging/line6/pod.c
+++ b/drivers/staging/line6/pod.c
@@ -40,8 +40,8 @@ enum {
};
enum {
- POD_monitor_level = 0x04,
- POD_system_invalid = 0x10000
+ POD_MONITOR_LEVEL = 0x04,
+ POD_SYSTEM_INVALID = 0x10000
};
/* *INDENT-ON* */
@@ -170,7 +170,7 @@ void line6_pod_process_message(struct usb_line6_pod *pod)
<< 8) |
((int)buf[9] << 4) | (int)buf[10];
- if (buf[6] == POD_monitor_level)
+ if (buf[6] == POD_MONITOR_LEVEL)
pod->monitor_level = value;
break;
}
@@ -372,7 +372,7 @@ static int snd_pod_control_monitor_put(struct snd_kcontrol *kcontrol,
pod->monitor_level = ucontrol->value.integer.value[0];
pod_set_system_param_int(pod, ucontrol->value.integer.value[0],
- POD_monitor_level);
+ POD_MONITOR_LEVEL);
return 1;
}
@@ -463,7 +463,7 @@ static int pod_try_init(struct usb_interface *interface,
*/
if (pod->line6.properties->capabilities & LINE6_BIT_CONTROL) {
- pod->monitor_level = POD_system_invalid;
+ pod->monitor_level = POD_SYSTEM_INVALID;
/* initiate startup procedure: */
pod_startup1(pod);
--
1.8.0.2
^ permalink raw reply [flat|nested] 7+ messages in thread