From: Wang Long <long.wanglong@huawei.com>
To: <gaurav.minocha.os@gmail.com>, <robherring2@gmail.com>,
<robh+dt@kernel.org>, <pantelis.antoniou@konsulko.com>,
<grant.likely@linaro.org>
Cc: <pawel.moll@arm.com>, <mark.rutland@arm.com>,
<galak@codeaurora.org>, <devicetree@vger.kernel.org>,
<linux-kernel@vger.kernel.org>, <peifeiyue@huawei.com>,
<long.wanglong@huawei.com>, <ijc+devicetree@hellion.org.uk>
Subject: [PATCH v2 0/5] Update the OF unittest and some small fix
Date: Wed, 11 Mar 2015 08:36:49 +0000 [thread overview]
Message-ID: <1426063014-211712-1-git-send-email-long.wanglong@huawei.com> (raw)
This series patches do some small fixes in drivers/of/unittest.c,
and update the Documenttion.
At last, replace selftest with unittest in the c, dtsi
and binding files.
* v2 <- v1:
- According to Gaurav's advice. make the rename
file patch correctly.
Wang Long (5):
of/unittest: remove the duplicate of_changeset_init
of/unittest: Fix the wrong expected value in
of_selftest_property_string
Documentation: update the of_selftest.txt
Documentation: rename of_selftest.txt to of_unittest.txt
of/unittest: replace 'selftest' with 'unittest'
Documentation/devicetree/bindings/unittest.txt | 44 +-
.../{of_selftest.txt => of_unittest.txt} | 35 +-
drivers/of/unittest-data/tests-overlay.dtsi | 108 ++--
drivers/of/unittest.c | 703 ++++++++++-----------
4 files changed, 445 insertions(+), 445 deletions(-)
rename Documentation/devicetree/{of_selftest.txt => of_unittest.txt} (87%)
--
1.8.3.4
next reply other threads:[~2015-03-11 8:26 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-11 8:36 Wang Long [this message]
2015-03-11 8:36 ` [PATCH v2 1/5] of/unittest: remove the duplicate of_changeset_init Wang Long
2015-03-11 8:36 ` [PATCH v2 2/5] of/unittest: Fix the wrong expected value in of_selftest_property_string Wang Long
2015-03-11 8:36 ` [PATCH v2 3/5] Documentation: update the of_selftest.txt Wang Long
2015-03-11 8:36 ` [PATCH v2 4/5] Documentation: rename of_selftest.txt to of_unittest.txt Wang Long
2015-03-11 8:36 ` [PATCH v2 5/5] of/unittest: replace 'selftest' with 'unittest' Wang Long
2015-03-25 4:43 ` [PATCH v2 0/5] Update the OF unittest and some small fix Rob Herring
2015-03-28 13:23 ` Grant Likely
2015-03-29 17:24 ` Grant Likely
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1426063014-211712-1-git-send-email-long.wanglong@huawei.com \
--to=long.wanglong@huawei.com \
--cc=devicetree@vger.kernel.org \
--cc=galak@codeaurora.org \
--cc=gaurav.minocha.os@gmail.com \
--cc=grant.likely@linaro.org \
--cc=ijc+devicetree@hellion.org.uk \
--cc=linux-kernel@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=pantelis.antoniou@konsulko.com \
--cc=pawel.moll@arm.com \
--cc=peifeiyue@huawei.com \
--cc=robh+dt@kernel.org \
--cc=robherring2@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®