* Re: [PATCH 00 of 23][-mm] Unionfs: Stackable Namespace Unification Filesystem
[not found] <patchbomb.1160633917@thor.fsl.cs.sunysb.edu>
@ 2006-10-12 20:54 ` Andrew Morton
2006-10-13 6:54 ` Pekka Enberg
0 siblings, 1 reply; 3+ messages in thread
From: Andrew Morton @ 2006-10-12 20:54 UTC (permalink / raw)
To: Josef Jeff Sipek; +Cc: linux-kernel
On Thu, 12 Oct 2006 02:18:37 -0400
Josef "Jeff" Sipek <jsipek@cs.sunysb.edu> wrote:
> This set of patches constitutes Unionfs version 2.0.
So we need to get this reviewed.
Christoph and I are pretty much the only people who do filesystem
reviewing, despite the fact that we have hoards of filesystem developers
out there busily doing their own stuff (and that includes the unionfs
developers, I might add).
Our review-to-development ratio is wildly out of whack and I don't know how
to fix that.
Meanwhile, from a quick scan I'd say that unionfs is much, much too lightly
commented for a review to be particularly effective. Please work on that.
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 00 of 23][-mm] Unionfs: Stackable Namespace Unification Filesystem
2006-10-12 20:54 ` [PATCH 00 of 23][-mm] Unionfs: Stackable Namespace Unification Filesystem Andrew Morton
@ 2006-10-13 6:54 ` Pekka Enberg
2006-10-13 13:41 ` Jan Engelhardt
0 siblings, 1 reply; 3+ messages in thread
From: Pekka Enberg @ 2006-10-13 6:54 UTC (permalink / raw)
To: Andrew Morton; +Cc: Josef Jeff Sipek, linux-kernel
On 10/12/06, Andrew Morton <akpm@osdl.org> wrote:
> Meanwhile, from a quick scan I'd say that unionfs is much, much too lightly
> commented for a review to be particularly effective. Please work on that.
Could use some basic coding style fixes too.
- Move assignments outside of if statement expression "if (err = foo_bar())"
- No C99-style comments "//"
- Use struct kmem_cache instead of the deprecated kmem_cache_t
- Don't use function-like macros as the left hand side of assignment
expression "itohi_ptr(inode) = kzalloc(size, GFP_KERNEL);". It's much
better to open-code the assignment or introduce a setter function
(e.g. inode_set_hiptr).
- Kill wrappers (e.g. unionfs_kill_block_super can be replaced with
generic_shutdown_super)
Pekka
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 00 of 23][-mm] Unionfs: Stackable Namespace Unification Filesystem
2006-10-13 6:54 ` Pekka Enberg
@ 2006-10-13 13:41 ` Jan Engelhardt
0 siblings, 0 replies; 3+ messages in thread
From: Jan Engelhardt @ 2006-10-13 13:41 UTC (permalink / raw)
To: Pekka Enberg; +Cc: Andrew Morton, Josef Jeff Sipek, linux-kernel
>> Meanwhile, from a quick scan I'd say that unionfs is much, much too
>> lightly
>> commented for a review to be particularly effective. Please work on
>> that.
>
> - Kill wrappers (e.g. unionfs_kill_block_super can be replaced with
> generic_shutdown_super)
Possibly the unionfs_kill_block_super function was once written with
more than just generic_shutdown_super in mind. Just a guess, though.
-`J'
--
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2006-10-13 13:44 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
[not found] <patchbomb.1160633917@thor.fsl.cs.sunysb.edu>
2006-10-12 20:54 ` [PATCH 00 of 23][-mm] Unionfs: Stackable Namespace Unification Filesystem Andrew Morton
2006-10-13 6:54 ` Pekka Enberg
2006-10-13 13:41 ` Jan Engelhardt
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®