mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Frederic Weisbecker <fweisbec@gmail.com>
To: Jan Beulich <JBeulich@novell.com>
Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>,
	Ingo Molnar <mingo@elte.hu>, Thomas Gleixner <tglx@linutronix.de>,
	Arnaldo Carvalho de Melo <acme@redhat.com>,
	LKML <linux-kernel@vger.kernel.org>,
	"H. Peter Anvin" <hpa@zytor.com>
Subject: Re: [PATCH 3/6] x86,64: Simplify save_regs()
Date: Mon, 4 Jul 2011 14:57:45 +0200	[thread overview]
Message-ID: <20110704125742.GB1915@somewhere.redhat.com> (raw)
In-Reply-To: <4E1185F3020000780004BF21@nat28.tlf.novell.com>

On Mon, Jul 04, 2011 at 08:20:51AM +0100, Jan Beulich wrote:
> >>> On 02.07.11 at 18:29, Frederic Weisbecker <fweisbec@gmail.com> wrote:
> > The save_regs function that saves the regs on low level
> > irq entry is complicated because of the fact it changes
> > its stack in the middle and also because it manipulates
> > data allocated in the caller frame and accesses there
> > are directly calculated from callee rsp value with the
> > return address in the middle of the way.
> > 
> > This complicates the static stack offsets calculation and
> > require more dynamic ones. It also needs a save/restore
> > of the function's return address.
> > 
> > To simplify and optimize this, turn save_regs() into a
> > macro.
> 
> So this got pulled out into a function a couple of releases ago,
> and now it's being converted back? Wasn't the original patch's
> intention to reduce the amount of duplication of generated
> code?

Right. I didn't know there was a conversion a while ago for
this save_regs() from a macro to a func in order to remove
code duplication.

I really did not think about code duplication, considering
it's better to optimize the irq entry path.

What do you guys think? We can still revert the whole patchset.

  reply	other threads:[~2011-07-04 12:57 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-07-02 16:29 [RFC GIT PULL] x86 entry / perf stacktrace changes Frederic Weisbecker
2011-07-02 16:29 ` [PATCH 1/6] x86: Save stack pointer in perf live regs savings Frederic Weisbecker
2011-07-02 16:29 ` [PATCH 2/6] x86: Fetch stack from regs when possible in dump_trace() Frederic Weisbecker
2011-07-02 16:29 ` [PATCH 3/6] x86,64: Simplify save_regs() Frederic Weisbecker
2011-07-04  7:20   ` Jan Beulich
2011-07-04 12:57     ` Frederic Weisbecker [this message]
2011-07-06 17:34       ` Andi Kleen
2011-07-06 18:20         ` H. Peter Anvin
2011-07-06 20:42           ` Frederic Weisbecker
2011-07-04 12:59     ` Frederic Weisbecker
2011-07-02 16:29 ` [PATCH 4/6] x86,64: Separate arg1 from rbp handling in SAVE_REGS_IRQ Frederic Weisbecker
2011-07-04  7:34   ` Jan Beulich
2011-07-02 16:29 ` [PATCH 5/6] x86: Remove useless unwinder backlink from irq regs saving Frederic Weisbecker
2011-07-04  7:29   ` Jan Beulich
2011-07-04  9:17     ` Ingo Molnar
2011-07-04 13:10       ` Frederic Weisbecker
2011-07-04 13:22     ` Frederic Weisbecker
2011-07-05 22:21       ` Valdis.Kletnieks
2011-07-02 16:29 ` [PATCH 6/6] x86: Don't use frame pointer to save old stack on irq entry Frederic Weisbecker
2011-07-04  9:13 ` [RFC GIT PULL] x86 entry / perf stacktrace changes Ingo Molnar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110704125742.GB1915@somewhere.redhat.com \
    --to=fweisbec@gmail.com \
    --cc=JBeulich@novell.com \
    --cc=a.p.zijlstra@chello.nl \
    --cc=acme@redhat.com \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®