mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Bjorn Helgaas <bhelgaas@google.com>
To: Darren Hart <dvhart@linux.intel.com>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Peter P Waskiewicz Jr <peter.p.waskiewicz.jr@intel.com>,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	danders@circuitco.com, vishal.l.verma@intel.com,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>
Subject: Re: [PATCH 7/8] pci: Add CircuitCo VENDOR ID and MinnowBoard DEVICE ID
Date: Wed, 26 Jun 2013 15:30:10 -0600	[thread overview]
Message-ID: <20130626213010.GA31010@google.com> (raw)
In-Reply-To: <1372281416.2720.28.camel@envy.home>

On Wed, Jun 26, 2013 at 02:16:56PM -0700, Darren Hart wrote:
> On Wed, 2013-06-26 at 13:37 -0600, Bjorn Helgaas wrote:
> > On Wed, Jun 26, 2013 at 11:15 AM, Darren Hart <dvhart@linux.intel.com> wrote:
> > > On Wed, 2013-06-26 at 10:32 -0600, Bjorn Helgaas wrote:
> > 
> > >> +#define PCI_VENDOR_ID_CIRCUITCO              0x1cc8
> > >> +
> > >>  #define PCI_VENDOR_ID_TEKRAM         0x1de1
> > >>  #define PCI_DEVICE_ID_TEKRAM_DC290   0xdc29
> > >
> > >
> > > Thanks Bjorn. When I reuse this Subsystem ID and there is more than one
> > > usage, I should send a patch to pci_ids.h adding it and replace the hex
> > > value in all drivers with the new define. Is that right?
> > 
> > Yeah, that's what I was thinking.
> > 
> > But Peter's comment makes more sense to me now.  The spec refers to
> > that config register as "Subsystem ID," not "Subsystem Device ID," but
> > I was confused because most existing usage treats it as a device ID.
> > For example, the field in struct pci_device_id is named "subdevice,"
> > and all the existing #defines in pci_ids.h are of the form
> > PCI_SUBDEVICE_ID_*.
> > 
> > Device IDs are pretty specific identifiers, so I was thinking that a
> > "sub-device ID" would be even more specific.  Then it would make no
> > sense to have a "sub-device ID" that was as generic as "MINNOWBOARD."
> > But the register is actually *not* a "sub-device ID," and I can see
> > that using the same Subsystem ID for all the devices on a board might
> > make sense.
> > 
> > So I think the name PCI_DEVICE_ID_CIRCUITCO_MINNOWBOARD is a bit of a
> > misnomer, and something like PCI_SUBSYSTEM_CIRCUITCO_MINNOWBOARD would
> > make it more clear that it really isn't sharing the device ID space
> > assigned to CircuitCo.  It would make perfect sense to have a Device
> > ID, e.g., "PCI_DEVICE_ID_CIRCUIT_CO_xxx 0x0001," that has nothing to
> > do with the Subsystem ID 0x0001.
> > 
> > If you want to do something like that (or even keep your original
> > patch), I can put that in my -next branch.  Just let me know.
> > 
> > Bjorn
> 
> 
> I would be happy to change DEVICE to SUBSYSTEM in the the pci_ids.h:
> 
> +#define PCI_VENDOR_ID_CIRCUITCO		0x1cc8
> +#define PCI_SUBSYSTEM_ID_CITCUITCO_MINNOWBOARD	0x0001
> 
> Would you like me to send another patch?

No need.  I'll just apply the following patch.  Obviously your follow-on
pch_gbe patch will need a corresponding change.

Let me know if it needs tweaking, or if you decide I was talking nonsense
above.


commit c2efb42ab6033388f3bbed2dbe0fb76f2402e04a
Author: Darren Hart <dvhart@linux.intel.com>
Date:   Tue Jun 25 20:08:46 2013 -0600

    PCI: Add CircuitCo vendor ID and subsystem ID
    
    Add CircuitCo's newly created VENDOR ID and their first board subsystem
    ID for the MinnowBoard.
    
    [bhelgaas: sort, change DEVICE_ID to SUBSYSTEM_ID]
    Signed-off-by: Darren Hart <dvhart@linux.intel.com>
    Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>

diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
index c129162..4c7b349 100644
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
@@ -2476,6 +2476,9 @@
 
 #define PCI_VENDOR_ID_ASMEDIA		0x1b21
 
+#define PCI_VENDOR_ID_CIRCUITCO		0x1cc8
+#define PCI_SUBSYSTEM_ID_CIRCUITCO_MINNOWBOARD	0x0001
+
 #define PCI_VENDOR_ID_TEKRAM		0x1de1
 #define PCI_DEVICE_ID_TEKRAM_DC290	0xdc29
 

  reply	other threads:[~2013-06-26 21:30 UTC|newest]

Thread overview: 56+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-06-26  1:53 [PATCH 0/8] MinnowBoard support Darren Hart
2013-06-26  1:53 ` [PATCH 1/8] pch_gbe: Use PCH_GBE_PHY_REGS_LEN instead of 32 Darren Hart
2013-06-26  1:53 ` [PATCH 2/8] pch_uart: Add uart_clk selection for the MinnowBoard Darren Hart
2013-06-26  2:31   ` Greg Kroah-Hartman
2013-06-26  3:16     ` Darren Hart
2013-06-26  3:39       ` Greg Kroah-Hartman
2013-06-26  3:58         ` Darren Hart
2013-06-26  4:16           ` Greg Kroah-Hartman
2013-06-26  6:43           ` Jiri Slaby
2013-06-26  7:19             ` Darren Hart
2013-06-26  7:25               ` Jiri Slaby
2013-06-26 16:23                 ` Darren Hart
2013-06-26  1:53 ` [PATCH 3/8] gpio-sch: Add sch_gpio_resume_set_enable() Darren Hart
2013-06-26 21:24   ` Darren Hart
2013-06-26  1:53 ` [PATCH 4/8] minnowboard: Add base platform driver for the MinnowBoard Darren Hart
2013-06-26  4:00   ` Olof Johansson
2013-06-26  4:43     ` Darren Hart
2013-06-26  4:52       ` Matthew Garrett
2013-06-26  5:32         ` Darren Hart
2013-06-26  5:36           ` Matthew Garrett
2013-06-26  7:17             ` Darren Hart
2013-06-27  9:14   ` Linus Walleij
2013-06-28  5:43     ` Darren Hart
2013-07-04 16:26       ` Mark Brown
2013-07-20 17:37         ` Linus Walleij
2013-07-21 23:41           ` Mark Brown
2013-10-30 14:18             ` Darren Hart
2013-10-30 21:36               ` Mark Brown
2013-07-22  0:09         ` Grant Likely
2013-07-22  3:27           ` Darren Hart
2013-06-26  1:53 ` [PATCH 5/8] minnowboard-gpio: Export MinnowBoard expansion GPIO Darren Hart
2013-06-26  7:55   ` Andy Shevchenko
2013-06-26 16:21     ` Darren Hart
2013-06-27  8:18       ` Andy Shevchenko
2013-06-28  4:27         ` Darren Hart
2013-06-26  1:53 ` [PATCH 6/8] minnowboard-keys: Bind MinnowBoard buttons to arrow keys Darren Hart
2013-06-26  8:46   ` Andy Shevchenko
2013-06-26 16:28     ` Darren Hart
2013-06-26 17:16       ` Greg Kroah-Hartman
2013-06-26 17:23         ` Darren Hart
2013-06-26 19:57           ` Linus Walleij
2013-06-26 21:23             ` Darren Hart
2013-06-26  1:53 ` [PATCH 7/8] pci: Add CircuitCo VENDOR ID and MinnowBoard DEVICE ID Darren Hart
2013-06-26 16:32   ` Bjorn Helgaas
2013-06-26 17:15     ` Darren Hart
2013-06-26 19:37       ` Bjorn Helgaas
2013-06-26 21:16         ` Darren Hart
2013-06-26 21:30           ` Bjorn Helgaas [this message]
2013-06-26 21:30         ` H. Peter Anvin
2013-06-26 21:46           ` Bjorn Helgaas
2013-06-26 21:49             ` H. Peter Anvin
2013-06-26  1:53 ` [PATCH 8/8] pch_gbe: Add MinnowBoard support Darren Hart
2013-06-26  2:35   ` Bjorn Helgaas
2013-06-26  3:11     ` Darren Hart
2013-06-26  3:25     ` H. Peter Anvin
2013-06-28  5:37   ` Darren Hart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130626213010.GA31010@google.com \
    --to=bhelgaas@google.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=danders@circuitco.com \
    --cc=dvhart@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=peter.p.waskiewicz.jr@intel.com \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome