mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "H. Peter Anvin" <hpa@zytor.com>
To: Bjorn Helgaas <bhelgaas@google.com>,
	Darren Hart <dvhart@linux.intel.com>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Peter P Waskiewicz Jr <peter.p.waskiewicz.jr@intel.com>,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	danders@circuitco.com, vishal.l.verma@intel.com,
	"David S. Miller" <davem@davemloft.net>,
	netdev <netdev@vger.kernel.org>
Subject: Re: [PATCH 8/8] pch_gbe: Add MinnowBoard support
Date: Tue, 25 Jun 2013 20:25:59 -0700	[thread overview]
Message-ID: <68829d6a-a419-49a7-9df9-c9fa80f45aed@email.android.com> (raw)
In-Reply-To: <CAErSpo4PuKOqKM19Ra5D_jCH0SEtNTo95_EhyXVxYAB3J_27zg@mail.gmail.com>

The same subsystem (not subdevice!) ID is used for all devices on the Minnowboard itself.

Bjorn Helgaas <bhelgaas@google.com> wrote:

>On Tue, Jun 25, 2013 at 7:53 PM, Darren Hart <dvhart@linux.intel.com>
>wrote:
>> The MinnowBoard uses an AR803x PHY with the PCH GBE.
>>
>> It does not implement the RGMII 2ns TX clock delay in the trace
>routing
>> nor via strapping. Add a detection method for the board and the PHY
>and
>> enable the tx clock delay via the registers.
>>
>> This PHY will hibernate without link for 10 seconds. Ensure the PHY
>is
>> awake for probe and then disable hibernation. A future improvement
>would
>> be to convert pch_gbe to using PHYLIB and making sure we can wake the
>> PHY at the necessary times rather than permanently disabling it.
>>
>> Use the MinnowBoard PCI subsystem ID to identify the board and setup
>the
>> appropriate callbacks in a new pci_id driver_data structure.
>>
>> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
>> Cc: "David S. Miller" <davem@davemloft.net>
>> Cc: "H. Peter Anvin" <hpa@zytor.com>
>> Cc: Peter Waskiewicz <peter.p.waskiewicz.jr@intel.com>
>> Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
>> Cc: netdev@vger.kernel.org
>> ---
>>  drivers/net/ethernet/oki-semi/pch_gbe/Kconfig      |  1 +
>>  drivers/net/ethernet/oki-semi/pch_gbe/pch_gbe.h    |  2 +
>>  .../net/ethernet/oki-semi/pch_gbe/pch_gbe_main.c   | 32 ++++++++
>>  .../net/ethernet/oki-semi/pch_gbe/pch_gbe_phy.c    | 89
>++++++++++++++++++++++
>>  .../net/ethernet/oki-semi/pch_gbe/pch_gbe_phy.h    |  2 +
>>  5 files changed, 126 insertions(+)
>> ...
>
>> diff --git a/drivers/net/ethernet/oki-semi/pch_gbe/pch_gbe_main.c
>b/drivers/net/ethernet/oki-semi/pch_gbe/pch_gbe_main.c
>> index 6667a6b..6f0b9e3 100644
>> --- a/drivers/net/ethernet/oki-semi/pch_gbe/pch_gbe_main.c
>> +++ b/drivers/net/ethernet/oki-semi/pch_gbe/pch_gbe_main.c
>>...
>> +static struct pch_gbe_privdata pch_gbe_minnowboard_privdata = {
>> +       .phy_reset = minnow_phy_reset,
>> +       .phy_tx_clk_delay = pch_gbe_phy_tx_clk_delay,
>> +};
>> +
>>  static DEFINE_PCI_DEVICE_TABLE(pch_gbe_pcidev_id) = {
>>         {.vendor = PCI_VENDOR_ID_INTEL,
>>          .device = PCI_DEVICE_ID_INTEL_IOH1_GBE,
>> +        .subvendor = PCI_VENDOR_ID_CIRCUITCO,
>> +        .subdevice = PCI_DEVICE_ID_CIRCUITCO_MINNOWBOARD,
>
>"MINNOWBOARD" seems like a pretty generic name for something that
>probably refers only to the gigabit ethernet device in the EG20T.  If
>you expect to use that same subdevice ID on other devices, I guess we
>can add PCI_DEVICE_ID_CIRCUITCO_MINNOWBOARD to pci_ids.h.  If it will
>only be used for the gigabit ethernet device, we would normally not
>add a #define for it and would just use the hex constant here (see the
>comment at the top of pci_ids.h).
>
>> +        .class = (PCI_CLASS_NETWORK_ETHERNET << 8),
>> +        .class_mask = (0xFFFF00),
>> +        .driver_data = (unsigned long) &pch_gbe_minnowboard_privdata
>> +        },
>> +       {.vendor = PCI_VENDOR_ID_INTEL,
>> +        .device = PCI_DEVICE_ID_INTEL_IOH1_GBE,
>>          .subvendor = PCI_ANY_ID,
>>          .subdevice = PCI_ANY_ID,
>>          .class = (PCI_CLASS_NETWORK_ETHERNET << 8),

-- 
Sent from my mobile phone. Please excuse brevity and lack of formatting.

  parent reply	other threads:[~2013-06-26  3:26 UTC|newest]

Thread overview: 56+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-06-26  1:53 [PATCH 0/8] " Darren Hart
2013-06-26  1:53 ` [PATCH 1/8] pch_gbe: Use PCH_GBE_PHY_REGS_LEN instead of 32 Darren Hart
2013-06-26  1:53 ` [PATCH 2/8] pch_uart: Add uart_clk selection for the MinnowBoard Darren Hart
2013-06-26  2:31   ` Greg Kroah-Hartman
2013-06-26  3:16     ` Darren Hart
2013-06-26  3:39       ` Greg Kroah-Hartman
2013-06-26  3:58         ` Darren Hart
2013-06-26  4:16           ` Greg Kroah-Hartman
2013-06-26  6:43           ` Jiri Slaby
2013-06-26  7:19             ` Darren Hart
2013-06-26  7:25               ` Jiri Slaby
2013-06-26 16:23                 ` Darren Hart
2013-06-26  1:53 ` [PATCH 3/8] gpio-sch: Add sch_gpio_resume_set_enable() Darren Hart
2013-06-26 21:24   ` Darren Hart
2013-06-26  1:53 ` [PATCH 4/8] minnowboard: Add base platform driver for the MinnowBoard Darren Hart
2013-06-26  4:00   ` Olof Johansson
2013-06-26  4:43     ` Darren Hart
2013-06-26  4:52       ` Matthew Garrett
2013-06-26  5:32         ` Darren Hart
2013-06-26  5:36           ` Matthew Garrett
2013-06-26  7:17             ` Darren Hart
2013-06-27  9:14   ` Linus Walleij
2013-06-28  5:43     ` Darren Hart
2013-07-04 16:26       ` Mark Brown
2013-07-20 17:37         ` Linus Walleij
2013-07-21 23:41           ` Mark Brown
2013-10-30 14:18             ` Darren Hart
2013-10-30 21:36               ` Mark Brown
2013-07-22  0:09         ` Grant Likely
2013-07-22  3:27           ` Darren Hart
2013-06-26  1:53 ` [PATCH 5/8] minnowboard-gpio: Export MinnowBoard expansion GPIO Darren Hart
2013-06-26  7:55   ` Andy Shevchenko
2013-06-26 16:21     ` Darren Hart
2013-06-27  8:18       ` Andy Shevchenko
2013-06-28  4:27         ` Darren Hart
2013-06-26  1:53 ` [PATCH 6/8] minnowboard-keys: Bind MinnowBoard buttons to arrow keys Darren Hart
2013-06-26  8:46   ` Andy Shevchenko
2013-06-26 16:28     ` Darren Hart
2013-06-26 17:16       ` Greg Kroah-Hartman
2013-06-26 17:23         ` Darren Hart
2013-06-26 19:57           ` Linus Walleij
2013-06-26 21:23             ` Darren Hart
2013-06-26  1:53 ` [PATCH 7/8] pci: Add CircuitCo VENDOR ID and MinnowBoard DEVICE ID Darren Hart
2013-06-26 16:32   ` Bjorn Helgaas
2013-06-26 17:15     ` Darren Hart
2013-06-26 19:37       ` Bjorn Helgaas
2013-06-26 21:16         ` Darren Hart
2013-06-26 21:30           ` Bjorn Helgaas
2013-06-26 21:30         ` H. Peter Anvin
2013-06-26 21:46           ` Bjorn Helgaas
2013-06-26 21:49             ` H. Peter Anvin
2013-06-26  1:53 ` [PATCH 8/8] pch_gbe: Add MinnowBoard support Darren Hart
2013-06-26  2:35   ` Bjorn Helgaas
2013-06-26  3:11     ` Darren Hart
2013-06-26  3:25     ` H. Peter Anvin [this message]
2013-06-28  5:37   ` Darren Hart

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=68829d6a-a419-49a7-9df9-c9fa80f45aed@email.android.com \
    --to=hpa@zytor.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=bhelgaas@google.com \
    --cc=danders@circuitco.com \
    --cc=davem@davemloft.net \
    --cc=dvhart@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=peter.p.waskiewicz.jr@intel.com \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome