mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jiri Olsa <jolsa@redhat.com>
To: Namhyung Kim <namhyung@kernel.org>
Cc: Arnaldo Carvalho de Melo <acme@ghostprotocols.net>,
	Peter Zijlstra <a.p.zijlstra@chello.nl>,
	Paul Mackerras <paulus@samba.org>, Ingo Molnar <mingo@kernel.org>,
	Namhyung Kim <namhyung.kim@lge.com>,
	LKML <linux-kernel@vger.kernel.org>, Arun Sharma <asharma@fb.com>,
	Frederic Weisbecker <fweisbec@gmail.com>,
	Rodrigo Campos <rodrigo@sdfg.com.ar>
Subject: Re: [PATCH 09/21] perf ui/hist: Add support to accumulated hist stat
Date: Mon, 6 Jan 2014 15:30:12 +0100	[thread overview]
Message-ID: <20140106143012.GC1183@krava.brq.redhat.com> (raw)
In-Reply-To: <8738l1ecj3.fsf@sejong.aot.lge.com>

On Mon, Jan 06, 2014 at 05:32:16PM +0900, Namhyung Kim wrote:
> On Sun, 5 Jan 2014 18:31:13 +0100, Jiri Olsa wrote:
> > On Tue, Dec 24, 2013 at 05:22:15PM +0900, Namhyung Kim wrote:
> >> +#define __HPP_COLOR_ACC_PERCENT_FN(_type, _field)				\
> >> +static u64 he_get_acc_##_field(struct hist_entry *he)				\
> >> +{										\
> >> +	return he->stat_acc->_field;						\
> >> +}										\
> >> +										\
> >> +static int hpp__color_acc_##_type(struct perf_hpp_fmt *fmt __maybe_unused,	\
> >> +			      struct perf_hpp *hpp, struct hist_entry *he) 	\
> >> +{										\
> >> +	return __hpp__fmt(hpp, he, he_get_acc_##_field, " %6.2f%%",		\
> >> +			  (hpp_snprint_fn)percent_color_snprintf, true);	\
> >> +}
> >> +
> >> +#define __HPP_ENTRY_ACC_PERCENT_FN(_type, _field)				\
> >> +static int hpp__entry_acc_##_type(struct perf_hpp_fmt *_fmt __maybe_unused,	\
> >> +			      struct perf_hpp *hpp, struct hist_entry *he) 	\
> >> +{										\
> >> +	const char *fmt = symbol_conf.field_sep ? " %.2f" : " %6.2f%%";		\
> >> +	return __hpp__fmt(hpp, he, he_get_acc_##_field, fmt,			\
> >> +			  scnprintf, true);					\
> >> +}
> >> +
> >>  #define __HPP_ENTRY_RAW_FN(_type, _field)					\
> >>  static u64 he_get_raw_##_field(struct hist_entry *he)				\
> >>  {										\
> >> @@ -148,17 +170,25 @@ __HPP_WIDTH_FN(_type, _min_width, _unit_width)				\
> >>  __HPP_COLOR_PERCENT_FN(_type, _field)					\
> >>  __HPP_ENTRY_PERCENT_FN(_type, _field)
> >>  
> >> +#define HPP_PERCENT_ACC_FNS(_type, _str, _field, _min_width, _unit_width)\
> >> +__HPP_HEADER_FN(_type, _str, _min_width, _unit_width)			\
> >> +__HPP_WIDTH_FN(_type, _min_width, _unit_width)				\
> >> +__HPP_COLOR_ACC_PERCENT_FN(_type, _field)				\
> >> +__HPP_ENTRY_ACC_PERCENT_FN(_type, _field)
> >
> > how about add 'stat|stat_acc' parameter to the HPP_PERCENT_FNS
> > macro and use it like:
> >
> > #define __HPP_COLOR_PERCENT_FN(_type, _field, _stat)                            \
> > static u64 he_get_##_stat##_field(struct hist_entry *he)                        \
> > {                                                                               \
> >         return he->##_stat._field;                                              \
> > }                                                                               \
> >
> >
> > and use 'he_get_##_stat##_field' in __HPP_ENTRY_PERCENT_FN
> >
> > This way you dont need to duplicate the code, that differs
> > only in the used stat data.. but it's possible I missed
> > something ;-)
> 
> The problem is that he->stat is a in-struct data but ->stat_acc is
> dynamically allocated.  So it should be 
> 
>   "he->stat. ## _field"
>            ~
> vs.
> 
>   "he->stat_acc-> ## _field"
>                ~~

I see.. maybe some other 'is_pointer' parameter is better
then duplicating the code.. but it's not that big anyway.. nevermind ;-)

> >
> > btw just noticed __HPP_COLOR_PERCENT_FN does not use _type
> 
> ???  It's used in hpp__color_##_type().

aah ok, missed that

thanks,
jirka

  reply	other threads:[~2014-01-06 15:20 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-12-24  8:22 [PATCHSET 00/21] perf tools: Add support to accumulate hist periods (v4) Namhyung Kim
2013-12-24  8:22 ` [PATCH 01/21] perf tools: Introduce struct add_entry_iter Namhyung Kim
2014-01-05 14:55   ` Jiri Olsa
2014-01-06  7:45     ` Namhyung Kim
2014-01-05 15:28   ` Jiri Olsa
2014-01-06  7:45     ` Namhyung Kim
2014-01-05 15:55   ` Jiri Olsa
2014-01-06  8:03     ` Namhyung Kim
2014-01-06 14:32       ` Jiri Olsa
2013-12-24  8:22 ` [PATCH 02/21] perf hists: Convert hist entry functions to use struct he_stat Namhyung Kim
2014-01-05 16:09   ` Jiri Olsa
2013-12-24  8:22 ` [PATCH 03/21] perf hists: Add support for accumulated stat of hist entry Namhyung Kim
2014-01-05 16:16   ` Jiri Olsa
2014-01-05 16:26   ` Jiri Olsa
2014-01-06  8:09     ` Namhyung Kim
2014-01-05 16:45   ` Jiri Olsa
2014-01-06  8:10     ` Namhyung Kim
2013-12-24  8:22 ` [PATCH 04/21] perf hists: Check if accumulated when adding a " Namhyung Kim
2013-12-24  8:22 ` [PATCH 05/21] perf hists: Accumulate hist entry stat based on the callchain Namhyung Kim
2014-01-05 16:58   ` Jiri Olsa
2014-01-05 17:15     ` Jiri Olsa
2014-01-06  8:17       ` Namhyung Kim
2013-12-24  8:22 ` [PATCH 06/21] perf tools: Update cpumode for each cumulative entry Namhyung Kim
2014-01-05 17:02   ` Jiri Olsa
2014-01-06  8:18     ` Namhyung Kim
2013-12-24  8:22 ` [PATCH 07/21] perf report: Cache cumulative callchains Namhyung Kim
2014-01-05 17:10   ` Jiri Olsa
2013-12-24  8:22 ` [PATCH 08/21] perf hists: Sort hist entries by accumulated period Namhyung Kim
2013-12-24  8:22 ` [PATCH 09/21] perf ui/hist: Add support to accumulated hist stat Namhyung Kim
2014-01-05 17:31   ` Jiri Olsa
2014-01-06  8:32     ` Namhyung Kim
2014-01-06 14:30       ` Jiri Olsa [this message]
2013-12-24  8:22 ` [PATCH 10/21] perf ui/browser: " Namhyung Kim
2014-01-05 17:33   ` Jiri Olsa
2013-12-24  8:22 ` [PATCH 11/21] perf ui/gtk: " Namhyung Kim
2014-01-05 17:35   ` Jiri Olsa
2013-12-24  8:22 ` [PATCH 12/21] perf tools: Apply percent-limit to cumulative percentage Namhyung Kim
2014-01-05 17:40   ` Jiri Olsa
2014-01-06  8:33     ` Namhyung Kim
2013-12-24  8:22 ` [PATCH 13/21] perf tools: Add more hpp helper functions Namhyung Kim
2013-12-24  8:22 ` [PATCH 14/21] perf report: Add --children option Namhyung Kim
2013-12-24  8:22 ` [PATCH 15/21] perf report: Add report.children config option Namhyung Kim
2013-12-24  8:22 ` [PATCH 16/21] perf tools: Factor out sample__resolve_callchain() Namhyung Kim
2014-01-05 17:56   ` Jiri Olsa
2013-12-24  8:22 ` [PATCH 17/21] perf tools: Factor out fill_callchain_info() Namhyung Kim
2013-12-24  8:22 ` [PATCH 18/21] perf top: Support callchain accumulation Namhyung Kim
2014-01-05 18:01   ` Jiri Olsa
2014-01-06  8:34     ` Namhyung Kim
2013-12-24  8:22 ` [PATCH 19/21] perf top: Add --children option Namhyung Kim
2013-12-24  8:22 ` [PATCH 20/21] perf top: Add top.children config option Namhyung Kim
2013-12-24  8:22 ` [PATCH 21/21] perf tools: Enable --children option by default Namhyung Kim
2014-01-05 18:08   ` Jiri Olsa
2014-01-06  8:47     ` Namhyung Kim
2014-03-20  5:36 [PATCHSET 00/21] perf tools: Add support to accumulate hist periods (v9) Namhyung Kim
2014-03-20  5:36 ` [PATCH 09/21] perf ui/hist: Add support to accumulated hist stat Namhyung Kim

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140106143012.GC1183@krava.brq.redhat.com \
    --to=jolsa@redhat.com \
    --cc=a.p.zijlstra@chello.nl \
    --cc=acme@ghostprotocols.net \
    --cc=asharma@fb.com \
    --cc=fweisbec@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=namhyung.kim@lge.com \
    --cc=namhyung@kernel.org \
    --cc=paulus@samba.org \
    --cc=rodrigo@sdfg.com.ar \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome