mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/6] x86, boot: clean up KASLR code
@ 2016-04-18 16:42 Kees Cook
  2016-04-18 16:42 ` [PATCH 1/6] x86, KASLR: rename aslr.c to kaslr.c Kees Cook
                   ` (6 more replies)
  0 siblings, 7 replies; 14+ messages in thread
From: Kees Cook @ 2016-04-18 16:42 UTC (permalink / raw)
  To: Ingo Molnar
  Cc: Kees Cook, Yinghai Lu, Baoquan He, H. Peter Anvin,
	Thomas Gleixner, Ingo Molnar, x86, Andrew Morton,
	Andrey Ryabinin, Dmitry Vyukov, H.J. Lu, Josh Poimboeuf,
	Borislav Petkov, Andy Lutomirski, linux-kernel

In order to make improvements to KASLR behavior, it has been suggested
that the code should be cleaned up a bit first. This is the start of
those changes. Since there are no stand-alone bug fixes in the later
patches, I will begin here. First with a rename followed by variable
name changes and comment improvements.

This is the first wave...

-Kees

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2016-04-19  9:34 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-04-18 16:42 [PATCH 0/6] x86, boot: clean up KASLR code Kees Cook
2016-04-18 16:42 ` [PATCH 1/6] x86, KASLR: rename aslr.c to kaslr.c Kees Cook
2016-04-19  9:31   ` [tip:x86/boot] x86/KASLR: Rename " tip-bot for Kees Cook
2016-04-18 16:42 ` [PATCH 2/6] x86, KASLR: Remove unneeded boot_params argument Kees Cook
2016-04-19  9:31   ` [tip:x86/boot] x86/KASLR: " tip-bot for Yinghai Lu
2016-04-18 16:42 ` [PATCH 3/6] x86, boot: Rename "real_mode" to "boot_params" Kees Cook
2016-04-19  9:32   ` [tip:x86/boot] x86/boot: " tip-bot for Kees Cook
2016-04-18 16:42 ` [PATCH 4/6] x86, boot: Clarify purpose of functions in misc.c Kees Cook
2016-04-19  9:32   ` [tip:x86/boot] x86/boot: " tip-bot for Kees Cook
2016-04-18 16:42 ` [PATCH 5/6] x86, KASLR: Clarify purpose of kaslr.c Kees Cook
2016-04-19  9:32   ` [tip:x86/boot] x86/KASLR: " tip-bot for Kees Cook
2016-04-18 16:42 ` [PATCH 6/6] x86, KASLR: Rename "random" to "random_addr" Kees Cook
2016-04-19  9:33   ` [tip:x86/boot] x86/KASLR: " tip-bot for Kees Cook
2016-04-19  8:36 ` [PATCH 0/6] x86, boot: clean up KASLR code Ingo Molnar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome