* [PATCH 0122/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:42 Baole Ni
2016-08-02 13:57 ` Alan Stern
0 siblings, 1 reply; 3+ messages in thread
From: Baole Ni @ 2016-08-02 10:42 UTC (permalink / raw)
To: rjw, viresh.kumar, jarkko.sakkinen, jgunthorpe, hpa, x86
Cc: linux-pm, linux-kernel, chuansheng.liu, baolex.ni, jslaby, peter,
lee.jones
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
drivers/cpufreq/powernow-k7.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/cpufreq/powernow-k7.c b/drivers/cpufreq/powernow-k7.c
index 9f013ed..2c7d73a 100644
--- a/drivers/cpufreq/powernow-k7.c
+++ b/drivers/cpufreq/powernow-k7.c
@@ -683,7 +683,7 @@ static void __exit powernow_exit(void)
cpufreq_unregister_driver(&powernow_driver);
}
-module_param(acpi_force, int, 0444);
+module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(acpi_force, "Force ACPI to be used.");
MODULE_AUTHOR("Dave Jones");
--
2.9.2
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro
2016-08-02 10:42 [PATCH 0122/1285] Replace numeric parameter like 0444 with macro Baole Ni
@ 2016-08-02 13:57 ` Alan Stern
2016-08-02 17:05 ` Jiri Slaby
0 siblings, 1 reply; 3+ messages in thread
From: Alan Stern @ 2016-08-02 13:57 UTC (permalink / raw)
To: Baole Ni
Cc: rjw, viresh.kumar, jarkko.sakkinen, jgunthorpe, hpa, x86,
linux-pm, linux-kernel, chuansheng.liu, jslaby, peter, lee.jones
On Tue, 2 Aug 2016, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
This reasoning is highly questionable. How does using a macro improve
either robustness or readability?
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
> drivers/cpufreq/powernow-k7.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/cpufreq/powernow-k7.c b/drivers/cpufreq/powernow-k7.c
> index 9f013ed..2c7d73a 100644
> --- a/drivers/cpufreq/powernow-k7.c
> +++ b/drivers/cpufreq/powernow-k7.c
> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void)
> cpufreq_unregister_driver(&powernow_driver);
> }
>
> -module_param(acpi_force, int, 0444);
> +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH);
This is an excellent example. To me, 0444 is _much_ more readable and
understandable than S_IRUSR | S_IRGRP | S_IROTH.
Alan Stern
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 0122/1285] Replace numeric parameter like 0444 with macro
2016-08-02 13:57 ` Alan Stern
@ 2016-08-02 17:05 ` Jiri Slaby
0 siblings, 0 replies; 3+ messages in thread
From: Jiri Slaby @ 2016-08-02 17:05 UTC (permalink / raw)
To: Alan Stern, Baole Ni
Cc: rjw, viresh.kumar, jarkko.sakkinen, jgunthorpe, hpa, x86,
linux-pm, linux-kernel, chuansheng.liu, peter, lee.jones
On 08/02/2016, 03:57 PM, Alan Stern wrote:
>> --- a/drivers/cpufreq/powernow-k7.c
>> +++ b/drivers/cpufreq/powernow-k7.c
>> @@ -683,7 +683,7 @@ static void __exit powernow_exit(void)
>> cpufreq_unregister_driver(&powernow_driver);
>> }
>>
>> -module_param(acpi_force, int, 0444);
>> +module_param(acpi_force, int, S_IRUSR | S_IRGRP | S_IROTH);
>
> This is an excellent example. To me, 0444 is _much_ more readable and
> understandable than S_IRUSR | S_IRGRP | S_IROTH.
If anything, that should be S_IRUGO. However, I personally prefer
numbers over macros too.
thanks,
--
js
suse labs
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2016-08-02 17:06 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:42 [PATCH 0122/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-02 13:57 ` Alan Stern
2016-08-02 17:05 ` Jiri Slaby
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®