* [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap
@ 2018-01-03 9:32 Chao Yu
2018-01-03 9:32 ` [PATCH 2/2] f2fs: clean up unneeded declaration Chao Yu
2018-01-03 20:12 ` [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Jaegeuk Kim
0 siblings, 2 replies; 6+ messages in thread
From: Chao Yu @ 2018-01-03 9:32 UTC (permalink / raw)
To: jaegeuk; +Cc: linux-f2fs-devel, linux-kernel, chao, Chao Yu
If we need an array with variable size in the end of structure, we
can utilize flexible array feature which is supported in C99, so
let's change sit_nat_version_bitmap[] to flexible array in struct
f2fs_checkpoint for readability.
Signed-off-by: Chao Yu <yuchao0@huawei.com>
---
fs/f2fs/f2fs.h | 4 ++--
include/linux/f2fs_fs.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
index 83d1f697388b..ad19d29688ae 100644
--- a/fs/f2fs/f2fs.h
+++ b/fs/f2fs/f2fs.h
@@ -1719,13 +1719,13 @@ static inline void *__bitmap_ptr(struct f2fs_sb_info *sbi, int flag)
if (__cp_payload(sbi) > 0) {
if (flag == NAT_BITMAP)
- return &ckpt->sit_nat_version_bitmap;
+ return ckpt->sit_nat_version_bitmap;
else
return (unsigned char *)ckpt + F2FS_BLKSIZE;
} else {
offset = (flag == NAT_BITMAP) ?
le32_to_cpu(ckpt->sit_ver_bitmap_bytesize) : 0;
- return &ckpt->sit_nat_version_bitmap + offset;
+ return ckpt->sit_nat_version_bitmap + offset;
}
}
diff --git a/include/linux/f2fs_fs.h b/include/linux/f2fs_fs.h
index 43e98d30d2df..564f65fc192f 100644
--- a/include/linux/f2fs_fs.h
+++ b/include/linux/f2fs_fs.h
@@ -157,7 +157,7 @@ struct f2fs_checkpoint {
unsigned char alloc_type[MAX_ACTIVE_LOGS];
/* SIT and NAT version bitmap */
- unsigned char sit_nat_version_bitmap[1];
+ unsigned char sit_nat_version_bitmap[];
} __packed;
/*
--
2.15.0.55.gc2ece9dc4de6
^ permalink raw reply [flat|nested] 6+ messages in thread
* [PATCH 2/2] f2fs: clean up unneeded declaration
2018-01-03 9:32 [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Chao Yu
@ 2018-01-03 9:32 ` Chao Yu
2018-01-03 20:12 ` [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Jaegeuk Kim
1 sibling, 0 replies; 6+ messages in thread
From: Chao Yu @ 2018-01-03 9:32 UTC (permalink / raw)
To: jaegeuk; +Cc: linux-f2fs-devel, linux-kernel, chao, Chao Yu
Commit 6afc662e68b5 ("f2fs: support flexible inline xattr size")
declared f2fs_sb_has_flexible_inline_xattr in f2fs.h for latter being
used in get_inline_xattr_addrs, but in latter version, related code
has been changed, leave f2fs_sb_has_flexible_inline_xattr w/o any
users. Let's remove it for cleanup.
Signed-off-by: Chao Yu <yuchao0@huawei.com>
---
fs/f2fs/f2fs.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
index ad19d29688ae..c082ae905f08 100644
--- a/fs/f2fs/f2fs.h
+++ b/fs/f2fs/f2fs.h
@@ -2449,7 +2449,6 @@ static inline int get_extra_isize(struct inode *inode)
return F2FS_I(inode)->i_extra_isize / sizeof(__le32);
}
-static inline int f2fs_sb_has_flexible_inline_xattr(struct super_block *sb);
static inline int get_inline_xattr_addrs(struct inode *inode)
{
return F2FS_I(inode)->i_inline_xattr_size;
--
2.15.0.55.gc2ece9dc4de6
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap
2018-01-03 9:32 [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Chao Yu
2018-01-03 9:32 ` [PATCH 2/2] f2fs: clean up unneeded declaration Chao Yu
@ 2018-01-03 20:12 ` Jaegeuk Kim
2018-01-04 1:20 ` Chao Yu
1 sibling, 1 reply; 6+ messages in thread
From: Jaegeuk Kim @ 2018-01-03 20:12 UTC (permalink / raw)
To: Chao Yu; +Cc: linux-f2fs-devel, linux-kernel, chao
On 01/03, Chao Yu wrote:
> If we need an array with variable size in the end of structure, we
> can utilize flexible array feature which is supported in C99, so
> let's change sit_nat_version_bitmap[] to flexible array in struct
> f2fs_checkpoint for readability.
>
> Signed-off-by: Chao Yu <yuchao0@huawei.com>
> ---
> fs/f2fs/f2fs.h | 4 ++--
> include/linux/f2fs_fs.h | 2 +-
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
> index 83d1f697388b..ad19d29688ae 100644
> --- a/fs/f2fs/f2fs.h
> +++ b/fs/f2fs/f2fs.h
> @@ -1719,13 +1719,13 @@ static inline void *__bitmap_ptr(struct f2fs_sb_info *sbi, int flag)
>
> if (__cp_payload(sbi) > 0) {
> if (flag == NAT_BITMAP)
> - return &ckpt->sit_nat_version_bitmap;
> + return ckpt->sit_nat_version_bitmap;
> else
> return (unsigned char *)ckpt + F2FS_BLKSIZE;
> } else {
> offset = (flag == NAT_BITMAP) ?
> le32_to_cpu(ckpt->sit_ver_bitmap_bytesize) : 0;
> - return &ckpt->sit_nat_version_bitmap + offset;
> + return ckpt->sit_nat_version_bitmap + offset;
> }
> }
>
> diff --git a/include/linux/f2fs_fs.h b/include/linux/f2fs_fs.h
> index 43e98d30d2df..564f65fc192f 100644
> --- a/include/linux/f2fs_fs.h
> +++ b/include/linux/f2fs_fs.h
> @@ -157,7 +157,7 @@ struct f2fs_checkpoint {
> unsigned char alloc_type[MAX_ACTIVE_LOGS];
>
> /* SIT and NAT version bitmap */
> - unsigned char sit_nat_version_bitmap[1];
> + unsigned char sit_nat_version_bitmap[];
I cannot find any benefit to do this. Moreover, it just makes the header
structure be different from the one in f2fs-tools.
> } __packed;
>
> /*
> --
> 2.15.0.55.gc2ece9dc4de6
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap
2018-01-03 20:12 ` [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Jaegeuk Kim
@ 2018-01-04 1:20 ` Chao Yu
2018-01-04 6:16 ` Jaegeuk Kim
0 siblings, 1 reply; 6+ messages in thread
From: Chao Yu @ 2018-01-04 1:20 UTC (permalink / raw)
To: Jaegeuk Kim; +Cc: linux-f2fs-devel, linux-kernel, chao
On 2018/1/4 4:12, Jaegeuk Kim wrote:
> On 01/03, Chao Yu wrote:
>> If we need an array with variable size in the end of structure, we
>> can utilize flexible array feature which is supported in C99, so
>> let's change sit_nat_version_bitmap[] to flexible array in struct
>> f2fs_checkpoint for readability.
>>
>> Signed-off-by: Chao Yu <yuchao0@huawei.com>
>> ---
>> fs/f2fs/f2fs.h | 4 ++--
>> include/linux/f2fs_fs.h | 2 +-
>> 2 files changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
>> index 83d1f697388b..ad19d29688ae 100644
>> --- a/fs/f2fs/f2fs.h
>> +++ b/fs/f2fs/f2fs.h
>> @@ -1719,13 +1719,13 @@ static inline void *__bitmap_ptr(struct f2fs_sb_info *sbi, int flag)
>>
>> if (__cp_payload(sbi) > 0) {
>> if (flag == NAT_BITMAP)
>> - return &ckpt->sit_nat_version_bitmap;
>> + return ckpt->sit_nat_version_bitmap;
>> else
>> return (unsigned char *)ckpt + F2FS_BLKSIZE;
>> } else {
>> offset = (flag == NAT_BITMAP) ?
>> le32_to_cpu(ckpt->sit_ver_bitmap_bytesize) : 0;
>> - return &ckpt->sit_nat_version_bitmap + offset;
>> + return ckpt->sit_nat_version_bitmap + offset;
>> }
>> }
>>
>> diff --git a/include/linux/f2fs_fs.h b/include/linux/f2fs_fs.h
>> index 43e98d30d2df..564f65fc192f 100644
>> --- a/include/linux/f2fs_fs.h
>> +++ b/include/linux/f2fs_fs.h
>> @@ -157,7 +157,7 @@ struct f2fs_checkpoint {
>> unsigned char alloc_type[MAX_ACTIVE_LOGS];
>>
>> /* SIT and NAT version bitmap */
>> - unsigned char sit_nat_version_bitmap[1];
>> + unsigned char sit_nat_version_bitmap[];
>
> I cannot find any benefit to do this. Moreover, it just makes the header
I intend to change both kernel and tools, sorry, I didn't send out the
patch on tools. Anyway, I think it could be used to avoid checkpoint
structure size calculation by "sizeof(struct checkpoint) - 1", with the
patch, readability can be improved. Right?
Thanks,
> structure be different from the one in f2fs-tools.
>
>> } __packed;
>>
>> /*
>> --
>> 2.15.0.55.gc2ece9dc4de6
>
> .
>
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap
2018-01-04 1:20 ` Chao Yu
@ 2018-01-04 6:16 ` Jaegeuk Kim
2018-01-04 6:28 ` Chao Yu
0 siblings, 1 reply; 6+ messages in thread
From: Jaegeuk Kim @ 2018-01-04 6:16 UTC (permalink / raw)
To: Chao Yu; +Cc: linux-f2fs-devel, linux-kernel, chao
On 01/04, Chao Yu wrote:
> On 2018/1/4 4:12, Jaegeuk Kim wrote:
> > On 01/03, Chao Yu wrote:
> >> If we need an array with variable size in the end of structure, we
> >> can utilize flexible array feature which is supported in C99, so
> >> let's change sit_nat_version_bitmap[] to flexible array in struct
> >> f2fs_checkpoint for readability.
> >>
> >> Signed-off-by: Chao Yu <yuchao0@huawei.com>
> >> ---
> >> fs/f2fs/f2fs.h | 4 ++--
> >> include/linux/f2fs_fs.h | 2 +-
> >> 2 files changed, 3 insertions(+), 3 deletions(-)
> >>
> >> diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
> >> index 83d1f697388b..ad19d29688ae 100644
> >> --- a/fs/f2fs/f2fs.h
> >> +++ b/fs/f2fs/f2fs.h
> >> @@ -1719,13 +1719,13 @@ static inline void *__bitmap_ptr(struct f2fs_sb_info *sbi, int flag)
> >>
> >> if (__cp_payload(sbi) > 0) {
> >> if (flag == NAT_BITMAP)
> >> - return &ckpt->sit_nat_version_bitmap;
> >> + return ckpt->sit_nat_version_bitmap;
> >> else
> >> return (unsigned char *)ckpt + F2FS_BLKSIZE;
> >> } else {
> >> offset = (flag == NAT_BITMAP) ?
> >> le32_to_cpu(ckpt->sit_ver_bitmap_bytesize) : 0;
> >> - return &ckpt->sit_nat_version_bitmap + offset;
> >> + return ckpt->sit_nat_version_bitmap + offset;
> >> }
> >> }
> >>
> >> diff --git a/include/linux/f2fs_fs.h b/include/linux/f2fs_fs.h
> >> index 43e98d30d2df..564f65fc192f 100644
> >> --- a/include/linux/f2fs_fs.h
> >> +++ b/include/linux/f2fs_fs.h
> >> @@ -157,7 +157,7 @@ struct f2fs_checkpoint {
> >> unsigned char alloc_type[MAX_ACTIVE_LOGS];
> >>
> >> /* SIT and NAT version bitmap */
> >> - unsigned char sit_nat_version_bitmap[1];
> >> + unsigned char sit_nat_version_bitmap[];
> >
> > I cannot find any benefit to do this. Moreover, it just makes the header
>
> I intend to change both kernel and tools, sorry, I didn't send out the
> patch on tools. Anyway, I think it could be used to avoid checkpoint
> structure size calculation by "sizeof(struct checkpoint) - 1", with the
> patch, readability can be improved. Right?
I don't think so. It's even defined only in f2fs-tools, and well covered by a
macro. There's no reason to spend time to sync it between f2fs and f2fs-tools.
>
> Thanks,
>
> > structure be different from the one in f2fs-tools.
> >
> >> } __packed;
> >>
> >> /*
> >> --
> >> 2.15.0.55.gc2ece9dc4de6
> >
> > .
> >
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap
2018-01-04 6:16 ` Jaegeuk Kim
@ 2018-01-04 6:28 ` Chao Yu
0 siblings, 0 replies; 6+ messages in thread
From: Chao Yu @ 2018-01-04 6:28 UTC (permalink / raw)
To: Jaegeuk Kim; +Cc: linux-f2fs-devel, linux-kernel, chao
On 2018/1/4 14:16, Jaegeuk Kim wrote:
> On 01/04, Chao Yu wrote:
>> On 2018/1/4 4:12, Jaegeuk Kim wrote:
>>> On 01/03, Chao Yu wrote:
>>>> If we need an array with variable size in the end of structure, we
>>>> can utilize flexible array feature which is supported in C99, so
>>>> let's change sit_nat_version_bitmap[] to flexible array in struct
>>>> f2fs_checkpoint for readability.
>>>>
>>>> Signed-off-by: Chao Yu <yuchao0@huawei.com>
>>>> ---
>>>> fs/f2fs/f2fs.h | 4 ++--
>>>> include/linux/f2fs_fs.h | 2 +-
>>>> 2 files changed, 3 insertions(+), 3 deletions(-)
>>>>
>>>> diff --git a/fs/f2fs/f2fs.h b/fs/f2fs/f2fs.h
>>>> index 83d1f697388b..ad19d29688ae 100644
>>>> --- a/fs/f2fs/f2fs.h
>>>> +++ b/fs/f2fs/f2fs.h
>>>> @@ -1719,13 +1719,13 @@ static inline void *__bitmap_ptr(struct f2fs_sb_info *sbi, int flag)
>>>>
>>>> if (__cp_payload(sbi) > 0) {
>>>> if (flag == NAT_BITMAP)
>>>> - return &ckpt->sit_nat_version_bitmap;
>>>> + return ckpt->sit_nat_version_bitmap;
>>>> else
>>>> return (unsigned char *)ckpt + F2FS_BLKSIZE;
>>>> } else {
>>>> offset = (flag == NAT_BITMAP) ?
>>>> le32_to_cpu(ckpt->sit_ver_bitmap_bytesize) : 0;
>>>> - return &ckpt->sit_nat_version_bitmap + offset;
>>>> + return ckpt->sit_nat_version_bitmap + offset;
>>>> }
>>>> }
>>>>
>>>> diff --git a/include/linux/f2fs_fs.h b/include/linux/f2fs_fs.h
>>>> index 43e98d30d2df..564f65fc192f 100644
>>>> --- a/include/linux/f2fs_fs.h
>>>> +++ b/include/linux/f2fs_fs.h
>>>> @@ -157,7 +157,7 @@ struct f2fs_checkpoint {
>>>> unsigned char alloc_type[MAX_ACTIVE_LOGS];
>>>>
>>>> /* SIT and NAT version bitmap */
>>>> - unsigned char sit_nat_version_bitmap[1];
>>>> + unsigned char sit_nat_version_bitmap[];
>>>
>>> I cannot find any benefit to do this. Moreover, it just makes the header
>>
>> I intend to change both kernel and tools, sorry, I didn't send out the
>> patch on tools. Anyway, I think it could be used to avoid checkpoint
>> structure size calculation by "sizeof(struct checkpoint) - 1", with the
>> patch, readability can be improved. Right?
>
> I don't think so. It's even defined only in f2fs-tools, and well covered by a
> macro. There's no reason to spend time to sync it between f2fs and f2fs-tools.
OK, this is only about readability, it's really not a big deal to drop this
patch.
Thanks,
>
>>
>> Thanks,
>>
>>> structure be different from the one in f2fs-tools.
>>>
>>>> } __packed;
>>>>
>>>> /*
>>>> --
>>>> 2.15.0.55.gc2ece9dc4de6
>>>
>>> .
>>>
>
> .
>
^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2018-01-04 6:28 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-01-03 9:32 [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Chao Yu
2018-01-03 9:32 ` [PATCH 2/2] f2fs: clean up unneeded declaration Chao Yu
2018-01-03 20:12 ` [PATCH 1/2] f2fs: use flexible array for f2fs_checkpoint::sit_nat_version_bitmap Jaegeuk Kim
2018-01-04 1:20 ` Chao Yu
2018-01-04 6:16 ` Jaegeuk Kim
2018-01-04 6:28 ` Chao Yu
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®