mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/5] ipc: cleanups & bugfixes
@ 2018-07-05  5:59 Manfred Spraul
  2018-07-05  5:59 ` [PATCH 1/6] ipc: reorganize initialization of kern_ipc_perm.id Manfred Spraul
                   ` (5 more replies)
  0 siblings, 6 replies; 12+ messages in thread
From: Manfred Spraul @ 2018-07-05  5:59 UTC (permalink / raw)
  To: LKML, Davidlohr Bueso, Dmitry Vyukov
  Cc: 1vier1, Andrew Morton, Kees Cook, Manfred Spraul

Hi,

Dmitry convinced me that I should properly review the initialization
of new ipc objects, and I found another issue.

The series corrects 3 issues with ipc_addid(), and also renames
two functions and corrects a wrong comment.

0001-ipc-reorganize-initialization-of-kern_ipc_perm.id:
	Access kern_ipc_perm.id under the IPC spinlock.
	My original idea of removing kern_ipc_perm entirely
	is not possible, e.g. the proc interface needs the id.

0002-ipc-reorganize-initialization-of-kern_ipc_perm.seq:
	Bugfix for the syzbot finding

0003-ipc-util.c-Use-ipc_rcu_putref-for-failues-in-ipc_add:
	Bugfix from code review

0004-ipc-Rename-ipcctl_pre_down_nolock.patch:
	Comment update & function rename from code review

0005-ipc-rename-ipc_lock-to-ipc_lock_idr:
	Function rename from code review

0006-ipc-util.c-correct-comment-in-ipc_obtain_object_che
	Comment correction from code review

The patches are lightly tested, especially I have not tested
the checkpoint/restore code or tested the failure cases.

--
	Manfred

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2018-07-06 17:18 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-07-05  5:59 [PATCH 0/5] ipc: cleanups & bugfixes Manfred Spraul
2018-07-05  5:59 ` [PATCH 1/6] ipc: reorganize initialization of kern_ipc_perm.id Manfred Spraul
2018-07-05  5:59 ` [PATCH 2/6] ipc: reorganize initialization of kern_ipc_perm.seq Manfred Spraul
2018-07-05  8:36   ` Dmitry Vyukov
2018-07-05 15:12     ` Manfred Spraul
2018-07-05 16:08       ` Dmitry Vyukov
2018-07-05 21:56       ` Andrew Morton
2018-07-06 17:18         ` Davidlohr Bueso
2018-07-05  5:59 ` [PATCH 3/6] ipc/util.c: Use ipc_rcu_putref() for failues in ipc_addid() Manfred Spraul
2018-07-05  5:59 ` [PATCH 4/6] ipc: Rename ipcctl_pre_down_nolock() Manfred Spraul
2018-07-05  5:59 ` [PATCH 5/6] ipc: rename ipc_lock() to ipc_lock_idr() Manfred Spraul
2018-07-05  5:59 ` [PATCH 6/6] ipc/util.c: correct comment in ipc_obtain_object_check Manfred Spraul

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®