From: John Whitmore <johnfwhitmore@gmail.com>
To: linux-kernel@vger.kernel.org
Cc: devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
John Whitmore <johnfwhitmore@gmail.com>
Subject: [PATCH 00/16] staging:rtl8192u: Proxy Structures?
Date: Thu, 26 Jul 2018 20:24:10 +0100 [thread overview]
Message-ID: <20180726192426.31913-1-johnfwhitmore@gmail.com> (raw)
This series of patches contains coding style changes.
There is one type of change, proxy structures, which whilst not flagged
by checkpatch, as an issue, I have changed. I can't see the purpose of
defining a structure, in this case arrays, and then using a #define to
name the structure something else.
This may well be a pattern which I'm not familiar with, in which case
the patches can be rejected, and I'll have learned something, but I thought
I'd better explicitly mention it, as I'm assuming that there is not actual
point to the practice.
Apart from that all the rest are simple coding style changes.
John Whitmore (16):
staging:rtl8192u: Rename SwChnlCmd - Style
staging:rtl8192u: Rename CmdID - Style
staging:rtl8192u: Rename Para1 > para_1 - Style
staging:rtl8192u: Rename Para2 to para_2 - style
staging:rtl8192u: Rename msDelay to ms_delay - Style
staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG - Style
staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray - Style
staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array - Style
staging:rtl8192u: Remove proxy rtl819XRadioA_Array - Style
staging:rtl8192u: Remove proxy rtl819XRadioB_Array - Style
staging:rtl8192u: Remove proxy rtl819XRadioC_Array - Style
staging:rtl8192u: Remove proxy rtl819XRadioD_Array - Style
staging:rtl8192u: Rename HW90_BLOCK_E - Style
staging:rtl8192u: Rename RF90_RADIO_PATH_E - Style
staging:rtl8192u: Remove repeated definitions - Style
staging:rtl8192u: Rename eRFPath - Style
drivers/staging/rtl8192u/r8190_rtl8256.c | 42 ++---
drivers/staging/rtl8192u/r8192U_core.c | 4 +-
drivers/staging/rtl8192u/r819xU_phy.c | 230 +++++++++++------------
drivers/staging/rtl8192u/r819xU_phy.h | 42 ++---
4 files changed, 147 insertions(+), 171 deletions(-)
--
2.18.0
next reply other threads:[~2018-07-26 19:24 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-26 19:24 John Whitmore [this message]
2018-07-26 19:24 ` [PATCH 01/16] staging:rtl8192u: Rename SwChnlCmd - Style John Whitmore
2018-07-26 19:24 ` [PATCH 02/16] staging:rtl8192u: Rename CmdID " John Whitmore
2018-07-26 19:24 ` [PATCH 03/16] staging:rtl8192u: Rename Para1 > para_1 " John Whitmore
2018-07-26 19:24 ` [PATCH 04/16] staging:rtl8192u: Rename Para2 to para_2 - style John Whitmore
2018-07-26 19:24 ` [PATCH 05/16] staging:rtl8192u: Rename msDelay to ms_delay - Style John Whitmore
2018-07-26 19:24 ` [PATCH 06/16] staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG " John Whitmore
2018-07-26 19:24 ` [PATCH 07/16] staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray " John Whitmore
2018-07-26 19:24 ` [PATCH 08/16] staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 09/16] staging:rtl8192u: Remove proxy rtl819XRadioA_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 10/16] staging:rtl8192u: Remove proxy rtl819XRadioB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 11/16] staging:rtl8192u: Remove proxy rtl819XRadioC_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 12/16] staging:rtl8192u: Remove proxy rtl819XRadioD_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 13/16] staging:rtl8192u: Rename HW90_BLOCK_E " John Whitmore
2018-07-26 19:24 ` [PATCH 14/16] staging:rtl8192u: Rename RF90_RADIO_PATH_E " John Whitmore
2018-07-26 19:24 ` [PATCH 15/16] staging:rtl8192u: Remove repeated definitions " John Whitmore
2018-07-26 19:24 ` [PATCH 16/16] staging:rtl8192u: Rename eRFPath " John Whitmore
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180726192426.31913-1-johnfwhitmore@gmail.com \
--to=johnfwhitmore@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome