mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: John Whitmore <johnfwhitmore@gmail.com>
To: linux-kernel@vger.kernel.org
Cc: devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
	John Whitmore <johnfwhitmore@gmail.com>
Subject: [PATCH 01/16] staging:rtl8192u: Rename SwChnlCmd - Style
Date: Thu, 26 Jul 2018 20:24:11 +0100	[thread overview]
Message-ID: <20180726192426.31913-2-johnfwhitmore@gmail.com> (raw)
In-Reply-To: <20180726192426.31913-1-johnfwhitmore@gmail.com>

Rename the structure SwChnlCmd to sw_chnl_cmd. This change clears the
checkpatch issue with CamelCase naming. The change is purely a coding
style change and should have no impact on runtime code execution.

Signed-off-by: John Whitmore <johnfwhitmore@gmail.com>
---
 drivers/staging/rtl8192u/r819xU_phy.c | 16 ++++++++--------
 drivers/staging/rtl8192u/r819xU_phy.h |  2 +-
 2 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/drivers/staging/rtl8192u/r819xU_phy.c b/drivers/staging/rtl8192u/r819xU_phy.c
index 75fcd3134b6d..4a49bc1f139c 100644
--- a/drivers/staging/rtl8192u/r819xU_phy.c
+++ b/drivers/staging/rtl8192u/r819xU_phy.c
@@ -1215,8 +1215,8 @@ bool rtl8192_SetRFPowerState(struct net_device *dev,
 }
 
 /******************************************************************************
- * function:  This function sets command table variable (struct SwChnlCmd).
- * input:     SwChnlCmd      *CmdTable    //table to be set
+ * function:  This function sets command table variable (struct sw_chnl_cmd).
+ * input:     sw_chnl_cmd      *CmdTable    //table to be set
  *            u32            CmdTableIdx  //variable index in table to be set
  *            u32            CmdTableSz   //table size
  *            switch_chan_cmd_id    CmdID        //command ID to set
@@ -1227,11 +1227,11 @@ bool rtl8192_SetRFPowerState(struct net_device *dev,
  * return:    true if finished, false otherwise
  * notice:
  ******************************************************************************/
-static u8 rtl8192_phy_SetSwChnlCmdArray(struct SwChnlCmd *CmdTable, u32 CmdTableIdx,
+static u8 rtl8192_phy_SetSwChnlCmdArray(struct sw_chnl_cmd *CmdTable, u32 CmdTableIdx,
 					u32 CmdTableSz, enum switch_chan_cmd_id CmdID,
 					u32 Para1, u32 Para2, u32 msDelay)
 {
-	struct SwChnlCmd *pCmd;
+	struct sw_chnl_cmd *pCmd;
 
 	if (CmdTable == NULL) {
 		RT_TRACE(COMP_ERR, "%s(): CmdTable cannot be NULL\n", __func__);
@@ -1268,13 +1268,13 @@ static u8 rtl8192_phy_SwChnlStepByStep(struct net_device *dev, u8 channel,
 				       u8 *stage, u8 *step, u32 *delay)
 {
 	struct r8192_priv *priv = ieee80211_priv(dev);
-	struct SwChnlCmd   PreCommonCmd[MAX_PRECMD_CNT];
+	struct sw_chnl_cmd   PreCommonCmd[MAX_PRECMD_CNT];
 	u32		   PreCommonCmdCnt;
-	struct SwChnlCmd   PostCommonCmd[MAX_POSTCMD_CNT];
+	struct sw_chnl_cmd   PostCommonCmd[MAX_POSTCMD_CNT];
 	u32		   PostCommonCmdCnt;
-	struct SwChnlCmd   RfDependCmd[MAX_RFDEPENDCMD_CNT];
+	struct sw_chnl_cmd   RfDependCmd[MAX_RFDEPENDCMD_CNT];
 	u32		   RfDependCmdCnt;
-	struct SwChnlCmd  *CurrentCmd = NULL;
+	struct sw_chnl_cmd  *CurrentCmd = NULL;
 	u8		   eRFPath;
 
 	RT_TRACE(COMP_CH, "%s() stage: %d, step: %d, channel: %d\n",
diff --git a/drivers/staging/rtl8192u/r819xU_phy.h b/drivers/staging/rtl8192u/r819xU_phy.h
index 75aa56ddd22f..509b18415127 100644
--- a/drivers/staging/rtl8192u/r819xU_phy.h
+++ b/drivers/staging/rtl8192u/r819xU_phy.h
@@ -18,7 +18,7 @@ enum switch_chan_cmd_id {
 
 /* -----------------------Define structure---------------------- */
 /* 1. Switch channel related */
-struct SwChnlCmd {
+struct sw_chnl_cmd {
 	enum switch_chan_cmd_id	CmdID;
 	u32		        Para1;
 	u32		        Para2;
-- 
2.18.0


  reply	other threads:[~2018-07-26 19:24 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-26 19:24 [PATCH 00/16] staging:rtl8192u: Proxy Structures? John Whitmore
2018-07-26 19:24 ` John Whitmore [this message]
2018-07-26 19:24 ` [PATCH 02/16] staging:rtl8192u: Rename CmdID - Style John Whitmore
2018-07-26 19:24 ` [PATCH 03/16] staging:rtl8192u: Rename Para1 > para_1 " John Whitmore
2018-07-26 19:24 ` [PATCH 04/16] staging:rtl8192u: Rename Para2 to para_2 - style John Whitmore
2018-07-26 19:24 ` [PATCH 05/16] staging:rtl8192u: Rename msDelay to ms_delay - Style John Whitmore
2018-07-26 19:24 ` [PATCH 06/16] staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG " John Whitmore
2018-07-26 19:24 ` [PATCH 07/16] staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray " John Whitmore
2018-07-26 19:24 ` [PATCH 08/16] staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 09/16] staging:rtl8192u: Remove proxy rtl819XRadioA_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 10/16] staging:rtl8192u: Remove proxy rtl819XRadioB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 11/16] staging:rtl8192u: Remove proxy rtl819XRadioC_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 12/16] staging:rtl8192u: Remove proxy rtl819XRadioD_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 13/16] staging:rtl8192u: Rename HW90_BLOCK_E " John Whitmore
2018-07-26 19:24 ` [PATCH 14/16] staging:rtl8192u: Rename RF90_RADIO_PATH_E " John Whitmore
2018-07-26 19:24 ` [PATCH 15/16] staging:rtl8192u: Remove repeated definitions " John Whitmore
2018-07-26 19:24 ` [PATCH 16/16] staging:rtl8192u: Rename eRFPath " John Whitmore

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180726192426.31913-2-johnfwhitmore@gmail.com \
    --to=johnfwhitmore@gmail.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome