From: John Whitmore <johnfwhitmore@gmail.com>
To: linux-kernel@vger.kernel.org
Cc: devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
John Whitmore <johnfwhitmore@gmail.com>
Subject: [PATCH 03/16] staging:rtl8192u: Rename Para1 > para_1 - Style
Date: Thu, 26 Jul 2018 20:24:13 +0100 [thread overview]
Message-ID: <20180726192426.31913-4-johnfwhitmore@gmail.com> (raw)
In-Reply-To: <20180726192426.31913-1-johnfwhitmore@gmail.com>
Rename the member variable Para1 to para_1. This change clears the
checkpatch issue with CamelCase naming. The change is purely a coding
style change and should have no impact on runtime code execution.
Signed-off-by: John Whitmore <johnfwhitmore@gmail.com>
---
drivers/staging/rtl8192u/r819xU_phy.c | 10 +++++-----
drivers/staging/rtl8192u/r819xU_phy.h | 2 +-
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8192u/r819xU_phy.c b/drivers/staging/rtl8192u/r819xU_phy.c
index 17cc47e20145..c2a73ec90f70 100644
--- a/drivers/staging/rtl8192u/r819xU_phy.c
+++ b/drivers/staging/rtl8192u/r819xU_phy.c
@@ -1245,7 +1245,7 @@ static u8 rtl8192_phy_SetSwChnlCmdArray(struct sw_chnl_cmd *CmdTable, u32 CmdTab
pCmd = CmdTable + CmdTableIdx;
pCmd->cmd_id = CmdID;
- pCmd->Para1 = Para1;
+ pCmd->para_1 = Para1;
pCmd->Para2 = Para2;
pCmd->msDelay = msDelay;
@@ -1380,22 +1380,22 @@ static u8 rtl8192_phy_SwChnlStepByStep(struct net_device *dev, u8 channel,
rtl8192_SetTxPowerLevel(dev, channel);
break;
case CMD_ID_WRITE_PORT_ULONG:
- write_nic_dword(dev, CurrentCmd->Para1,
+ write_nic_dword(dev, CurrentCmd->para_1,
CurrentCmd->Para2);
break;
case CMD_ID_WRITE_PORT_USHORT:
- write_nic_word(dev, CurrentCmd->Para1,
+ write_nic_word(dev, CurrentCmd->para_1,
(u16)CurrentCmd->Para2);
break;
case CMD_ID_WRITE_PORT_UCHAR:
- write_nic_byte(dev, CurrentCmd->Para1,
+ write_nic_byte(dev, CurrentCmd->para_1,
(u8)CurrentCmd->Para2);
break;
case CMD_ID_RF_WRITE_REG:
for (eRFPath = 0; eRFPath < RF90_PATH_MAX; eRFPath++) {
rtl8192_phy_SetRFReg(dev,
(enum RF90_RADIO_PATH_E)eRFPath,
- CurrentCmd->Para1,
+ CurrentCmd->para_1,
bZebra1_ChannelNum,
CurrentCmd->Para2);
}
diff --git a/drivers/staging/rtl8192u/r819xU_phy.h b/drivers/staging/rtl8192u/r819xU_phy.h
index 75970febaac5..77ae606c77ce 100644
--- a/drivers/staging/rtl8192u/r819xU_phy.h
+++ b/drivers/staging/rtl8192u/r819xU_phy.h
@@ -20,7 +20,7 @@ enum switch_chan_cmd_id {
/* 1. Switch channel related */
struct sw_chnl_cmd {
enum switch_chan_cmd_id cmd_id;
- u32 Para1;
+ u32 para_1;
u32 Para2;
u32 msDelay;
} __packed;
--
2.18.0
next prev parent reply other threads:[~2018-07-26 19:24 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-26 19:24 [PATCH 00/16] staging:rtl8192u: Proxy Structures? John Whitmore
2018-07-26 19:24 ` [PATCH 01/16] staging:rtl8192u: Rename SwChnlCmd - Style John Whitmore
2018-07-26 19:24 ` [PATCH 02/16] staging:rtl8192u: Rename CmdID " John Whitmore
2018-07-26 19:24 ` John Whitmore [this message]
2018-07-26 19:24 ` [PATCH 04/16] staging:rtl8192u: Rename Para2 to para_2 - style John Whitmore
2018-07-26 19:24 ` [PATCH 05/16] staging:rtl8192u: Rename msDelay to ms_delay - Style John Whitmore
2018-07-26 19:24 ` [PATCH 06/16] staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG " John Whitmore
2018-07-26 19:24 ` [PATCH 07/16] staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray " John Whitmore
2018-07-26 19:24 ` [PATCH 08/16] staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 09/16] staging:rtl8192u: Remove proxy rtl819XRadioA_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 10/16] staging:rtl8192u: Remove proxy rtl819XRadioB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 11/16] staging:rtl8192u: Remove proxy rtl819XRadioC_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 12/16] staging:rtl8192u: Remove proxy rtl819XRadioD_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 13/16] staging:rtl8192u: Rename HW90_BLOCK_E " John Whitmore
2018-07-26 19:24 ` [PATCH 14/16] staging:rtl8192u: Rename RF90_RADIO_PATH_E " John Whitmore
2018-07-26 19:24 ` [PATCH 15/16] staging:rtl8192u: Remove repeated definitions " John Whitmore
2018-07-26 19:24 ` [PATCH 16/16] staging:rtl8192u: Rename eRFPath " John Whitmore
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180726192426.31913-4-johnfwhitmore@gmail.com \
--to=johnfwhitmore@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome