From: John Whitmore <johnfwhitmore@gmail.com>
To: linux-kernel@vger.kernel.org
Cc: devel@driverdev.osuosl.org, gregkh@linuxfoundation.org,
John Whitmore <johnfwhitmore@gmail.com>
Subject: [PATCH 11/16] staging:rtl8192u: Remove proxy rtl819XRadioC_Array - Style
Date: Thu, 26 Jul 2018 20:24:21 +0100 [thread overview]
Message-ID: <20180726192426.31913-12-johnfwhitmore@gmail.com> (raw)
In-Reply-To: <20180726192426.31913-1-johnfwhitmore@gmail.com>
Remove the array rtl819XRadioC_Array which is only serving as a proxy for
the real array Rtl8192UsbRadioC_Array. This is a coding style change and
should have no impact on runtime code execution.
Signed-off-by: John Whitmore <johnfwhitmore@gmail.com>
---
drivers/staging/rtl8192u/r819xU_phy.c | 7 +++----
drivers/staging/rtl8192u/r819xU_phy.h | 1 -
2 files changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8192u/r819xU_phy.c b/drivers/staging/rtl8192u/r819xU_phy.c
index 1cbb48c5c110..3ed48d6095d7 100644
--- a/drivers/staging/rtl8192u/r819xU_phy.c
+++ b/drivers/staging/rtl8192u/r819xU_phy.c
@@ -29,7 +29,6 @@ static u32 RF_CHANNEL_TABLE_ZEBRA[] = {
};
#define rtl819XMACPHY_Array Rtl8192UsbMACPHY_Array
-#define rtl819XRadioC_Array Rtl8192UsbRadioC_Array
#define rtl819XRadioD_Array Rtl8192UsbRadioD_Array
/******************************************************************************
@@ -1009,14 +1008,14 @@ u8 rtl8192_phy_ConfigRFWithHeaderFile(struct net_device *dev,
case RF90_PATH_C:
for (i = 0; i < RadioC_ArrayLength; i = i+2) {
- if (rtl819XRadioC_Array[i] == 0xfe) {
+ if (Rtl8192UsbRadioC_Array[i] == 0xfe) {
mdelay(100);
continue;
}
rtl8192_phy_SetRFReg(dev, eRFPath,
- rtl819XRadioC_Array[i],
+ Rtl8192UsbRadioC_Array[i],
bMask12Bits,
- rtl819XRadioC_Array[i+1]);
+ Rtl8192UsbRadioC_Array[i+1]);
mdelay(1);
}
diff --git a/drivers/staging/rtl8192u/r819xU_phy.h b/drivers/staging/rtl8192u/r819xU_phy.h
index d708796d7cec..44af37f19f45 100644
--- a/drivers/staging/rtl8192u/r819xU_phy.h
+++ b/drivers/staging/rtl8192u/r819xU_phy.h
@@ -25,7 +25,6 @@ struct sw_chnl_cmd {
u32 ms_delay;
} __packed;
-extern u32 rtl819XRadioC_Array[];
extern u32 rtl819XRadioD_Array[];
enum HW90_BLOCK_E {
--
2.18.0
next prev parent reply other threads:[~2018-07-26 19:25 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-26 19:24 [PATCH 00/16] staging:rtl8192u: Proxy Structures? John Whitmore
2018-07-26 19:24 ` [PATCH 01/16] staging:rtl8192u: Rename SwChnlCmd - Style John Whitmore
2018-07-26 19:24 ` [PATCH 02/16] staging:rtl8192u: Rename CmdID " John Whitmore
2018-07-26 19:24 ` [PATCH 03/16] staging:rtl8192u: Rename Para1 > para_1 " John Whitmore
2018-07-26 19:24 ` [PATCH 04/16] staging:rtl8192u: Rename Para2 to para_2 - style John Whitmore
2018-07-26 19:24 ` [PATCH 05/16] staging:rtl8192u: Rename msDelay to ms_delay - Style John Whitmore
2018-07-26 19:24 ` [PATCH 06/16] staging:rtl8192u: Remove proxy struct rtl819XMACPHY_Array_PG " John Whitmore
2018-07-26 19:24 ` [PATCH 07/16] staging:rtl8192u: Remove proxy struct rtl819XPHY_REG_1T2RArray " John Whitmore
2018-07-26 19:24 ` [PATCH 08/16] staging:rtl8192u: Remove proxy array rtl819XAGCTAB_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 09/16] staging:rtl8192u: Remove proxy rtl819XRadioA_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 10/16] staging:rtl8192u: Remove proxy rtl819XRadioB_Array " John Whitmore
2018-07-26 19:24 ` John Whitmore [this message]
2018-07-26 19:24 ` [PATCH 12/16] staging:rtl8192u: Remove proxy rtl819XRadioD_Array " John Whitmore
2018-07-26 19:24 ` [PATCH 13/16] staging:rtl8192u: Rename HW90_BLOCK_E " John Whitmore
2018-07-26 19:24 ` [PATCH 14/16] staging:rtl8192u: Rename RF90_RADIO_PATH_E " John Whitmore
2018-07-26 19:24 ` [PATCH 15/16] staging:rtl8192u: Remove repeated definitions " John Whitmore
2018-07-26 19:24 ` [PATCH 16/16] staging:rtl8192u: Rename eRFPath " John Whitmore
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180726192426.31913-12-johnfwhitmore@gmail.com \
--to=johnfwhitmore@gmail.com \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome