mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Niklas Söderlund" <niklas.soderlund@ragnatech.se>
To: Michael Dege <michael.dege@renesas.com>
Cc: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>,
	Paul Barker <paul@pbarker.dev>,
	Andrew Lunn <andrew+netdev@lunn.ch>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
	netdev@vger.kernel.org, linux-renesas-soc@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	Nikita Yushchenko <nikita.yoush@cogentembedded.com>
Subject: Re: [PATCH 1/3] net: renesas: rswitch: rename rswitch.c to rswitch_main.c
Date: Fri, 4 Jul 2025 11:11:46 +0200	[thread overview]
Message-ID: <20250704091146.GB137171@ragnatech.se> (raw)
In-Reply-To: <20250704-add_l2_switching-v1-1-ff882aacb258@renesas.com>

Hi Michael,

Thanks for your work.

On 2025-07-04 07:51:15 +0200, Michael Dege wrote:
> Adding new functionality to the driver. Therefore splitting into multiple
> c files to keep them manageable. New functionality will be added to
> separate files.
> 
> Signed-off-by: Michael Dege <michael.dege@renesas.com>

Reviewed-by: Niklas Söderlund <niklas.soderlund+renesas@ragnatech.se>

> ---
>  drivers/net/ethernet/renesas/Makefile                      | 1 +
>  drivers/net/ethernet/renesas/{rswitch.c => rswitch_main.c} | 0
>  2 files changed, 1 insertion(+)
> 
> diff --git a/drivers/net/ethernet/renesas/Makefile b/drivers/net/ethernet/renesas/Makefile
> index f65fc76f8b4df8dd9f24af836b6dc0772965366f..6222298bb5582b7091cf8de76acb83ac7dd39c11 100644
> --- a/drivers/net/ethernet/renesas/Makefile
> +++ b/drivers/net/ethernet/renesas/Makefile
> @@ -8,6 +8,7 @@ obj-$(CONFIG_SH_ETH) += sh_eth.o
>  ravb-objs := ravb_main.o ravb_ptp.o
>  obj-$(CONFIG_RAVB) += ravb.o
>  
> +rswitch-objs := rswitch_main.o
>  obj-$(CONFIG_RENESAS_ETHER_SWITCH) += rswitch.o
>  
>  obj-$(CONFIG_RENESAS_GEN4_PTP) += rcar_gen4_ptp.o
> diff --git a/drivers/net/ethernet/renesas/rswitch.c b/drivers/net/ethernet/renesas/rswitch_main.c
> similarity index 100%
> rename from drivers/net/ethernet/renesas/rswitch.c
> rename to drivers/net/ethernet/renesas/rswitch_main.c
> 
> -- 
> 2.49.0
> 

-- 
Kind Regards,
Niklas Söderlund

  parent reply	other threads:[~2025-07-04  9:11 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-04  5:51 [PATCH 0/3] net: renesas: rswitch: R-Car S4 add HW offloading for layer 2 switching Michael Dege
2025-07-04  5:51 ` [PATCH 1/3] net: renesas: rswitch: rename rswitch.c to rswitch_main.c Michael Dege
2025-07-04  8:34   ` Andrew Lunn
2025-07-04  9:11   ` Niklas Söderlund [this message]
2025-07-04  5:51 ` [PATCH 2/3] net: renesas: rswitch: add offloading for L2 switching Michael Dege
2025-07-04  8:43   ` Andrew Lunn
2025-07-04  9:02     ` Nikita Yushchenko
2025-07-04 17:49       ` Andrew Lunn
2025-07-07  8:13     ` Michael Dege
2025-07-07  8:42       ` Michael Dege
2025-07-07 11:30       ` Andrew Lunn
2025-07-04  5:51 ` [PATCH 3/3] net: renesas: rswitch: add modifiable ageing time Michael Dege
2025-07-07 12:50   ` Geert Uytterhoeven
2025-07-07 12:59     ` Michael Dege
2025-07-04  8:33 ` [PATCH 0/3] net: renesas: rswitch: R-Car S4 add HW offloading for layer 2 switching Andrew Lunn
2025-07-07 10:41   ` Michael Dege
2025-07-07 11:53     ` Andrew Lunn
2025-07-07 12:25       ` Michael Dege
2025-07-04  8:46 ` Andrew Lunn
2025-07-04  9:05   ` Nikita Yushchenko
2025-07-04 17:53     ` Andrew Lunn
2025-07-04 17:56       ` Nikita Yushchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250704091146.GB137171@ragnatech.se \
    --to=niklas.soderlund@ragnatech.se \
    --cc=andrew+netdev@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=michael.dege@renesas.com \
    --cc=netdev@vger.kernel.org \
    --cc=nikita.yoush@cogentembedded.com \
    --cc=pabeni@redhat.com \
    --cc=paul@pbarker.dev \
    --cc=yoshihiro.shimoda.uh@renesas.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®