From: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: linux-kernel@vger.kernel.org,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
Josh Poimboeuf <jpoimboe@kernel.org>,
Masami Hiramatsu <mhiramat@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@kernel.org>, Jiri Olsa <jolsa@kernel.org>,
Namhyung Kim <namhyung@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>,
Andrii Nakryiko <andrii@kernel.org>,
Indu Bhagat <indu.bhagat@oracle.com>,
"Jose E. Marchesi" <jemarch@gnu.org>,
Beau Belgrave <beaub@linux.microsoft.com>,
Jens Remus <jremus@linux.ibm.com>,
Linus Torvalds <torvalds@linux-foundation.org>,
Andrew Morton <akpm@linux-foundation.org>
Subject: [RFC PATCH 2/5] unwind: Export unwind_user symbol to GPL modules
Date: Wed, 9 Jul 2025 17:25:49 -0400 [thread overview]
Message-ID: <20250709212556.32777-3-mathieu.desnoyers@efficios.com> (raw)
In-Reply-To: <20250709212556.32777-1-mathieu.desnoyers@efficios.com>
Allow the unwind_user symbol to be used by GPL modules, for instance
LTTng.
Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Cc: Steven Rostedt (Google) <rostedt@goodmis.org>
Cc: Josh Poimboeuf <jpoimboe@kernel.org>
Cc: Masami Hiramatsu <mhiramat@kernel.org>
Cc: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Ingo Molnar <mingo@kernel.org>
Cc: Jiri Olsa <jolsa@kernel.org>
Cc: Namhyung Kim <namhyung@kernel.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Andrii Nakryiko <andrii@kernel.org>
Cc: Indu Bhagat <indu.bhagat@oracle.com>
Cc: "Jose E. Marchesi" <jemarch@gnu.org>
Cc: Beau Belgrave <beaub@linux.microsoft.com>
Cc: Jens Remus <jremus@linux.ibm.com>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Andrew Morton <akpm@linux-foundation.org>
---
kernel/unwind/user.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/kernel/unwind/user.c b/kernel/unwind/user.c
index 349bdd72390b..9aefbfc8427a 100644
--- a/kernel/unwind/user.c
+++ b/kernel/unwind/user.c
@@ -187,3 +187,4 @@ int unwind_user(struct unwind_stacktrace *trace, unsigned int max_entries)
return 0;
}
+EXPORT_SYMBOL_GPL(unwind_user);
--
2.43.0
next prev parent reply other threads:[~2025-07-09 21:26 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-09 21:25 [RFC PATCH 0/5] Improvements to unwind user Mathieu Desnoyers
2025-07-09 21:25 ` [RFC PATCH 1/5] unwind_user: Fix userspace unwind iterator 32-bit compat handling Mathieu Desnoyers
2025-07-09 21:25 ` Mathieu Desnoyers [this message]
2025-07-11 7:36 ` [RFC PATCH 2/5] unwind: Export unwind_user symbol to GPL modules Christoph Hellwig
2025-07-11 10:57 ` Steven Rostedt
2025-07-11 11:38 ` Greg KH
2025-07-11 13:17 ` Steven Rostedt
2025-07-11 16:39 ` Greg KH
2025-07-11 17:32 ` Steven Rostedt
2025-07-11 18:24 ` Greg KH
2025-07-11 18:28 ` Steven Rostedt
2025-07-15 14:34 ` Steven Rostedt
2025-07-11 14:02 ` Steven Rostedt
2025-07-11 14:17 ` Mathieu Desnoyers
2025-07-11 18:10 ` dan.j.williams
2025-07-11 18:21 ` Steven Rostedt
2025-07-14 6:40 ` Christoph Hellwig
2025-07-11 17:22 ` James Bottomley
2025-07-14 6:39 ` Christoph Hellwig
2025-07-14 10:27 ` Steven Rostedt
2025-07-14 11:38 ` Christoph Hellwig
2025-07-14 11:54 ` Steven Rostedt
2025-07-14 11:59 ` Greg KH
2025-07-14 12:20 ` Steven Rostedt
2025-07-14 12:26 ` Steven Rostedt
2025-07-14 13:26 ` Greg KH
2025-07-14 13:35 ` Steven Rostedt
2025-07-14 13:56 ` Greg KH
2025-07-14 14:05 ` Steven Rostedt
2025-07-14 13:43 ` Arjan van de Ven
2025-07-14 12:02 ` Steven Rostedt
2025-07-15 7:19 ` Christoph Hellwig
2025-07-15 9:26 ` Steven Rostedt
2025-07-09 21:25 ` [RFC PATCH 3/5] unwind deferred: Introduce unwind_user_trace_cached Mathieu Desnoyers
2025-07-11 7:37 ` Christoph Hellwig
2025-07-09 21:25 ` [RFC PATCH 4/5] unwind: Rename unwind_stacktrace to unwind_user_stacktrace Mathieu Desnoyers
2025-07-09 21:41 ` Steven Rostedt
2025-07-10 21:32 ` Steven Rostedt
2025-07-09 21:25 ` [RFC PATCH 5/5] unwind: Introduce unwind user entry type Mathieu Desnoyers
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250709212556.32777-3-mathieu.desnoyers@efficios.com \
--to=mathieu.desnoyers@efficios.com \
--cc=akpm@linux-foundation.org \
--cc=andrii@kernel.org \
--cc=beaub@linux.microsoft.com \
--cc=indu.bhagat@oracle.com \
--cc=jemarch@gnu.org \
--cc=jolsa@kernel.org \
--cc=jpoimboe@kernel.org \
--cc=jremus@linux.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mhiramat@kernel.org \
--cc=mingo@kernel.org \
--cc=namhyung@kernel.org \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®