From: Steven Rostedt <rostedt@goodmis.org>
To: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Cc: linux-kernel@vger.kernel.org,
Josh Poimboeuf <jpoimboe@kernel.org>,
Masami Hiramatsu <mhiramat@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Ingo Molnar <mingo@kernel.org>, Jiri Olsa <jolsa@kernel.org>,
Namhyung Kim <namhyung@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>,
Andrii Nakryiko <andrii@kernel.org>,
Indu Bhagat <indu.bhagat@oracle.com>,
"Jose E. Marchesi" <jemarch@gnu.org>,
Beau Belgrave <beaub@linux.microsoft.com>,
Jens Remus <jremus@linux.ibm.com>,
Linus Torvalds <torvalds@linux-foundation.org>,
Andrew Morton <akpm@linux-foundation.org>
Subject: Re: [RFC PATCH 4/5] unwind: Rename unwind_stacktrace to unwind_user_stacktrace
Date: Thu, 10 Jul 2025 17:32:57 -0400 [thread overview]
Message-ID: <20250710173257.794d466d@batman.local.home> (raw)
In-Reply-To: <20250709174139.4aa32d2c@gandalf.local.home>
On Wed, 9 Jul 2025 17:41:39 -0400
Steven Rostedt <rostedt@goodmis.org> wrote:
> On Wed, 9 Jul 2025 17:25:51 -0400
> Mathieu Desnoyers <mathieu.desnoyers@efficios.com> wrote:
>
> > Rename the unwind_stacktrace structure to unwind_user_stacktrace to make
> > it consistent with the rest of the API.
>
> We originally had that name, but decided it was too long. As only the
> deferred unwind uses "unwind_" and it is currently only for user space, do
> we really need to have a 22 character structure name? 17 is already big
> enough.
>
> And say we make an unwind_kernel_stacktrace()? I doubt we ever would, but
> if we did, it would still use the same structure. There's nothing
> inherently user space here (with maybe the exception of the compat type,
> but still).
>
> And how is this unique to user space? The kernel can have sframes too.
>
> Actually, I think we should rename "enum unwind_user_type" to
> "enum unwind_type".
>
> struct unwind_entry {
> enum unwind_type type;
> unsigned long ip;
> };
>
> As it is only being used for user space now, but it doesn't mean it can't
> be used for the kernel.
>
> Heck, there's already work to use sframes in kernel code to replace ORC so
> that architectures like ARM64 can have live kernel patching.
Actually, I'm going to leave everything as is. The "struct unwind_user_*"
is only used internally in the user code and is not part of the API of
the infrastructure. The "struct unwind_stackframe" is used in the API
as a parameter. To me, it makes more sense to keep it short than adding
"user" to it and making all the callbacks have a longer name.
I know your patch 5 exposes more, but we'll deal with that when the
time comes.
-- Steve
next prev parent reply other threads:[~2025-07-10 21:33 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-09 21:25 [RFC PATCH 0/5] Improvements to unwind user Mathieu Desnoyers
2025-07-09 21:25 ` [RFC PATCH 1/5] unwind_user: Fix userspace unwind iterator 32-bit compat handling Mathieu Desnoyers
2025-07-09 21:25 ` [RFC PATCH 2/5] unwind: Export unwind_user symbol to GPL modules Mathieu Desnoyers
2025-07-11 7:36 ` Christoph Hellwig
2025-07-11 10:57 ` Steven Rostedt
2025-07-11 11:38 ` Greg KH
2025-07-11 13:17 ` Steven Rostedt
2025-07-11 16:39 ` Greg KH
2025-07-11 17:32 ` Steven Rostedt
2025-07-11 18:24 ` Greg KH
2025-07-11 18:28 ` Steven Rostedt
2025-07-15 14:34 ` Steven Rostedt
2025-07-11 14:02 ` Steven Rostedt
2025-07-11 14:17 ` Mathieu Desnoyers
2025-07-11 18:10 ` dan.j.williams
2025-07-11 18:21 ` Steven Rostedt
2025-07-14 6:40 ` Christoph Hellwig
2025-07-11 17:22 ` James Bottomley
2025-07-14 6:39 ` Christoph Hellwig
2025-07-14 10:27 ` Steven Rostedt
2025-07-14 11:38 ` Christoph Hellwig
2025-07-14 11:54 ` Steven Rostedt
2025-07-14 11:59 ` Greg KH
2025-07-14 12:20 ` Steven Rostedt
2025-07-14 12:26 ` Steven Rostedt
2025-07-14 13:26 ` Greg KH
2025-07-14 13:35 ` Steven Rostedt
2025-07-14 13:56 ` Greg KH
2025-07-14 14:05 ` Steven Rostedt
2025-07-14 13:43 ` Arjan van de Ven
2025-07-14 12:02 ` Steven Rostedt
2025-07-15 7:19 ` Christoph Hellwig
2025-07-15 9:26 ` Steven Rostedt
2025-07-09 21:25 ` [RFC PATCH 3/5] unwind deferred: Introduce unwind_user_trace_cached Mathieu Desnoyers
2025-07-11 7:37 ` Christoph Hellwig
2025-07-09 21:25 ` [RFC PATCH 4/5] unwind: Rename unwind_stacktrace to unwind_user_stacktrace Mathieu Desnoyers
2025-07-09 21:41 ` Steven Rostedt
2025-07-10 21:32 ` Steven Rostedt [this message]
2025-07-09 21:25 ` [RFC PATCH 5/5] unwind: Introduce unwind user entry type Mathieu Desnoyers
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250710173257.794d466d@batman.local.home \
--to=rostedt@goodmis.org \
--cc=akpm@linux-foundation.org \
--cc=andrii@kernel.org \
--cc=beaub@linux.microsoft.com \
--cc=indu.bhagat@oracle.com \
--cc=jemarch@gnu.org \
--cc=jolsa@kernel.org \
--cc=jpoimboe@kernel.org \
--cc=jremus@linux.ibm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=mhiramat@kernel.org \
--cc=mingo@kernel.org \
--cc=namhyung@kernel.org \
--cc=peterz@infradead.org \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®