mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: James Bottomley <James.Bottomley@HansenPartnership.com>
To: Greg KH <gregkh@linuxfoundation.org>,
	Steven Rostedt <rostedt@goodmis.org>
Cc: Christoph Hellwig <hch@infradead.org>,
	Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
	linux-kernel@vger.kernel.org,
	Josh Poimboeuf <jpoimboe@kernel.org>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Ingo Molnar <mingo@kernel.org>, Jiri Olsa <jolsa@kernel.org>,
	Namhyung Kim <namhyung@kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Andrii Nakryiko <andrii@kernel.org>,
	Indu Bhagat <indu.bhagat@oracle.com>,
	"Jose E. Marchesi" <jemarch@gnu.org>,
	Beau Belgrave <beaub@linux.microsoft.com>,
	Jens Remus <jremus@linux.ibm.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	 tech-board-discuss@lists.linuxfoundation.org
Subject: Re: [RFC PATCH 2/5] unwind: Export unwind_user symbol to GPL modules
Date: Fri, 11 Jul 2025 10:22:50 -0700	[thread overview]
Message-ID: <9ca3a6596596e87e7ee06be3414387859aaadafc.camel@HansenPartnership.com> (raw)
In-Reply-To: <2025071124-cola-slouching-9dd2@gregkh>

On Fri, 2025-07-11 at 13:38 +0200, Greg KH wrote:
> On Fri, Jul 11, 2025 at 06:57:42AM -0400, Steven Rostedt wrote:
> > 
> > [ Adding the TAB to this as well ]
> > 
> > On Fri, 11 Jul 2025 00:36:28 -0700
> > Christoph Hellwig <hch@infradead.org> wrote:
> > 
> > > On Wed, Jul 09, 2025 at 05:25:49PM -0400, Mathieu Desnoyers
> > > wrote:
> > > > Allow the unwind_user symbol to be used by GPL modules, for
> > > > instance LTTng.  
> > > 
> > > I don't see a LTTng submission or any other user in this series.
> > > So the usual prohibition against adding unused exports applies
> > > here as usual.
> > 
> > I want to bring up this discussion. I understand there's a policy
> > not to add EXPORT_SYMBOL_GPL() unless there's a current user of it
> > in the kernel proper. My question is, does this policy have to be
> > draconian?
> 
> It's not "draconian", it is "we do not add exports for stuff that is
> not in our kernel tree."  Simple, direct, and obvious.  We have no
> idea how, or if, external modules do anything with apis that we
> export and do not use internally, so we can't change them without
> breaking anything, so it's simpler and more obvious to not even
> attempt to care about
> them.

Since the argument is still going on, I've got to say I agree with
Greg: it's not draconian it's a simple technical rule which is easily
enforceable and gets us out of making political decisions like what's a
"good" use of a symbol and what isn't.  Once we start making political
decisions about kernel symbol exports we open ourselves up to
accusations of partisanship and favouritism ... since we have a clear
technical criterion, it's just way easier not to descend that slippery
slope.

Regards,

James


  parent reply	other threads:[~2025-07-11 17:23 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-09 21:25 [RFC PATCH 0/5] Improvements to unwind user Mathieu Desnoyers
2025-07-09 21:25 ` [RFC PATCH 1/5] unwind_user: Fix userspace unwind iterator 32-bit compat handling Mathieu Desnoyers
2025-07-09 21:25 ` [RFC PATCH 2/5] unwind: Export unwind_user symbol to GPL modules Mathieu Desnoyers
2025-07-11  7:36   ` Christoph Hellwig
2025-07-11 10:57     ` Steven Rostedt
2025-07-11 11:38       ` Greg KH
2025-07-11 13:17         ` Steven Rostedt
2025-07-11 16:39           ` Greg KH
2025-07-11 17:32             ` Steven Rostedt
2025-07-11 18:24               ` Greg KH
2025-07-11 18:28                 ` Steven Rostedt
2025-07-15 14:34             ` Steven Rostedt
2025-07-11 14:02         ` Steven Rostedt
2025-07-11 14:17           ` Mathieu Desnoyers
2025-07-11 18:10           ` dan.j.williams
2025-07-11 18:21             ` Steven Rostedt
2025-07-14  6:40             ` Christoph Hellwig
2025-07-11 17:22         ` James Bottomley [this message]
2025-07-14  6:39       ` Christoph Hellwig
2025-07-14 10:27         ` Steven Rostedt
2025-07-14 11:38           ` Christoph Hellwig
2025-07-14 11:54             ` Steven Rostedt
2025-07-14 11:59               ` Greg KH
2025-07-14 12:20                 ` Steven Rostedt
2025-07-14 12:26                   ` Steven Rostedt
2025-07-14 13:26                   ` Greg KH
2025-07-14 13:35                     ` Steven Rostedt
2025-07-14 13:56                       ` Greg KH
2025-07-14 14:05                         ` Steven Rostedt
2025-07-14 13:43                     ` Arjan van de Ven
2025-07-14 12:02               ` Steven Rostedt
2025-07-15  7:19               ` Christoph Hellwig
2025-07-15  9:26                 ` Steven Rostedt
2025-07-09 21:25 ` [RFC PATCH 3/5] unwind deferred: Introduce unwind_user_trace_cached Mathieu Desnoyers
2025-07-11  7:37   ` Christoph Hellwig
2025-07-09 21:25 ` [RFC PATCH 4/5] unwind: Rename unwind_stacktrace to unwind_user_stacktrace Mathieu Desnoyers
2025-07-09 21:41   ` Steven Rostedt
2025-07-10 21:32     ` Steven Rostedt
2025-07-09 21:25 ` [RFC PATCH 5/5] unwind: Introduce unwind user entry type Mathieu Desnoyers

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9ca3a6596596e87e7ee06be3414387859aaadafc.camel@HansenPartnership.com \
    --to=james.bottomley@hansenpartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=andrii@kernel.org \
    --cc=beaub@linux.microsoft.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@infradead.org \
    --cc=indu.bhagat@oracle.com \
    --cc=jemarch@gnu.org \
    --cc=jolsa@kernel.org \
    --cc=jpoimboe@kernel.org \
    --cc=jremus@linux.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mhiramat@kernel.org \
    --cc=mingo@kernel.org \
    --cc=namhyung@kernel.org \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=tech-board-discuss@lists.linuxfoundation.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®