mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@infradead.org>
To: dan.j.williams@intel.com
Cc: Steven Rostedt <rostedt@goodmis.org>,
	Greg KH <gregkh@linuxfoundation.org>,
	Christoph Hellwig <hch@infradead.org>,
	Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
	linux-kernel@vger.kernel.org,
	Josh Poimboeuf <jpoimboe@kernel.org>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Ingo Molnar <mingo@kernel.org>, Jiri Olsa <jolsa@kernel.org>,
	Namhyung Kim <namhyung@kernel.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	Andrii Nakryiko <andrii@kernel.org>,
	Indu Bhagat <indu.bhagat@oracle.com>,
	"Jose E. Marchesi" <jemarch@gnu.org>,
	Beau Belgrave <beaub@linux.microsoft.com>,
	Jens Remus <jremus@linux.ibm.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	tech-board-discuss@lists.linuxfoundation.org
Subject: Re: [RFC PATCH 2/5] unwind: Export unwind_user symbol to GPL modules
Date: Sun, 13 Jul 2025 23:40:03 -0700	[thread overview]
Message-ID: <aHSmQ0AcZA-FUk4M@infradead.org> (raw)
In-Reply-To: <6871537ec0461_1d3d100c6@dwillia2-xfh.jf.intel.com.notmuch>

On Fri, Jul 11, 2025 at 11:10:06AM -0700, dan.j.williams@intel.com wrote:
> It is odd to read this claimed benefit when viewing it from the wider
> Linux kernel project. Upstream maintenance of ABI contracts is the
> fundamental struggle of subsystems. The request, "can we get the kernel
> out of the way and maintain our own ABI to our users?" is a consistent
> refrain, and it consistently receives a qualified "no" for regression,
> security, and other interface evolution concerns.

Exactly.

  parent reply	other threads:[~2025-07-14  6:40 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-09 21:25 [RFC PATCH 0/5] Improvements to unwind user Mathieu Desnoyers
2025-07-09 21:25 ` [RFC PATCH 1/5] unwind_user: Fix userspace unwind iterator 32-bit compat handling Mathieu Desnoyers
2025-07-09 21:25 ` [RFC PATCH 2/5] unwind: Export unwind_user symbol to GPL modules Mathieu Desnoyers
2025-07-11  7:36   ` Christoph Hellwig
2025-07-11 10:57     ` Steven Rostedt
2025-07-11 11:38       ` Greg KH
2025-07-11 13:17         ` Steven Rostedt
2025-07-11 16:39           ` Greg KH
2025-07-11 17:32             ` Steven Rostedt
2025-07-11 18:24               ` Greg KH
2025-07-11 18:28                 ` Steven Rostedt
2025-07-15 14:34             ` Steven Rostedt
2025-07-11 14:02         ` Steven Rostedt
2025-07-11 14:17           ` Mathieu Desnoyers
2025-07-11 18:10           ` dan.j.williams
2025-07-11 18:21             ` Steven Rostedt
2025-07-14  6:40             ` Christoph Hellwig [this message]
2025-07-11 17:22         ` James Bottomley
2025-07-14  6:39       ` Christoph Hellwig
2025-07-14 10:27         ` Steven Rostedt
2025-07-14 11:38           ` Christoph Hellwig
2025-07-14 11:54             ` Steven Rostedt
2025-07-14 11:59               ` Greg KH
2025-07-14 12:20                 ` Steven Rostedt
2025-07-14 12:26                   ` Steven Rostedt
2025-07-14 13:26                   ` Greg KH
2025-07-14 13:35                     ` Steven Rostedt
2025-07-14 13:56                       ` Greg KH
2025-07-14 14:05                         ` Steven Rostedt
2025-07-14 13:43                     ` Arjan van de Ven
2025-07-14 12:02               ` Steven Rostedt
2025-07-15  7:19               ` Christoph Hellwig
2025-07-15  9:26                 ` Steven Rostedt
2025-07-09 21:25 ` [RFC PATCH 3/5] unwind deferred: Introduce unwind_user_trace_cached Mathieu Desnoyers
2025-07-11  7:37   ` Christoph Hellwig
2025-07-09 21:25 ` [RFC PATCH 4/5] unwind: Rename unwind_stacktrace to unwind_user_stacktrace Mathieu Desnoyers
2025-07-09 21:41   ` Steven Rostedt
2025-07-10 21:32     ` Steven Rostedt
2025-07-09 21:25 ` [RFC PATCH 5/5] unwind: Introduce unwind user entry type Mathieu Desnoyers

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aHSmQ0AcZA-FUk4M@infradead.org \
    --to=hch@infradead.org \
    --cc=akpm@linux-foundation.org \
    --cc=andrii@kernel.org \
    --cc=beaub@linux.microsoft.com \
    --cc=dan.j.williams@intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=indu.bhagat@oracle.com \
    --cc=jemarch@gnu.org \
    --cc=jolsa@kernel.org \
    --cc=jpoimboe@kernel.org \
    --cc=jremus@linux.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.desnoyers@efficios.com \
    --cc=mhiramat@kernel.org \
    --cc=mingo@kernel.org \
    --cc=namhyung@kernel.org \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=tech-board-discuss@lists.linuxfoundation.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®