mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Ray Lee" <ray-lk@madrabbit.org>
To: "Brett Warden" <brett.warden@gmail.com>
Cc: linux-kernel@vger.kernel.org, trivial@kernel.org
Subject: Re: [PATCH] bw-qcam: use data_reverse instead of manually poking the control register
Date: Wed, 26 Sep 2007 14:00:00 -0700	[thread overview]
Message-ID: <2c0942db0709261400l10ef6c3ft2d73d8b2ada4a04@mail.gmail.com> (raw)
In-Reply-To: <a372714f0709261306q714100e3t643b31d8f194de2e@mail.gmail.com>

On 9/26/07, Brett Warden <brett.warden@gmail.com> wrote:
> On 9/26/07, Ray Lee <ray-lk@madrabbit.org> wrote:
>
> > Just as an aside, if you've tested this and it works, then there's no
> > point to keep the write_lpcontrol even as a comment. Kill those four
> > lines, and if someone's interested in what happened they'll just look
> > at the file history.
>
> Point taken, thanks for the feedback.
>
> ---
>
> diff --git a/drivers/media/video/bw-qcam.c b/drivers/media/video/bw-qcam.c
> index 7d47cbe..0ba92e3 100644
> --- a/drivers/media/video/bw-qcam.c
> +++ b/drivers/media/video/bw-qcam.c
> @@ -107,6 +107,11 @@ static inline void write_lpcontrol(struct
> qcam_device *q, int d)
>         parport_write_control(q->pport, d);
>  }
>
> +static inline void reverse_port(struct qcam_device *q)
> +{
> +       parport_data_reverse(q->pport);
> +}
> +
>  static int qc_waithand(struct qcam_device *q, int val);
>  static int qc_command(struct qcam_device *q, int command);
>  static int qc_readparam(struct qcam_device *q);
> @@ -369,7 +374,7 @@ static void qc_reset(struct qcam_device *q)
>                         break;
>
>                 case QC_ANY:
> -                       write_lpcontrol(q, 0x20);
> +                       reverse_port(q);
>                         write_lpdata(q, 0x75);
>
>                         if (read_lpdata(q) != 0x75) {
> @@ -512,10 +517,12 @@ static inline int qc_readbytes(struct
> qcam_device *q, char buffer[])
>         switch (q->port_mode & QC_MODE_MASK)
>         {
>                 case QC_BIDIR:          /* Bi-directional Port */
> -                       write_lpcontrol(q, 0x26);
> +                       reverse_port(q);
> +                       write_lpcontrol(q, 0x6);
>                         lo = (qc_waithand2(q, 1) >> 1);
>                         hi = (read_lpstatus(q) >> 3) & 0x1f;
> -                       write_lpcontrol(q, 0x2e);
> +                       reverse_port(q);
> +                       write_lpcontrol(q, 0xe);
>                         lo2 = (qc_waithand2(q, 0) >> 1);
>                         hi2 = (read_lpstatus(q) >> 3) & 0x1f;
>                         switch (q->bpp)
> @@ -613,10 +620,13 @@ static long qc_capture(struct qcam_device * q,
> char __user *buf, unsigned long l
>
>         if ((q->port_mode & QC_MODE_MASK) == QC_BIDIR)
>         {
> -               write_lpcontrol(q, 0x2e);       /* turn port around */
> -               write_lpcontrol(q, 0x26);
> +               reverse_port(q);                        /* turn port around */
> +               write_lpcontrol(q, 0xe);
> +               reverse_port(q);
> +               write_lpcontrol(q, 0x6);
>                 (void) qc_waithand(q, 1);
> -               write_lpcontrol(q, 0x2e);
> +               reverse_port(q);
> +               write_lpcontrol(q, 0xe);
>                 (void) qc_waithand(q, 0);
>         }

Better, and do you have time for two (possibly stupid) questions? In
each of the last cases it looks like the transformation is from a
write_lpcontrol -> reverse_port and a write_lpcontrol (old address -
0x20). Except the first one, which merely has the reverse_port. One
would think that there should be a write_lpcontrol(q, 0x0); after that
one.

Also, is the reverse port sticky, or does it only apply to the next
write? If it's only the next, then maybe a different name would be
better. If it's sticky, then I think the code is wrong...

Ray

  reply	other threads:[~2007-09-26 21:00 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-09-26 19:12 Brett Warden
2007-09-26 19:43 ` Ray Lee
2007-09-26 20:06   ` Brett Warden
2007-09-26 21:00     ` Ray Lee [this message]
2007-09-26 21:43       ` Brett Warden
2007-09-27 19:28         ` Brett Warden
2007-09-27 21:29           ` Alan Cox
2007-09-26 21:00 ` Randy Dunlap

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2c0942db0709261400l10ef6c3ft2d73d8b2ada4a04@mail.gmail.com \
    --to=ray-lk@madrabbit.org \
    --cc=brett.warden@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=trivial@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®