From: "Ken'ichi Ohmichi" <oomichi@mxs.nes.nec.co.jp>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Adrian Bunk <bunk@kernel.org>,
kexec-ml <kexec@lists.infradead.org>,
lkml <linux-kernel@vger.kernel.org>
Subject: [PATCH 0/4] [-mm patch] Cleanup add-vmcoreinfo.patch v2
Date: Fri, 14 Sep 2007 11:49:13 +0900 [thread overview]
Message-ID: <46E9F6A9.8060500@mxs.nes.nec.co.jp> (raw)
Hi Andrew,
I updated the cleanup patchset for add-vmcoreinfo.patch.
* Cleanup add-vmcoreinfo.patch v1:
http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/0318.html
This patchset (v2) includes a new patch[4/4] for adding a prefix
"VMCOREINFO_" to the vmcoreinfo macros. Other patches ([1/4]-[3/4])
don't have any changes.
Changelog:
- Add "Add a prefix VMCOREINFO_ to the vmcoreinfo macros" patch.
Patchset:
[1/4] Cleanup the coding style according to Andrew's comments:
http://lists.infradead.org/pipermail/kexec/2007-August/000522.html
- vmcoreinfo_append_str() should have suitable __attribute__s so that
the compiler can check its use.
- vmcoreinfo_max_size should have size_t.
- Use get_seconds() instead of xtime.tv_sec.
- Use init_uts_ns.name.release instead of UTS_RELEASE.
[2/4] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data.
The dump filetering command 'makedumpfile'(v1.1.6 or before) had assumed
the above values, and it was not good from the reliability viewpoint.
So makedumpfile v1.2.0 came to need these values and I created the patch
to let the kernel output them.
makedumpfile site:
https://sourceforge.net/projects/makedumpfile/
[3/4] Use the existing ia64_tpa() instead of asm code.
[4/4] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros.
Old vmcoreinfo macros were defined as generic names SYMBOL/SIZE/OFFSET
/LENGTH/CONFIG, and it is impossible to grep for them. So these names
should be changed. This discussion is the following:
http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/0415.html
Thanks
Ken'ichi Ohmichi
next reply other threads:[~2007-09-14 2:49 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-09-14 2:49 Ken'ichi Ohmichi [this message]
2007-09-14 2:53 ` [PATCH 1/4] [-mm patch] Cleanup the coding style according to Andrew's comments Ken'ichi Ohmichi
2007-09-14 2:56 ` [PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data Ken'ichi Ohmichi
2007-09-14 3:36 ` David Rientjes
2007-09-20 5:16 ` Ken'ichi Ohmichi
2007-09-14 2:58 ` [PATCH 3/4] [-mm patch] Use the existing ia64_tpa() instead of asm code Ken'ichi Ohmichi
2007-09-14 3:00 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
2007-09-15 2:03 ` Andrew Morton
2007-09-20 5:28 ` Ken'ichi Ohmichi
2007-09-20 5:30 ` [PATCH 5/4] [-mm patch] Rename macros returning the size Ken'ichi Ohmichi
2007-09-20 12:21 ` Satyam Sharma
2007-09-20 18:40 ` David Rientjes
2007-09-25 8:49 ` Ken'ichi Ohmichi
2007-09-20 5:32 ` [PATCH 6/4] [-mm patch] use the existing offsetof() Ken'ichi Ohmichi
2007-09-20 12:28 ` Satyam Sharma
2007-09-25 8:50 ` Ken'ichi Ohmichi
2007-09-25 8:59 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=46E9F6A9.8060500@mxs.nes.nec.co.jp \
--to=oomichi@mxs.nes.nec.co.jp \
--cc=akpm@linux-foundation.org \
--cc=bunk@kernel.org \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®