From: "Ken'ichi Ohmichi" <oomichi@mxs.nes.nec.co.jp>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Adrian Bunk <bunk@kernel.org>,
kexec-ml <kexec@lists.infradead.org>,
lkml <linux-kernel@vger.kernel.org>,
David Rientjes <rientjes@google.com>,
Joe Perches <joe@perches.com>
Subject: [PATCH 5/4] [-mm patch] Rename macros returning the size.
Date: Thu, 20 Sep 2007 14:30:22 +0900 [thread overview]
Message-ID: <46F2056E.6080601@mxs.nes.nec.co.jp> (raw)
In-Reply-To: <46F204FD.6040303@mxs.nes.nec.co.jp>
[PATCH 5/4] [-mm patch] Rename macros returning the size.
The #define SIZE() should be renamed STRUCT_SIZE() since it's always
returning the size of the struct with a given name. This would allow
TYPEDEF_SIZE() to simply become SIZE() since it need not be used
exclusively for typedefs. This idea is David Rientjes's.
http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/1964.html
Thanks
Ken'ichi Ohmichi
---
Signed-off-by: David Rientjes <rientjes@google.com>
Signed-off-by: Ken'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp>
---
diff -rpuN a/arch/ia64/kernel/machine_kexec.c b/arch/ia64/kernel/machine_kexec.c
--- a/arch/ia64/kernel/machine_kexec.c 2007-09-18 15:22:19.000000000 +0900
+++ b/arch/ia64/kernel/machine_kexec.c 2007-09-18 15:22:41.000000000 +0900
@@ -137,7 +137,7 @@ void arch_crash_save_vmcoreinfo(void)
VMCOREINFO_SYMBOL(node_memblk);
VMCOREINFO_LENGTH(node_memblk, NR_NODE_MEMBLKS);
- VMCOREINFO_SIZE(node_memblk_s);
+ VMCOREINFO_STRUCT_SIZE(node_memblk_s);
VMCOREINFO_OFFSET(node_memblk_s, start_paddr);
VMCOREINFO_OFFSET(node_memblk_s, size);
#endif
diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h
--- a/include/linux/kexec.h 2007-09-18 15:22:19.000000000 +0900
+++ b/include/linux/kexec.h 2007-09-18 15:23:22.000000000 +0900
@@ -131,10 +131,10 @@ unsigned long paddr_vmcoreinfo_note(void
vmcoreinfo_append_str("SYMBOL(%s)=%lx\n", #name, (unsigned long)&name)
#define VMCOREINFO_SIZE(name) \
vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
- (unsigned long)sizeof(struct name))
-#define VMCOREINFO_TYPEDEF_SIZE(name) \
- vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
(unsigned long)sizeof(name))
+#define VMCOREINFO_STRUCT_SIZE(name) \
+ vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
+ (unsigned long)sizeof(struct name))
#define VMCOREINFO_OFFSET(name, field) \
vmcoreinfo_append_str("OFFSET(%s.%s)=%lu\n", #name, #field, \
(unsigned long)&(((struct name *)0)->field))
diff -rpuN a/kernel/kexec.c b/kernel/kexec.c
--- a/kernel/kexec.c 2007-09-18 15:22:19.000000000 +0900
+++ b/kernel/kexec.c 2007-09-18 15:22:41.000000000 +0900
@@ -1210,15 +1210,15 @@ static int __init crash_save_vmcoreinfo_
#ifdef CONFIG_SPARSEMEM
VMCOREINFO_SYMBOL(mem_section);
VMCOREINFO_LENGTH(mem_section, NR_SECTION_ROOTS);
- VMCOREINFO_SIZE(mem_section);
+ VMCOREINFO_STRUCT_SIZE(mem_section);
VMCOREINFO_OFFSET(mem_section, section_mem_map);
#endif
- VMCOREINFO_SIZE(page);
- VMCOREINFO_SIZE(pglist_data);
- VMCOREINFO_SIZE(zone);
- VMCOREINFO_SIZE(free_area);
- VMCOREINFO_SIZE(list_head);
- VMCOREINFO_TYPEDEF_SIZE(nodemask_t);
+ VMCOREINFO_STRUCT_SIZE(page);
+ VMCOREINFO_STRUCT_SIZE(pglist_data);
+ VMCOREINFO_STRUCT_SIZE(zone);
+ VMCOREINFO_STRUCT_SIZE(free_area);
+ VMCOREINFO_STRUCT_SIZE(list_head);
+ VMCOREINFO_SIZE(nodemask_t);
VMCOREINFO_OFFSET(page, flags);
VMCOREINFO_OFFSET(page, _count);
VMCOREINFO_OFFSET(page, mapping);
_
next prev parent reply other threads:[~2007-09-20 5:31 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-09-14 2:49 [PATCH 0/4] [-mm patch] Cleanup add-vmcoreinfo.patch v2 Ken'ichi Ohmichi
2007-09-14 2:53 ` [PATCH 1/4] [-mm patch] Cleanup the coding style according to Andrew's comments Ken'ichi Ohmichi
2007-09-14 2:56 ` [PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data Ken'ichi Ohmichi
2007-09-14 3:36 ` David Rientjes
2007-09-20 5:16 ` Ken'ichi Ohmichi
2007-09-14 2:58 ` [PATCH 3/4] [-mm patch] Use the existing ia64_tpa() instead of asm code Ken'ichi Ohmichi
2007-09-14 3:00 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
2007-09-15 2:03 ` Andrew Morton
2007-09-20 5:28 ` Ken'ichi Ohmichi
2007-09-20 5:30 ` Ken'ichi Ohmichi [this message]
2007-09-20 12:21 ` [PATCH 5/4] [-mm patch] Rename macros returning the size Satyam Sharma
2007-09-20 18:40 ` David Rientjes
2007-09-25 8:49 ` Ken'ichi Ohmichi
2007-09-20 5:32 ` [PATCH 6/4] [-mm patch] use the existing offsetof() Ken'ichi Ohmichi
2007-09-20 12:28 ` Satyam Sharma
2007-09-25 8:50 ` Ken'ichi Ohmichi
2007-09-25 8:59 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=46F2056E.6080601@mxs.nes.nec.co.jp \
--to=oomichi@mxs.nes.nec.co.jp \
--cc=akpm@linux-foundation.org \
--cc=bunk@kernel.org \
--cc=joe@perches.com \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rientjes@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®