From: "Ken'ichi Ohmichi" <oomichi@mxs.nes.nec.co.jp>
To: David Rientjes <rientjes@google.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Adrian Bunk <bunk@kernel.org>,
kexec-ml <kexec@lists.infradead.org>,
lkml <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data.
Date: Thu, 20 Sep 2007 14:16:35 +0900 [thread overview]
Message-ID: <46F20233.1040209@mxs.nes.nec.co.jp> (raw)
In-Reply-To: <alpine.DEB.0.9999.0709132034540.30494@chino.kir.corp.google.com>
Hi David,
David Rientjes wrote:
> On Fri, 14 Sep 2007, Ken'ichi Ohmichi wrote:
>
>> diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h
>> --- a/include/linux/kexec.h 2007-09-10 23:28:42.000000000 +0900
>> +++ b/include/linux/kexec.h 2007-09-10 23:29:52.000000000 +0900
>> @@ -132,11 +132,16 @@ unsigned long paddr_vmcoreinfo_note(void
>> #define SIZE(name) \
>> vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
>> (unsigned long)sizeof(struct name))
>> +#define TYPEDEF_SIZE(name) \
>> + vmcoreinfo_append_str("SIZE(%s)=%lu\n", #name, \
>> + (unsigned long)sizeof(name))
>> #define OFFSET(name, field) \
>> vmcoreinfo_append_str("OFFSET(%s.%s)=%lu\n", #name, #field, \
>> (unsigned long)&(((struct name *)0)->field))
>> #define LENGTH(name, value) \
>> vmcoreinfo_append_str("LENGTH(%s)=%lu\n", #name, (unsigned long)value)
>> +#define NUMBER(name) \
>> + vmcoreinfo_append_str("NUMBER(%s)=%ld\n", #name, (long)name)
>> #define CONFIG(name) \
>> vmcoreinfo_append_str("CONFIG_%s=y\n", #name)
>>
>
> The #define SIZE() should be renamed STRUCT_SIZE() since it's always returning the size of the struct with a given name. This would allow TYPEDEF_SIZE() to simply become SIZE() since it need not be used exclusively for typedefs.
Thank you for the comment.
That sounds good, I'll post a new patch including it.
Thanks
Ken'ichi Ohmichi
next prev parent reply other threads:[~2007-09-20 5:17 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-09-14 2:49 [PATCH 0/4] [-mm patch] Cleanup add-vmcoreinfo.patch v2 Ken'ichi Ohmichi
2007-09-14 2:53 ` [PATCH 1/4] [-mm patch] Cleanup the coding style according to Andrew's comments Ken'ichi Ohmichi
2007-09-14 2:56 ` [PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data Ken'ichi Ohmichi
2007-09-14 3:36 ` David Rientjes
2007-09-20 5:16 ` Ken'ichi Ohmichi [this message]
2007-09-14 2:58 ` [PATCH 3/4] [-mm patch] Use the existing ia64_tpa() instead of asm code Ken'ichi Ohmichi
2007-09-14 3:00 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
2007-09-15 2:03 ` Andrew Morton
2007-09-20 5:28 ` Ken'ichi Ohmichi
2007-09-20 5:30 ` [PATCH 5/4] [-mm patch] Rename macros returning the size Ken'ichi Ohmichi
2007-09-20 12:21 ` Satyam Sharma
2007-09-20 18:40 ` David Rientjes
2007-09-25 8:49 ` Ken'ichi Ohmichi
2007-09-20 5:32 ` [PATCH 6/4] [-mm patch] use the existing offsetof() Ken'ichi Ohmichi
2007-09-20 12:28 ` Satyam Sharma
2007-09-25 8:50 ` Ken'ichi Ohmichi
2007-09-25 8:59 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=46F20233.1040209@mxs.nes.nec.co.jp \
--to=oomichi@mxs.nes.nec.co.jp \
--cc=akpm@linux-foundation.org \
--cc=bunk@kernel.org \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rientjes@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome